summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLone_Wolf2021-08-27 14:56:28 +0200
committerLone_Wolf2021-08-27 14:56:28 +0200
commit78b68a85a5570d3fcb8ef1bcf46122a372e536d2 (patch)
treef118338f1d0d556f05a228a3275b224df310b39d
parente0e963f5303aaa13c53a83f7f9b805c658dc3e41 (diff)
downloadaur-78b68a85a5570d3fcb8ef1bcf46122a372e536d2.tar.gz
PKGBUILD now uses user-set CFLAGS, tried to clarify optdepends
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD15
2 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3d9bc6cdbab..21de33ac9e6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cnrdrvcups-lb
pkgdesc = CUPS Canon UFR II LIPSLX CARPS2 printer driver for LBP iR MF ImageCLASS ImageRUNNER Laser Shot i-SENSYS ImagePRESS ADVANCE printers and copiers
pkgver = 5.40
- pkgrel = 2
+ pkgrel = 3
url = https://www.canon-europe.com/support/products/imagerunner/imagerunner-1730i.aspx
arch = x86_64
license = GPL2
@@ -13,7 +13,8 @@ pkgbase = cnrdrvcups-lb
depends = gcc-libs
depends = libxml2
depends = libglade
- optdepends = libjpeg6-turbo: improves printing results for color imageRUNNER/i-SENSYS LBP devices
+ optdepends = libjpeg6-turbo: solves cpu hang on some color imageRUNNER/i-SENSYS LBP devices
+ optdepends = llibjbig-shared: port of debian/fedora specific jbigkit funtionality that can prevent cpu hangs on some models
optdepends = gtk2: for cnsetuputil2
conflicts = cndrvcups-lb
conflicts = cndrvcups-common-lb
diff --git a/PKGBUILD b/PKGBUILD
index cd54ca6fb717..76370bde2c59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ pkgname='cnrdrvcups-lb'
_pkgver='5.40'; _dl='8/0100007658/25';_suffix='08'
pkgver="${_pkgver}"
-pkgrel='2'
+pkgrel='3'
pkgdesc='CUPS Canon UFR II LIPSLX CARPS2 printer driver for LBP iR MF ImageCLASS ImageRUNNER Laser Shot i-SENSYS ImagePRESS ADVANCE printers and copiers'
arch=('x86_64')
# Direct links to the download reference go bad on the next version. We want something that will persist for a while.
@@ -19,7 +19,8 @@ license=('GPL2' 'MIT' 'custom')
# parts of the code are GPL or MIT licensed, some parts have a custom license
makedepends=('jbigkit' 'gzip' 'gtk2')
depends=('gcc-libs' 'libxml2' 'libglade')
-optdepends=('libjpeg6-turbo: improves printing results for color imageRUNNER/i-SENSYS LBP devices'
+optdepends=('libjpeg6-turbo: solves cpu hang on some color imageRUNNER/i-SENSYS LBP devices'
+ 'llibjbig-shared: port of debian/fedora specific jbigkit funtionality that can prevent cpu hangs on some models'
'gtk2: for cnsetuputil2')
@@ -111,7 +112,8 @@ prepare() {
_setvars() {
# variables used by the (generated) make.Arch & make.install.Arch files
# relative paths start at ${srcdir}/${_srcdir}
-
+ # _libsarch is architecture dependent
+
_vars=(
_builddir="${srcdir}/${_srcdir}"
common_dir="${_common_dir}"
@@ -120,7 +122,7 @@ _setvars() {
RPM_BUILD_DIR="${srcdir}/${_srcdir}"
_prefix='/usr'
_machine_type="MACHINETYPE="$CARCH
- _cflags="CFLAGS=-march=x86-64 -O2 -pipe -fno-plt"
+ _cflags="CFLAGS=""$CFLAGS"
_libdir='/usr/lib'
_bindir='/usr/bin'
locallibs='/usr/lib/'
@@ -130,11 +132,6 @@ _setvars() {
_libsarch='libs64/intel'
nobuild=0
)
-
-# -fcommon is needed to compile succesfully with gcc10 , see https://gcc.gnu.org/gcc-10/porting_to.html
-# -O2 -pipe -fno-plt are taken from makepkg.conf default for archlinux
-# _libsarch is architecture dependent
-
}
build() {