summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2024-02-02 23:19:42 -0500
committerChris Severance2024-02-02 23:19:42 -0500
commit1fe1983f1c828db17696a446d1761b61a1d527fa (patch)
treeae94b25459280170a0203bd0fb0cf0c80e83a24e
parentaac7f61f45cb50661db2633e779997eab0249c28 (diff)
downloadaur-cnrdrvcups-lb-bin.tar.gz
autu: Update to 5.80.04-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD18
2 files changed, 23 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c771f131dca..3dcf2eedaee3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,29 @@
pkgbase = cnrdrvcups-lb-bin
pkgdesc = CUPS Canon UFR II LIPSLX CARPS2 printer driver for LBP iR MF ImageCLASS ImageRUNNER Laser Shot i-SENSYS ImagePRESS ADVANCE printers and copiers
- pkgver = 5.70.13
+ pkgver = 5.80.04
pkgrel = 1
url = https://www.canon-europe.com/support/products/imagerunner/imagerunner-1730i.aspx
arch = x86_64
arch = aarch64
- license = GPL2
+ license = GPL-2.0-only
license = MIT
license = custom
makedepends = jbigkit
makedepends = gzip
makedepends = gtk3
+ depends = libcups
+ depends = glibc
depends = gcc-libs
depends = libxml2
optdepends = libjpeg6-turbo: solves cpu hang on some color imageRUNNER/i-SENSYS LBP devices
+ optdepends = jbigkit: solves some cpu hangs
optdepends = libjbig-shared: port of debian/fedora specific jbigkit functionality that can prevent cpu hangs on some models
optdepends = ghostscript: necessary for printing on some devices
optdepends = gtk3: for cnsetuputil2
- provides = cnrdrvcups-lb=5.70
+ optdepends = gdk-pixbuf2: for cnsetuputil2
+ optdepends = cairo: for cnsetuputil2
+ optdepends = pango: for cnsetuputil2
+ provides = cnrdrvcups-lb=5.80
conflicts = cndrvcups-lb
conflicts = cndrvcups-common-lb
conflicts = cndrvcups-lb-bin
@@ -25,9 +31,8 @@ pkgbase = cnrdrvcups-lb-bin
options = !emptydirs
options = !strip
options = !libtool
- source = http://gdlp01.c-wss.com/gds/8/0100007658/34/linux-UFRII-drv-v570-m17n-13.tar.gz
- md5sums = 7ac8db8dbe6ea19058bce0b2275e185f
- sha256sums = 753a7bb324a109890cedd3455d04663caff40548a82c07477ef8f2b1a20707fd
- sha512sums = 57197570456675dc80c7a40f1c99fcdb00f9af2ce9742c2e23ad6ef74cc748cdad825679897b4ebedbf24189f60267952871422d862f8cbd1be77ea6da44183f
+ source = http://gdlp01.c-wss.com/gds/8/0100007658/38/linux-UFRII-drv-v580-m17n-04.tar.gz
+ md5sums = f21fc68223967a5897ba52fd7942ced7
+ sha512sums = c040a636223da374d342c915ecee8de5d3689786430ada9da6b2660f6467290cb23ededc02d1509cafbec86fbfe19a5631a68cfb0b4f2cfd8fff6c2a50ea4724
pkgname = cnrdrvcups-lb-bin
diff --git a/PKGBUILD b/PKGBUILD
index 9210bb2519f1..b45ddd567e21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,21 +25,26 @@ pkgname="${pkgbase}"
#_pkgver='5.60'; _dl='8/0100007658/30';_suffix1='m17n';_suffix2='08'
#_pkgver='5.60'; _dl='8/0100007658/31';_suffix1='m17n';_suffix2='10'
#_pkgver='5.70'; _dl='8/0100007658/33';_suffix1='m17n';_suffix2='11'
-_pkgver='5.70'; _dl='8/0100007658/34';_suffix1='m17n';_suffix2='13'
+#_pkgver='5.70'; _dl='8/0100007658/34';_suffix1='m17n';_suffix2='13'
+_pkgver='5.80'; _dl='8/0100007658/38';_suffix1='m17n';_suffix2='04'
pkgver="${_pkgver}.${_suffix2}"
-pkgrel='1'
+pkgrel=1
pkgdesc='CUPS Canon UFR II LIPSLX CARPS2 printer driver for LBP iR MF ImageCLASS ImageRUNNER Laser Shot i-SENSYS ImagePRESS ADVANCE printers and copiers'
arch=('x86_64' 'aarch64')
# Direct links to the download reference go bad on the next version. We want something that will persist for a while.
url='https://www.canon-europe.com/support/products/imagerunner/imagerunner-1730i.aspx'
-license=('GPL2' 'MIT' 'custom')
+license=('GPL-2.0-only' 'MIT' 'custom')
# parts of the code are GPL or MIT licensed, some parts have a custom license
-depends=('gcc-libs' 'libxml2')
+depends=('libcups' 'glibc' 'gcc-libs' 'libxml2')
optdepends=(
'libjpeg6-turbo: solves cpu hang on some color imageRUNNER/i-SENSYS LBP devices'
+ 'jbigkit: solves some cpu hangs'
'libjbig-shared: port of debian/fedora specific jbigkit functionality that can prevent cpu hangs on some models'
'ghostscript: necessary for printing on some devices'
'gtk3: for cnsetuputil2'
+ 'gdk-pixbuf2: for cnsetuputil2'
+ 'cairo: for cnsetuputil2'
+ 'pango: for cnsetuputil2'
)
makedepends=('jbigkit' 'gzip' 'gtk3')
provides=("cnrdrvcups-lb=${_pkgver}")
@@ -49,9 +54,8 @@ options=('!emptydirs' '!strip' '!libtool')
source=(
"http://gdlp01.c-wss.com/gds/${_dl}/linux-UFRII-drv-v${_pkgver//\./}-${_suffix1}-${_suffix2}.tar.gz"
)
-md5sums=('7ac8db8dbe6ea19058bce0b2275e185f')
-sha256sums=('753a7bb324a109890cedd3455d04663caff40548a82c07477ef8f2b1a20707fd')
-sha512sums=('57197570456675dc80c7a40f1c99fcdb00f9af2ce9742c2e23ad6ef74cc748cdad825679897b4ebedbf24189f60267952871422d862f8cbd1be77ea6da44183f')
+md5sums=('f21fc68223967a5897ba52fd7942ced7')
+sha512sums=('c040a636223da374d342c915ecee8de5d3689786430ada9da6b2660f6467290cb23ededc02d1509cafbec86fbfe19a5631a68cfb0b4f2cfd8fff6c2a50ea4724')
build() {
set -u