summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2018-11-04 13:31:38 +0800
committerJingbei Li2018-11-04 13:31:38 +0800
commit0d088cb4e45235a6cebf68f02b7a3aa4277dc9a1 (patch)
treeb5e12d1b6a998e444c500737ffba34ea1df3534c
parent2a2e00c8270b9c1fa02f3b14ce0af686b2e1f124 (diff)
downloadaur-0d088cb4e45235a6cebf68f02b7a3aa4277dc9a1.tar.gz
upgraded to 2.6
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD37
2 files changed, 20 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1efbd7e7bc5e..b4785e09a7dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
pkgbase = cntk
pkgdesc = Microsoft Cognitive Toolkit (CNTK), an open source deep-learning toolkit
- pkgver = 2.5.1
- pkgrel = 2
+ pkgver = 2.6
+ pkgrel = 1
url = https://github.com/Microsoft/CNTK
arch = x86_64
license = CUSTOM
makedepends = cmake
makedepends = git
makedepends = inetutils
- makedepends = java-environment
makedepends = python-pip
makedepends = python-setuptools
makedepends = python-wheel
makedepends = swig
- depends = gcc6
depends = boost
depends = cub
depends = cuda
@@ -25,12 +23,11 @@ pkgbase = cntk
depends = opencv
depends = openmp
depends = openmpi
- depends = protobuf
+ depends = protobuf-static
depends = python-numpy
depends = python-scipy
optdepends = swig
- optdepends = java-environment
- source = git+https://github.com/Microsoft/CNTK#tag=v2.5.1
+ source = git+https://github.com/Microsoft/CNTK#tag=v2.6
md5sums = SKIP
pkgname = cntk
diff --git a/PKGBUILD b/PKGBUILD
index af6a5ed84ad5..72d5ce7ae72f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Jingbei Li <i@jingbei.li>
pkgname=cntk
_gitname=CNTK
-pkgver=2.5.1
-pkgrel=2
+pkgver=2.6
+pkgrel=1
pkgdesc="Microsoft Cognitive Toolkit (CNTK), an open source deep-learning toolkit"
arch=('x86_64')
url="https://github.com/Microsoft/$_gitname"
license=('CUSTOM')
-depends=('gcc6' 'boost' 'cub' 'cuda' 'cudnn' 'libzip' 'nccl' 'nvidia-utils' 'openblas-lapack' 'opencv' 'openmp' 'openmpi' 'protobuf' 'python-numpy' 'python-scipy')
-makedepends=('cmake' 'git' 'inetutils' 'java-environment' 'python-pip' 'python-setuptools' 'python-wheel' 'swig')
-optdepends=('swig' 'java-environment')
+depends=('boost' 'cub' 'cuda' 'cudnn' 'libzip' 'nccl' 'nvidia-utils' 'openblas-lapack' 'opencv' 'openmp' 'openmpi' 'protobuf-static' 'python-numpy' 'python-scipy')
+makedepends=('cmake' 'git' 'inetutils' 'python-pip' 'python-setuptools' 'python-wheel' 'swig')
+optdepends=('swig')
source=("git+$url#tag=v$pkgver")
md5sums=('SKIP')
@@ -18,8 +18,8 @@ prepare(){
git submodule update --init --recursive
sed \
- -e 's|libprotobuf.a|libprotobuf.so|' \
-e 's|cuda/include/cudnn.h|include/cudnn.h|' \
+ -e 's/36/37/g' \
-i configure
# https://github.com/Microsoft/CNTK/issues/62
@@ -28,32 +28,28 @@ prepare(){
# https://github.com/Microsoft/CNTK/issues/3191
sed '120s/.*/return cub::ShuffleIndex<CUB_PTX_WARP_THREADS>(input, srcLane, mask);/' -i Source/Math/CntkBatchNormalization.cuh
+ # CUDA 10
+ sed 's|device_functions.h|cuda_runtime_api.h|' -i Source/Math/GPUMatrixCUDAKernels.cuh
+
mkdir -p build
- export OMPI_MPICXX=g++-6
+ export OMPI_MPICXX=g++-7
./configure \
--with-build-top=build \
- --with-jdk=/usr/lib/jvm/default \
--with-openblas \
--with-opencv \
- --with-py36-path \
+ --with-py37-path \
--with-cuda=/opt/cuda \
--with-cub=/usr/include \
--with-gdk-include=/opt/cuda/include \
--with-gdk-nvml-lib=/opt/cuda/lib64/stubs \
--with-cudnn=/opt/cuda \
- --with-nccl=/opt/cuda \
+ --with-nccl=/usr \
--with-swig
#--with-kaldi=/opt/kaldi \
sed \
- -e 's| $(PROTOBUF_PATH)/lib/libprotobuf.a| -lprotobuf|' \
-e 's|$(CUDNN_PATH)/cuda|$(CUDNN_PATH)|g'\
- -e '/DOpenMP/s/""/"-fopenmp"/g' \
- -e '/DOpenMP_C_FLAGS/a\\t\t-DMPI_LIBRARY="/usr/include" \\' \
- -e '/DOpenMP_C_FLAGS/a\\t\t-DMPI_LIBRARIES="/usr/include" \\' \
- -e '/DOpenMP_C_FLAGS/a\\t\t-DMPI_CXX_LIBRARIES="/usr/include" \\' \
- -e '/DOpenMP_C_FLAGS/a\\t\t-DMPI_include_LIBRARY="/usr/include" \\' \
+ -e 's/36/37/g'\
-i Makefile
- sed '10,11d' -i Source/Multiverso/Test/CMakeLists.txt
sed \
-e 's|libmpi.so.12|libmpi.so|g' \
-i bindings/python/cntk/train/distributed.py
@@ -61,8 +57,7 @@ prepare(){
build() {
cd $srcdir/$_gitname/build
- make \
- CXXFLAGS='-Wno-sign-compare -fPIC'
+ make CXXFLAGS='-Wno-sign-compare -fPIC'
}
package() {
@@ -71,9 +66,9 @@ package() {
cp -r bin lib $pkgdir/usr
cd $srcdir/$_gitname/build/python
- PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps ${pkgname}_gpu-$pkgver-cp36-cp36m-linux_x86_64.whl
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps ${pkgname}_gpu-$pkgver-cp37-cp37m-linux_x86_64.whl
- rm -rf $pkgdir/usr/lib/python3.6/site-packages/$pkgname/libs
+ rm -rf $pkgdir/usr/lib/python3.7/site-packages/$pkgname/libs
install -Dm644 $srcdir/$_gitname/LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}