summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2018-05-21 02:34:49 +0800
committerJingbei Li2018-05-21 02:34:49 +0800
commit32bca837f0845fb32aa286f49450931d91210742 (patch)
tree7ffc664ab13537010b98f5dca43746d5edb420bd
parentbfd316b9e914c205ed95851ee20e71106ad99c55 (diff)
downloadaur-32bca837f0845fb32aa286f49450931d91210742.tar.gz
upgraded to 2.5.1
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d8773f258b6..7db8ff89f2bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cntk
pkgdesc = Microsoft Cognitive Toolkit (CNTK), an open source deep-learning toolkit
- pkgver = 2.5
+ pkgver = 2.5.1
pkgrel = 1
url = https://github.com/Microsoft/CNTK
arch = x86_64
@@ -13,6 +13,7 @@ pkgbase = cntk
makedepends = python-setuptools
makedepends = python-wheel
makedepends = swig
+ depends = gcc6
depends = boost
depends = cub
depends = cuda
@@ -29,7 +30,7 @@ pkgbase = cntk
depends = python-scipy
optdepends = swig
optdepends = java-environment
- source = git+https://github.com/Microsoft/CNTK#tag=v2.5
+ source = git+https://github.com/Microsoft/CNTK#tag=v2.5.1
md5sums = SKIP
pkgname = cntk
diff --git a/PKGBUILD b/PKGBUILD
index d8064f2ee953..3f3e5d859e86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Jingbei Li <i@jingbei.li>
pkgname=cntk
_gitname=CNTK
-pkgver=2.5
+pkgver=2.5.1
pkgrel=1
pkgdesc="Microsoft Cognitive Toolkit (CNTK), an open source deep-learning toolkit"
arch=('x86_64')
url="https://github.com/Microsoft/$_gitname"
license=('CUSTOM')
-depends=('boost' 'cub' 'cuda' 'cudnn' 'libzip' 'nccl' 'nvidia-utils' 'openblas-lapack' 'opencv' 'openmp' 'openmpi' 'protobuf' 'python-numpy' 'python-scipy')
-makedepends=('cmake' 'git' 'inetutils' 'java-environment' 'python-pip' 'python-setuptools' 'python-wheel' 'swig' )
+depends=('gcc6' 'boost' 'cub' 'cuda' 'cudnn' 'libzip' 'nccl' 'nvidia-utils' 'openblas-lapack' 'opencv' 'openmp' 'openmpi' 'protobuf' 'python-numpy' 'python-scipy')
+makedepends=('cmake' 'git' 'inetutils' 'java-environment' 'python-pip' 'python-setuptools' 'python-wheel' 'swig')
optdepends=('swig' 'java-environment')
source=("git+$url#tag=v$pkgver")
md5sums=('SKIP')
@@ -25,7 +25,11 @@ prepare(){
# https://github.com/Microsoft/CNTK/issues/62
sed 's|/var/lock/|/tmp/cntk/|g' -i `grep '/var/lock' . -rIl`
+ # https://github.com/Microsoft/CNTK/issues/3191
+ sed '120s/.*/return cub::ShuffleIndex<CUB_PTX_WARP_THREADS>(input, srcLane, mask);/' -i Source/Math/CntkBatchNormalization.cuh
+
mkdir -p build
+ export OMPI_MPICXX=g++-6
./configure \
--with-build-top=build \
--with-jdk=/usr/lib/jvm/default \
@@ -69,5 +73,7 @@ package() {
cd $srcdir/$_gitname/build/python
pip install --root=$pkgdir ${pkgname}_gpu-$pkgver-cp36-cp36m-linux_x86_64.whl
+ rm -rf $pkgdir/usr/lib/python3.6/site-packages/$pkgname/libs
+
install -Dm644 $srcdir/$_gitname/LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}