summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2018-07-02 19:38:14 -0400
committerJean Lucas2018-07-02 19:38:14 -0400
commit0a82ed9435017c00a587961d3be86b7dc46529a1 (patch)
tree9bb254a98298b333a0e66de46ab3e9b8c9ce9dd3
parent827c06b6625e37234a0a0f2a46f9e2577eb6729d (diff)
downloadaur-0a82ed9435017c00a587961d3be86b7dc46529a1.tar.gz
Update pkgver() and depends
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b51ded6cc6f6..aa5342c3e0ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Jul 2 22:37:42 UTC 2018
+# Mon Jul 2 23:37:28 UTC 2018
pkgbase = coax
pkgdesc = Barely-working Rust/GTK+ Wire client (insecure)
- pkgver = 0.1.0+123+gfbb9144
+ pkgver = 0+123+gfbb9144
pkgrel = 1
url = https://github.com/wireapp/coax
arch = any
@@ -10,6 +10,10 @@ pkgbase = coax
makedepends = git
makedepends = librsvg
depends = cargo
+ depends = libsodium
+ depends = gtk3
+ depends = openssl
+ depends = sqlite
source = git+https://github.com/wireapp/coax#branch=develop
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 6ed88450d51c..f80b961126ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=coax
-pkgver=0.1.0+123+gfbb9144
+pkgver=0+123+gfbb9144
pkgrel=1
pkgdesc='Barely-working Rust/GTK+ Wire client (insecure)'
arch=(any)
url=https://github.com/wireapp/coax
license=(GPL3)
-depends=(cargo)
+depends=(cargo libsodium gtk3 openssl sqlite)
makedepends=(git librsvg)
source=(git+https://github.com/wireapp/coax#branch=develop)
sha512sums=(SKIP)
pkgver() {
- cd coax/coax-gtk
- echo "$(grep '^version' Cargo.toml | head -n1 | cut -d\" -f2)+$(git rev-list --count HEAD)+g$(git describe --always)"
+ cd coax
+ echo 0+$(git rev-list --count HEAD)+g$(git describe --always)
}
build() {
@@ -25,7 +25,7 @@ build() {
package() {
cd coax
- install -Dm 755 target/release/coax-gtk $pkgdir/usr/bin/coax
+ install -D target/release/coax-gtk $pkgdir/usr/bin/coax
install -Dm 644 LICENSE $pkgdir/usr/share/licenses/coax/LICENSE
cd coax-gtk/src/gtk
install -Dm 644 coax.svg $pkgdir/usr/share/icons/hicolor/scalable/apps/coax.svg