summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2018-07-02 18:38:42 -0400
committerJean Lucas2018-07-02 18:38:42 -0400
commit827c06b6625e37234a0a0f2a46f9e2577eb6729d (patch)
treecb4b6fb30675210ee34e559facc316a0c9874ce4
downloadaur-827c06b6625e37234a0a0f2a46f9e2577eb6729d.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b51ded6cc6f6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Mon Jul 2 22:37:42 UTC 2018
+pkgbase = coax
+ pkgdesc = Barely-working Rust/GTK+ Wire client (insecure)
+ pkgver = 0.1.0+123+gfbb9144
+ pkgrel = 1
+ url = https://github.com/wireapp/coax
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = librsvg
+ depends = cargo
+ source = git+https://github.com/wireapp/coax#branch=develop
+ sha512sums = SKIP
+
+pkgname = coax
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ed88450d51c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Jean Lucas <jean@4ray.co>
+
+pkgname=coax
+pkgver=0.1.0+123+gfbb9144
+pkgrel=1
+pkgdesc='Barely-working Rust/GTK+ Wire client (insecure)'
+arch=(any)
+url=https://github.com/wireapp/coax
+license=(GPL3)
+depends=(cargo)
+makedepends=(git librsvg)
+source=(git+https://github.com/wireapp/coax#branch=develop)
+sha512sums=(SKIP)
+
+pkgver() {
+ cd coax/coax-gtk
+ echo "$(grep '^version' Cargo.toml | head -n1 | cut -d\" -f2)+$(git rev-list --count HEAD)+g$(git describe --always)"
+}
+
+build() {
+ cd coax
+ rustup override set nightly-2018-04-10
+ cargo build --release --features=prod
+}
+
+package() {
+ cd coax
+ install -Dm 755 target/release/coax-gtk $pkgdir/usr/bin/coax
+ install -Dm 644 LICENSE $pkgdir/usr/share/licenses/coax/LICENSE
+ cd coax-gtk/src/gtk
+ install -Dm 644 coax.svg $pkgdir/usr/share/icons/hicolor/scalable/apps/coax.svg
+ rsvg-convert -w 48 -h 48 coax.svg -o coax.png
+ install -Dm 644 coax.png $pkgdir/usr/share/icons/hicolor/48x48/apps/coax.png
+ sed -i s%@bindir@/coax-gtk%/usr/bin/coax% coax.desktop
+ install -Dm 644 coax.desktop $pkgdir/usr/share/applications/coax.desktop
+}