summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrià Arrufat2017-02-27 17:34:00 +0100
committerAdrià Arrufat2017-02-27 17:34:00 +0100
commit3851c9f798309c63ab12f7555174af9fc02eb144 (patch)
treee18f3b2205d4ac5c1f9b500d43ca1551532bc4db
downloadaur-3851c9f798309c63ab12f7555174af9fc02eb144.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD35
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..958cdbee53b6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Mon Feb 27 16:33:40 UTC 2017
+pkgbase = coax-git
+ pkgdesc = A (barely working) native Wire client for Unix
+ pkgver = 0.0.0+20170227+34+ge2979a1
+ pkgrel = 1
+ url = https://github.com/wireapp/coax
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cargo
+ depends = libsodium
+ depends = gtk3
+ depends = openssl
+ depends = sqlite
+ source = git+https://github.com/wireapp/coax.git/
+ sha512sums = SKIP
+
+pkgname = coax-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6643d9e0b3ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Adrià Arrufat <adria.arrufat+AUR AT protonmail DOT ch>
+pkgname=coax-git
+pkgver=0.0.0+20170227+34+ge2979a1
+pkgrel=1
+pkgdesc="A (barely working) native Wire client for Unix"
+arch=('i686' 'x86_64')
+url="https://github.com/wireapp/coax"
+license=('GPL3')
+depends=('libsodium' 'gtk3' 'openssl' 'sqlite')
+makedepends=('cargo')
+source=("git+https://github.com/wireapp/coax.git/")
+sha512sums=('SKIP')
+
+
+pkgver() {
+ cd coax
+ _date=$(git show --format="%cd" --date=format:"%Y%m%d" --no-patch)
+ _count=$(git rev-list --count HEAD)
+ _commit=$(git rev-parse --short HEAD)
+ echo 0.0.0+$_date+$_count+g$_commit
+}
+
+build() {
+ cd "coax/coax-gtk"
+ cargo build --release
+}
+
+package() {
+ cd "coax/coax-gtk"
+ cargo install --force --features=prod --root=$pkgdir/usr
+ install -Dm644 src/gtk/coax.desktop $pkgdir/usr/share/applications/coax.desktop
+ sed -i $pkgdir/usr/share/applications/coax.desktop -e 's/@bindir@/\/usr\/bin/'
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/coax/COPYING"
+ rm $pkgdir/usr/.crates.toml
+}