summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Rossmannek2024-03-17 17:13:01 +0100
committerMax Rossmannek2024-03-17 17:13:01 +0100
commit425a856451812b8ff6bf4924f1f723f9b0709ea3 (patch)
tree47132346c94d38f93b37139ff640fe399c5fb31c
parent7194d5947b38660885a71cbe2a272280cfb05ac8 (diff)
downloadaur-425a856451812b8ff6bf4924f1f723f9b0709ea3.tar.gz
Update tooling
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ef94824046f..54a04db61765 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,14 @@
pkgbase = cobib-git
pkgdesc = Console Bibliography
pkgver = r517.c6d4f59
- pkgrel = 5
+ pkgrel = 6
url = https://gitlab.com/cobib/cobib
arch = any
license = MIT
makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
depends = python-bibtexparser
depends = python-beautifulsoup4
diff --git a/PKGBUILD b/PKGBUILD
index 457005d65dd0..2c1c5e347f89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,11 @@
_pkgname='cobib'
pkgname="${_pkgname}-git"
pkgver=r517.c6d4f59
-pkgrel=5
+pkgrel=6
arch=('any')
depends=('python' 'python-bibtexparser' 'python-beautifulsoup4' 'python-lxml' 'python-ruamel-yaml' 'python-pylatexenc' 'python-requests' 'python-requests-oauthlib' 'python-text-unidecode' 'python-rich' 'python-textual' 'python-markdown-it-py' 'python-mdit_py_plugins' 'python-linkify-it-py')
license=('MIT')
-makedepends=('git')
+makedepends=('git' 'python-build' 'python-installer' 'python-wheel')
provides=('cobib')
conflicts=('cobib')
pkgdesc="Console Bibliography"
@@ -23,13 +23,12 @@ pkgver() {
build() {
cd $srcdir/${_pkgname}
- python3 setup.py build
+ python3 -m build --wheel --no-isolation
}
package() {
cd $srcdir/${_pkgname}
make DESTDIR="${pkgdir}" install_extras
- python3 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python3 -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-