summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalló György2016-08-10 12:00:30 +0200
committerBalló György2016-08-10 12:00:30 +0200
commit0d49a2201e9e731d0576fb3abbff232c8fdf6655 (patch)
tree57e82286f03d13b83325cf5b5e5315c89ff762af
downloadaur-0d49a2201e9e731d0576fb3abbff232c8fdf6655.tar.gz
Add cobra
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
-rw-r--r--install.patch25
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e1211a42b5b4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = cobra
+ pkgdesc = Clean and expressive language for .NET and Mono
+ pkgver = 0.9.6
+ pkgrel = 1
+ url = http://cobra-language.com/
+ arch = any
+ license = MIT
+ depends = mono
+ options = !strip
+ source = http://cobra-language.com/downloads/Cobra-0.9.6.tar.gz
+ source = install.patch
+ sha256sums = 9f1e496520bad124f5d827aa35d7a591c412fbb4c41633ecb00e68fbb35457fa
+ sha256sums = SKIP
+
+pkgname = cobra
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e2831ecc57c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: Paul Dufrese <dufresnep@gmail.com>
+# Contributor: spider-mario <spidermario@free.fr>
+# Contributor: Johannes Krampf <mail@johkra.de>
+
+pkgname=cobra
+pkgver=0.9.6
+pkgrel=1
+pkgdesc="Clean and expressive language for .NET and Mono"
+arch=('any')
+options=('!strip')
+url="http://cobra-language.com/"
+license=('MIT')
+depends=(mono)
+source=(http://cobra-language.com/downloads/Cobra-$pkgver.tar.gz install.patch)
+sha256sums=('9f1e496520bad124f5d827aa35d7a591c412fbb4c41633ecb00e68fbb35457fa'
+ 'SKIP')
+
+prepare() {
+ cd Cobra-$pkgver/Source
+ patch -Np2 -i "$srcdir/install.patch"
+ echo "$pkgdir/opt" > install-directory.text
+ sed -i "s|\$(MSBuildExtensionsPath)|$pkgdir/usr/lib/mono/xbuild|" Cobra.MSBuild/Targets/Cobra.targets
+}
+
+package() {
+ cd Cobra-$pkgver/Source
+ bin/install-from-workspace
+ gacutil -i "$pkgdir/opt/Cobra-$pkgver/bin/Cobra.Core.dll" -root "$pkgdir/usr/lib/"
+ gacutil -i "$pkgdir/opt/Cobra-$pkgver/bin/Cobra.Compiler.dll" -root "$pkgdir/usr/lib/"
+ install -dm755 "$pkgdir/usr"
+ mv "$pkgdir/opt/bin" "$pkgdir/usr"
+ sed -i "s|$pkgdir||" "$pkgdir/usr/bin/cobra"
+ install -Dm644 ../License.text "$pkgdir/usr/share/licenses/$pkgname/License.text"
+}
diff --git a/install.patch b/install.patch
new file mode 100644
index 000000000000..fe935a01819b
--- /dev/null
+++ b/install.patch
@@ -0,0 +1,25 @@
+--- Cobra-0.9.6/Source/InstallFromWorkspace.cobra.orig 2013-12-24 20:26:09.460712423 -0500
++++ Cobra-0.9.6/Source/InstallFromWorkspace.cobra 2013-12-24 20:47:36.244101735 -0500
+@@ -168,9 +168,9 @@
+ .installLibrary(libName, lib['flags'], lib['files'].replace('/', .slash.toString), lib['requiresGacVerification'])
+ .verifyNewlyBuiltCobra
+ .copyFilesToInstallDirectory
+- .verifyNewlyInstalledCobra
++ #.verifyNewlyInstalledCobra
+ .cleanUpWorkspace
+- .installInPath
++ #.installInPath
+ .changeDirectoryInstruction
+ print 'Visit http://cobra-language.com/ for discussion, wiki, samples, irc and more.'
+ print
+@@ -736,8 +736,8 @@
+
+ def installLibrary(name as String, flags as String, files as String, requiresGacVerification)
+ .buildLibrary(name, flags, files as String)
+- .installLibraryToGAC(name)
+- .verifyGacInstallation(name, requiresGacVerification)
++ #.installLibraryToGAC(name)
++ #.verifyGacInstallation(name, requiresGacVerification)
+
+ def buildLibrary(name as String, flags as String, files as String)
+ """