summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororumin2016-06-02 01:02:34 +0900
committerorumin2016-06-02 01:02:34 +0900
commit703704e93f255df53d18f5810de08976776861e0 (patch)
treea40567763e8e7fbaee254a7f448f1c0d6e6e15e9
downloadaur-703704e93f255df53d18f5810de08976776861e0.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..80011c6d08a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed Jun 1 16:02:20 UTC 2016
+pkgbase = coccigrep-git
+ pkgdesc = coccigrep is a semantic grep for the C language based on coccinelle. Git HEAD Package version
+ pkgver = v1.16.r1.g6d70e56
+ pkgrel = 1
+ url = http://http://home.regit.org/software/coccigrep/
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python-setuptools
+ provides = coccigrep
+ source = git+https://github.com/regit/coccigrep.git
+ md5sums = SKIP
+
+pkgname = coccigrep-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..992bed1a7031
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: orumin <dev@orum.in>
+
+_gitroot=coccigrep
+pkgname=coccigrep-git
+provides=('coccigrep')
+conflict=('coccigrep')
+pkgver=v1.16.r1.g6d70e56
+pkgrel=1
+pkgdesc='coccigrep is a semantic grep for the C language based on coccinelle. Git HEAD Package version'
+arch=('any')
+url='http://http://home.regit.org/software/coccigrep/'
+license=('GPL3')
+depends=('python-setuptools')
+makedepends=('python-setuptools')
+source=("git+https://github.com/regit/$_gitroot.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_gitroot"
+ git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir"
+}
+
+package() {
+ cd "$srcdir/coccigrep"
+
+ python3 setup.py install --prefix=/usr --root="$pkgdir" --optimize=0
+
+}