summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOmar Sandoval2016-06-11 11:40:29 -0700
committerOmar Sandoval2016-06-11 11:52:31 -0700
commit0d1a9b173a5a4a494ef9e48ec3dd0d761e0d814f (patch)
tree835356793b289fb45d4a250a4e6effc4c4ffac55
parent81e503d0c775218a66cf0c0ff4ed3fa8914db267 (diff)
downloadaur-0d1a9b173a5a4a494ef9e48ec3dd0d761e0d814f.tar.gz
Disable parallel make, add TeX dependencies, install manual
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
2 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f997f128a59d..3b2d979105c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = coccinelle
pkgdesc = Provides spatch program used to apply semantic patches
pkgver = 1.0.5
- pkgrel = 1
+ pkgrel = 2
url = http://coccinelle.lip6.fr/
arch = i686
arch = x86_64
@@ -9,6 +9,8 @@ pkgbase = coccinelle
makedepends = camlp4
makedepends = ocaml
makedepends = ocaml-findlib
+ makedepends = texlive-core
+ makedepends = texlive-fontsextra
depends = pcre
depends = python
optdepends = ocaml: OCaml scripting feature
diff --git a/PKGBUILD b/PKGBUILD
index 5a664bc1b75f..1b596f286b3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,12 +9,12 @@
pkgname=coccinelle
pkgver=1.0.5
-pkgrel=1
+pkgrel=2
pkgdesc="Provides spatch program used to apply semantic patches"
arch=('i686' 'x86_64')
url="http://coccinelle.lip6.fr/"
license=('GPL2')
-makedepends=('camlp4' 'ocaml' 'ocaml-findlib')
+makedepends=('camlp4' 'ocaml' 'ocaml-findlib' 'texlive-core' 'texlive-fontsextra')
depends=('pcre' 'python')
optdepends=('ocaml: OCaml scripting feature'
'ocaml-findlib: OCaml scripting feature')
@@ -23,14 +23,18 @@ source=(http://coccinelle.lip6.fr/distrib/${pkgname}-${pkgver}.tgz)
sha256sums=('5efb093b538145b7526a06946c09c7caaa715006658af2049faa8739f459743b')
build() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-$pkgver"
- ./configure --prefix=/usr
- make
+ ./configure --prefix=/usr
+ make -j1
}
package() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" MANDIR="/usr/share/man" install
+ make DESTDIR="$pkgdir/" MANDIR="/usr/share/man" install
+ install -m755 -d "$pkgdir/usr/share/doc/$pkgname/"
+ install -m644 -D docs/manual/*.pdf "$pkgdir/usr/share/doc/$pkgname/"
}
+
+# vim:set ts=2 sw=2 et: