summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOmar Sandoval2016-09-28 10:22:22 -0700
committerOmar Sandoval2016-09-28 10:22:22 -0700
commitec7e6f87024e2e5488bef135e677c9beb30918bc (patch)
treedd50e85e2b43045804ce30ae3201e411d993ae03
parentefbb8f742a9b45748276a53590c6bb4d7026ef3c (diff)
downloadaur-ec7e6f87024e2e5488bef135e677c9beb30918bc.tar.gz
Update to 1.0.6
Upstream no longer builds the documentation by default, so don't install it anymore, and remove the TeX dependencies. Also, parallel make should be safe again.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 57be944705f4..1bf2d49ad833 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = coccinelle
pkgdesc = Provides spatch program used to apply semantic patches
- pkgver = 1.0.5
- pkgrel = 4
+ pkgver = 1.0.6
+ pkgrel = 1
url = http://coccinelle.lip6.fr/
arch = i686
arch = x86_64
@@ -9,19 +9,13 @@ pkgbase = coccinelle
makedepends = camlp4
makedepends = ocaml
makedepends = ocaml-findlib
- makedepends = hevea
- makedepends = texlive-core
- makedepends = texlive-fontsextra
- makedepends = texlive-latexextra
- makedepends = texlive-pictures
depends = pcre
depends = python
optdepends = ocaml: OCaml scripting feature
optdepends = ocaml-findlib: OCaml scripting feature
options = !strip
- options = !makeflags
- source = http://coccinelle.lip6.fr/distrib/coccinelle-1.0.5.tgz
- sha256sums = 5efb093b538145b7526a06946c09c7caaa715006658af2049faa8739f459743b
+ source = http://coccinelle.lip6.fr/distrib/coccinelle-1.0.6.tgz
+ sha256sums = 8452ed265c209dae99cbb33b67bc7912e72f8bca1e24f33f1a88ba3d7985e909
pkgname = coccinelle
diff --git a/PKGBUILD b/PKGBUILD
index 541eca8611ce..802c86ea5446 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,20 +8,19 @@
# Contributor: Vladimir Kirillov <proger@wilab.org.ua>
pkgname=coccinelle
-pkgver=1.0.5
-pkgrel=4
+pkgver=1.0.6
+pkgrel=1
pkgdesc="Provides spatch program used to apply semantic patches"
arch=('i686' 'x86_64')
url="http://coccinelle.lip6.fr/"
license=('GPL2')
-makedepends=('camlp4' 'ocaml' 'ocaml-findlib' 'hevea' 'texlive-core'
- 'texlive-fontsextra' 'texlive-latexextra' 'texlive-pictures')
+makedepends=('camlp4' 'ocaml' 'ocaml-findlib')
depends=('pcre' 'python')
optdepends=('ocaml: OCaml scripting feature'
'ocaml-findlib: OCaml scripting feature')
-options=('!strip' '!makeflags')
+options=('!strip')
source=(http://coccinelle.lip6.fr/distrib/${pkgname}-${pkgver}.tgz)
-sha256sums=('5efb093b538145b7526a06946c09c7caaa715006658af2049faa8739f459743b')
+sha256sums=('8452ed265c209dae99cbb33b67bc7912e72f8bca1e24f33f1a88ba3d7985e909')
build() {
cd "$pkgname-$pkgver"
@@ -34,8 +33,6 @@ package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir/" MANDIR="/usr/share/man" install
- install -m755 -d "$pkgdir/usr/share/doc/$pkgname/"
- install -m644 -D docs/manual/*.{pdf,css,gif,html} "$pkgdir/usr/share/doc/$pkgname/"
}
# vim:set ts=2 sw=2 et: