summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOmar Sandoval2018-06-28 23:47:31 -0700
committerOmar Sandoval2018-06-28 23:52:03 -0700
commit7bdd62341bee216ccca8f66e52f8cbe0d1bfd490 (patch)
treea299862c960f11d86bc892424f98fb14fe6cc457
downloadaur-7bdd62341bee216ccca8f66e52f8cbe0d1bfd490.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD51
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b30afc67e812
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = coccinelle-git
+ pkgdesc = Provides spatch program used to apply semantic patches
+ pkgver = 1.0.6.r452.175de16b
+ pkgrel = 1
+ url = http://coccinelle.lip6.fr/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = ocaml
+ makedepends = ocaml-findlib
+ depends = pcre
+ depends = python
+ optdepends = ocaml: OCaml scripting feature
+ optdepends = ocaml-findlib: OCaml scripting feature
+ provides = coccinelle
+ conflicts = coccinelle
+ options = !strip
+ options = !makeflags
+ source = git+https://github.com/coccinelle/coccinelle.git
+ sha256sums = SKIP
+
+pkgname = coccinelle-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d270e90e94e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Omar Sandoval <osandov at osandov dot com>
+# Contributor: Roger Zanoni <rogerzanoni@gmail.com>
+# Contributor: Sylvain Henry <hsyl20@gmail.com>
+# Contributor: Marti Raudsepp <marti@juffo.org>
+# Contributor: Dan McGee <dpmcgee@gmail.com>
+# Contributor: LeCrayonVert <sunrider@laposte.net>
+# Contributor: Lukas Fleischer <archlinux@cryptocrack.de>
+# Contributor: Vladimir Kirillov <proger@wilab.org.ua>
+
+pkgname=coccinelle-git
+_pkgname=coccinelle
+pkgver=1.0.6.r452.175de16b
+pkgrel=1
+pkgdesc="Provides spatch program used to apply semantic patches"
+arch=('i686' 'x86_64')
+url="http://coccinelle.lip6.fr/"
+license=('GPL2')
+makedepends=('ocaml' 'ocaml-findlib')
+depends=('pcre' 'python')
+optdepends=('ocaml: OCaml scripting feature'
+ 'ocaml-findlib: OCaml scripting feature')
+options=('!strip' '!makeflags')
+conflicts=('coccinelle')
+provides=('coccinelle')
+source=('git+https://github.com/coccinelle/coccinelle.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$_pkgname"
+
+ ./autogen
+ ./configure \
+ --prefix=/usr \
+ --enable-release=yes \
+ --with-python=/usr/bin/python3
+ make
+}
+
+package() {
+ cd "$_pkgname"
+
+ make DESTDIR="$pkgdir/" MANDIR="/usr/share/man" \
+ BASH_COMPLETION_DIR="/etc/bash_completion.d" install
+}
+
+# vim:set ts=2 sw=2 et: