summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorscott-linder2017-06-16 21:16:20 -0400
committerscott-linder2017-06-16 21:16:20 -0400
commit579b17f5e40ba570118358c3b10e4df6cece07e1 (patch)
tree1c0b184a2f02a797d4966bcaaf785f2f475b0553
parentcc13ead3f9527067368c09a1928f23d34ef0f446 (diff)
downloadaur-579b17f5e40ba570118358c3b10e4df6cece07e1.tar.gz
Update to latest version
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD35
3 files changed, 29 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 11c43dc0311e..9b7b66863985 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,21 @@
pkgbase = cockatrice-client-git
- pkgdesc = A cross-platform virtual tabletop for multiplayer card games (Client)
- pkgver = 20150924.1
+ pkgdesc = Open-source multiplatform supported program for playing tabletop card games over a network.
+ pkgver = 2.3.17
pkgrel = 1
- url = http://www.woogerworks.com/
+ url = https://cockatrice.github.io/
arch = i686
arch = x86_64
license = GPL2
- makedepends = git
makedepends = cmake
- depends = qt5-base
+ makedepends = git
+ depends = protobuf
+ depends = qt5-svg
depends = qt5-tools
depends = qt5-multimedia
- depends = qt5-svg
- depends = protobuf
- depends = zlib
+ provides = cockatrice-client
conflicts = cockatrice-client
- source = git+https://github.com/Cockatrice/Cockatrice.git
- md5sums = SKIP
+ source = git+https://github.com/Cockatrice/Cockatrice
+ sha256sums = SKIP
pkgname = cockatrice-client-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..232f199c7f33
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+Cockatrice/
+*.tar.xz
+*.swp
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
index 8e2d372fec5e..ebd6c00ad43c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,31 @@
-# Maintainer: Jorge Araya Navarro <elcorreo@deshackra.com>
+# Maintainer: Scott Linder <scott.linder18@gmail.com>
+# Contributer: Jorge Araya Navarro <elcorreo@deshackra.com>
+# Contributer: Mikhail Burakov <mikhail.burakov@gmail.com>
+
pkgname=cockatrice-client-git
-pkgver=20150924.1
+pkgver=2.3.17
pkgrel=1
-pkgdesc="A cross-platform virtual tabletop for multiplayer card games (Client)"
+pkgdesc='Open-source multiplatform supported program for playing tabletop card games over a network.'
arch=('i686' 'x86_64')
-url="http://www.woogerworks.com/"
+url='https://cockatrice.github.io/'
license=('GPL2')
-depends=('qt5-base' 'qt5-tools' 'qt5-multimedia' 'qt5-svg' 'protobuf' 'zlib')
-makedepends=('git' 'cmake')
+depends=('protobuf' 'qt5-svg' 'qt5-tools' 'qt5-multimedia')
+makedepends=('cmake' 'git')
+provides=('cockatrice-client')
conflicts=('cockatrice-client')
-source=(git+https://github.com/Cockatrice/Cockatrice.git)
-md5sums=('SKIP')
+source=("git+https://github.com/Cockatrice/Cockatrice")
+sha256sums=('SKIP')
build() {
cd "$srcdir/Cockatrice"
-
- if [ ! -d "build"];
- then
- mkdir build
- else
- rm -rf build
- mkdir build
- fi
+ test -d build && rm -rf build
+ mkdir build
cd build
- cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr -DWITH_CLIENT=1 -DWITH_ORACLE=1 -DWITH_SERVER=0 ..
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr -DWITH_ORACLE=1 -DWITH_CLIENT=1 -DWITH_SERVER=0 ..
make
}
package() {
cd "$srcdir/Cockatrice/build"
-
make DESTDIR="$pkgdir/" install
}
-
-# vim:set ts=2 sw=2 et: