summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrado2024-04-22 04:39:19 -0400
committerbrado2024-04-22 04:39:19 -0400
commit7e83839026f9bb1d5d45936b8cc68b9559a65dce (patch)
tree648b40e42dc2c2c73ed6bf4336858387f3032dc4
parentc6abc340113c44d291a641653ffc745b2f38f1e4 (diff)
downloadaur-7e83839026f9bb1d5d45936b8cc68b9559a65dce.tar.gz
bump to 3.3.6; use newly published generic zip build
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5cd44e087b07..bd32623d82da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cockpit-file-sharing
pkgdesc = A Cockpit plugin to easily manage samba and NFS file sharing.
- pkgver = 3.3.4
+ pkgver = 3.3.6
pkgrel = 1
url = https://github.com/45Drives/cockpit-file-sharing
arch = any
@@ -12,7 +12,7 @@ pkgbase = cockpit-file-sharing
depends = samba
depends = nfs-utils
provides = cockpit-file-sharing
- source = https://github.com/45Drives/cockpit-file-sharing/releases/download/v3.3.4/cockpit-file-sharing-3.3.4-1.el8.noarch.rpm
- sha512sums = 1ecd1a8e2c3e65a853e6b9320257a4ca4b8a4c2932a55fd3fa434bd18b2508aab4be306209b9568639198a5113375c23dd7580217524fa93e88b628d628d897a
+ source = https://github.com/45Drives/cockpit-file-sharing/releases/download/v3.3.6/cockpit-file-sharing_3.3.6_generic.zip
+ sha512sums = 5a022bcbf9e4b7725fb96fb03748e912de45ea5361a38959dda174b2bf5e4640b364786ffa157cfab986c83e8219d7fb24843860655d89b63ff66efd13eb43c6
pkgname = cockpit-file-sharing
diff --git a/PKGBUILD b/PKGBUILD
index ab605c57187b..bd63a1acc055 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_plugin=file-sharing
pkgname="cockpit-${_plugin}"
-pkgver="3.3.4"
+pkgver="3.3.6"
pkgrel=1
pkgdesc="A Cockpit plugin to easily manage samba and NFS file sharing."
arch=('any')
@@ -12,10 +12,11 @@ license=('GPL3')
depends=("cockpit" "python" "samba" "nfs-utils")
makedepends=("cockpit" "make")
provides=("${pkgname}")
-source=("${url}/releases/download/v${pkgver}/${pkgname}-${pkgver}-${pkgrel}.el8.noarch.rpm")
-sha512sums=("1ecd1a8e2c3e65a853e6b9320257a4ca4b8a4c2932a55fd3fa434bd18b2508aab4be306209b9568639198a5113375c23dd7580217524fa93e88b628d628d897a")
+source=("${url}/releases/download/v${pkgver}/${pkgname}_${pkgver}_generic.zip")
+sha512sums=("5a022bcbf9e4b7725fb96fb03748e912de45ea5361a38959dda174b2bf5e4640b364786ffa157cfab986c83e8219d7fb24843860655d89b63ff66efd13eb43c6")
package() {
- find $srcdir/ -mindepth 1 -maxdepth 1 -type d | xargs cp -r -t "$pkgdir"
+ cd ${pkgname}_${pkgver}_generic
+ sudo make install RESTART_COCKPIT=1
}