summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrkcf2020-05-17 02:23:07 -0500
committerrkcf2020-05-17 02:23:07 -0500
commit127499667918a54173a46c4eed023c18dedc306f (patch)
tree09887910539d25400fd53a06eed2da7dc271db77
downloadaur-127499667918a54173a46c4eed023c18dedc306f.tar.gz
add cockpit-zfs-manager 0.3.1.301
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dab24caaaf16
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = cockpit-zfs-manager
+ pkgdesc = An interactive ZFS on Linux admin package for Cockpit
+ pkgver = 0.3.1.301
+ pkgrel = 1
+ url = https://github.com/optimans/cockpit-zfs-manager
+ arch = any
+ license = GPL3
+ depends = cockpit
+ depends = zfs
+ source = https://github.com/optimans/cockpit-zfs-manager/archive/0.3.1.301.tar.gz
+ md5sums = 81f9b3b9eb426fad458360d23e899710
+
+pkgname = cockpit-zfs-manager
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..124ededcc818
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Andrew Steinke <rkcf@rkcf.me>
+
+pkgname=cockpit-zfs-manager
+pkgver=0.3.1.301
+pkgrel=1
+pkgdesc="An interactive ZFS on Linux admin package for Cockpit"
+arch=('any')
+url="https://github.com/optimans/cockpit-zfs-manager"
+license=('GPL3')
+depends=('cockpit' 'zfs')
+source=("https://github.com/optimans/cockpit-zfs-manager/archive/$pkgver.tar.gz")
+md5sums=('81f9b3b9eb426fad458360d23e899710')
+
+package() {
+ install -dm755 "$pkgdir"/usr/share/cockpit/zfs
+
+ for file in $(find "$srcdir/$pkgname-$pkgver/zfs/" -type f ); do
+ install -Dm644 "$file" "$pkgdir"/usr/share/cockpit/zfs/;
+ done
+}
+
+# vim:set ts=2 sw=2 et: