summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Daum2024-04-16 13:34:38 +0200
committerAlexander Daum2024-04-16 13:34:38 +0200
commit6222d47209c4f3f4a38d3113b376a2df81b2bf37 (patch)
treed28e2c376082f33d628c4a7828fed073800843ad
downloadaur-6222d47209c4f3f4a38d3113b376a2df81b2bf37.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a7d358e6e8f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = coco_r_cpp
+ pkgdesc = Coco/R Compiler Generator (C++ version)
+ pkgver = 2018_12_03
+ pkgrel = 1
+ url = https://ssw.jku.at/Research/Projects/Coco/
+ arch = x86_64
+ arch = i686
+ license = custom
+ source = https://ssw.jku.at/Research/Projects/Coco/CPP/CocoSourcesCPP.zip
+ sha512sums = 97baa9ac9888785562d1e2bd56fb433a3abdc037b9ea05382c7a85f1d3bb9f3da0a120e9bac2798da84207ebd66590b9ab08db57c2df4ed4968ac2a200285003
+
+pkgname = coco_r_cpp
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aeb1734d9925
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Alexander Daum <alexander.daum at mailbox dot org>
+
+pkgname='coco_r_cpp'
+pkgver=2018_12_03
+pkgrel=1
+pkgdesc='Coco/R Compiler Generator (C++ version)'
+url='https://ssw.jku.at/Research/Projects/Coco/'
+license=(
+ 'custom' # TODO install license
+)
+source=(
+ "https://ssw.jku.at/Research/Projects/Coco/CPP/CocoSourcesCPP.zip"
+)
+sha512sums=(
+ '97baa9ac9888785562d1e2bd56fb433a3abdc037b9ea05382c7a85f1d3bb9f3da0a120e9bac2798da84207ebd66590b9ab08db57c2df4ed4968ac2a200285003'
+)
+arch=(
+ 'x86_64'
+ 'i686'
+)
+
+build() {
+ make
+}
+
+package() {
+ install -D -m 0755 Coco ${pkgdir}/usr/bin/cococpp
+ install -d ${pkgdir}/usr/share/coco-cpp/
+ install -m 0644 *frame ${pkgdir}/usr/share/coco-cpp/
+}