summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Delafosse2021-11-30 10:08:41 +0100
committerPaul Delafosse2021-11-30 10:08:41 +0100
commitac2a6ebd8389767973b04bf1d5f920fa1fe03d9f (patch)
tree9b51eff3f15de1b72d36b289cb28537d3cfc9e44
parent16298e2729aeb011b30f51d756a1db08e50f435c (diff)
downloadaur-ac2a6ebd8389767973b04bf1d5f920fa1fe03d9f.tar.gz
chore: update version to 4.0.0
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD16
3 files changed, 20 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b6976a6d18e..95850f892c36 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = cocogitto-bin
- pkgdesc = A set of cli tools for the conventional commit and semver specifications
- pkgver = 2.1.1
+ pkgdesc = The conventional commits toolbox
+ pkgver = 4.0.0
pkgrel = 1
- url = https://github.com/oknozor/cocogitto
+ url = https://github.com/cocogitto/cocogitto
arch = x86_64
arch = armv7h
arch = aarch64
license = MIT
+ makedepends = git
provides = cocogitto
- source_x86_64 = https://github.com/oknozor/cocogitto/releases/download/2.1.1/cocogitto-2.1.1-x86_64-unknown-linux-musl.tar.gz
- md5sums_x86_64 = 8e291dfaefdbee9e1155dc763ef2d271
- source_armv7h = https://github.com/oknozor/cocogitto/releases/download/2.1.1/cocogitto-2.1.1-armv7-unknown-linux-musleabihf.tar.gz
- md5sums_armv7h = 0227118624c06778b03e66e18b6a6be3
- source_aarch64 = https://github.com/oknozor/cocogitto/releases/download/2.1.1/cocogitto-2.1.1-aarch64-linux-android.tar.gz
- md5sums_aarch64 = fab9951beace0112cea33dbea5b8d361
+ source = https://github.com/cocogitto/cocogitto/releases/download/4.0.0/cocogitto-4.0.0-x86_64-unknown-linux-musl.tar.gz
+ md5sums = 6305efc833f24718e56b5dbd62537bc3
+ source_armv7h = https://github.com/cocogitto/cocogitto/releases/download/4.0.0/cocogitto-4.0.0-armv7-unknown-linux-musleabihf.tar.gz
+ md5sums_armv7h = e73716757add18a4bcaa93ef0afc6fcb
+ source_aarch64 = https://github.com/cocogitto/cocogitto/releases/download/4.0.0/cocogitto-4.0.0-aarch64-linux-android.tar.gz
+ md5sums_aarch64 = 7f3ff6c2377e5f28c7117d4c244337cc
pkgname = cocogitto-bin
diff --git a/.gitignore b/.gitignore
index 38d6762abbfe..5c5665b2b4db 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
pkg
src
cocogitto*
+PKGBUILD-namcap.log
diff --git a/PKGBUILD b/PKGBUILD
index 4d1aea265319..abc267d9232c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,16 @@
# Maintainer: Paul Delafosse <paul.delafosse@protonmail.com>
pkgname=cocogitto-bin
_pkgname=cocogitto
-pkgver=2.1.1
+pkgver=4.0.0
pkgrel=1
-pkgdesc='A set of cli tools for the conventional commit and semver specifications'
+pkgdesc='The conventional commits toolbox'
arch=('x86_64' 'armv7h' 'aarch64')
-url='https://github.com/oknozor/cocogitto'
+url='https://github.com/cocogitto/cocogitto'
license=('MIT')
+makedepends=('git')
+
provides=('cocogitto')
-source_x86_64=("$url/releases/download/$pkgver/${_pkgname}-${pkgver}-x86_64-unknown-linux-musl.tar.gz")
+source=("$url/releases/download/$pkgver/${_pkgname}-${pkgver}-x86_64-unknown-linux-musl.tar.gz")
source_armv7h=("$url/releases/download/$pkgver/${_pkgname}-${pkgver}-armv7-unknown-linux-musleabihf.tar.gz")
source_aarch64=("$url/releases/download/$pkgver/${_pkgname}-${pkgver}-aarch64-linux-android.tar.gz")
@@ -18,6 +20,6 @@ package() {
install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}
-md5sums_x86_64=('8e291dfaefdbee9e1155dc763ef2d271')
-md5sums_armv7h=('0227118624c06778b03e66e18b6a6be3')
-md5sums_aarch64=('fab9951beace0112cea33dbea5b8d361')
+md5sums=('6305efc833f24718e56b5dbd62537bc3')
+md5sums_armv7h=('e73716757add18a4bcaa93ef0afc6fcb')
+md5sums_aarch64=('7f3ff6c2377e5f28c7117d4c244337cc')