summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilson E. Alvarez2017-01-09 23:01:44 -0400
committerWilson E. Alvarez2017-01-09 23:01:44 -0400
commit2ef95d1a910b316d2af46fef8c74722cd3d3b3a4 (patch)
tree9a0466bfe36f225a93b0ba4b4402967d56abad67
parentf80cbce3c50be583ef79ecefa2b7c516f191a6da (diff)
downloadaur-2ef95d1a910b316d2af46fef8c74722cd3d3b3a4.tar.gz
Updated CCPhysicsBody.cpp patch
-rw-r--r--.SRCINFO6
-rw-r--r--CCPhysicsBody.patch26
-rw-r--r--PKGBUILD4
3 files changed, 21 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ad49b444f9a..3524b6dd2ec7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Jan 9 14:15:03 UTC 2017
+# Tue Jan 10 03:00:43 UTC 2017
pkgbase = cocos2d-x-src
pkgdesc = Cocos2D-X is a game engine that supports multiple platforms such as iOS, Android, WinXP/7/8, WP8, BlackBerry, MeeGo, Marmelade, WebOS, Mac OS X
pkgver = 3.14
- pkgrel = 1
+ pkgrel = 2
url = http://cdn.cocos2d-x.org/
arch = i686
arch = x86_64
@@ -75,7 +75,7 @@ pkgbase = cocos2d-x-src
sha1sums = 353bdefe07bdb6eb7f53aff20d20e83b488c1c05
sha1sums = 49b7919fc38803c1dd2f5b1d47fb0c75fde1fec6
sha1sums = bcad039c11e29d4cbae9e371cb428d52f2eb15ff
- sha1sums = 281f4c79226a94bf5d1152ccfc7f2d2bb71a2c87
+ sha1sums = 53d64b6246ba32f9f61817f505b30b4d67eeeb44
sha1sums = 2c6801bae13956394ddcd94080861aac8a25be99
sha1sums = 0d70b91142ceece19d90a620c707cb5f86f45d32
sha1sums = 49838c03951aa76524fb651dcb78834393a17682
diff --git a/CCPhysicsBody.patch b/CCPhysicsBody.patch
index f9faaac7301c..d3451769be7b 100644
--- a/CCPhysicsBody.patch
+++ b/CCPhysicsBody.patch
@@ -1,28 +1,34 @@
---- CCPhysicsBody.cpp 2016-12-29 13:42:38.000000000 -0400
-+++ /opt/cocos2d-x-git/cocos/physics/CCPhysicsBody.cpp 2017-01-04 13:22:53.445318965 -0400
-@@ -575,12 +575,6 @@
+--- lel/cocos2d-x-3.14/cocos/physics/CCPhysicsBody.cpp 2016-12-29 13:42:38.000000000 -0400
++++ /opt/cocos2d-x-git/cocos/physics/CCPhysicsBody.cpp 2017-01-08 12:02:19.747686186 -0400
+@@ -575,12 +575,12 @@
void PhysicsBody::setVelocity(const Vec2& velocity)
{
- if (!_dynamic)
-- {
++ if (cpBodyGetType(_cpBody) == CP_BODY_TYPE_STATIC)
+ {
- CCLOG("physics warning: your can't set velocity for a static body.");
-- return;
-- }
++ CCLOG("physics warning: you can't set velocity for a static body.");
+ return;
+ }
-
++
cpBodySetVelocity(_cpBody, PhysicsHelper::point2cpv(velocity));
}
-@@ -601,12 +595,6 @@
+@@ -601,12 +601,12 @@
void PhysicsBody::setAngularVelocity(float velocity)
{
- if (!_dynamic)
-- {
++ if (cpBodyGetType(_cpBody) == CP_BODY_TYPE_STATIC)
+ {
- CCLOG("physics warning: your can't set angular velocity for a static body.");
-- return;
-- }
++ CCLOG("physics warning: you can't set angular velocity for a static body.");
+ return;
+ }
-
++
cpBodySetAngularVelocity(_cpBody, velocity);
}
diff --git a/PKGBUILD b/PKGBUILD
index 56aeca60737f..f80856248d15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_appname=cocos2d-x
pkgname=cocos2d-x-src
pkgver=3.14
-pkgrel=1
+pkgrel=2
pkgdesc="Cocos2D-X is a game engine that supports multiple platforms such as iOS, Android, WinXP/7/8, WP8, BlackBerry, MeeGo, Marmelade, WebOS, Mac OS X"
arch=('i686' 'x86_64')
url="http://cdn.cocos2d-x.org/"
@@ -68,7 +68,7 @@ sha1sums=(
'353bdefe07bdb6eb7f53aff20d20e83b488c1c05'
'49b7919fc38803c1dd2f5b1d47fb0c75fde1fec6'
'bcad039c11e29d4cbae9e371cb428d52f2eb15ff'
-'281f4c79226a94bf5d1152ccfc7f2d2bb71a2c87'
+'53d64b6246ba32f9f61817f505b30b4d67eeeb44'
'2c6801bae13956394ddcd94080861aac8a25be99'
'0d70b91142ceece19d90a620c707cb5f86f45d32'
'49838c03951aa76524fb651dcb78834393a17682'