summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilson E. Alvarez2016-05-13 22:54:51 -0400
committerWilson E. Alvarez2016-05-13 22:54:51 -0400
commit65a9fc2beb4f8d9efaa2e1a42abfd51700a7c22d (patch)
tree76af95e7246630dd553536516ed510e058782685
parent7466c9b9ec1522863330d7e9f3274a9e671d29a5 (diff)
downloadaur-65a9fc2beb4f8d9efaa2e1a42abfd51700a7c22d.tar.gz
cocos2d-x v3.11 - Added DasFranck's python path fix.
Hardcoded python paths are now set to python2.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--README14
3 files changed, 8 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b32a31e3e11f..d926a442ad05 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat May 14 02:17:42 UTC 2016
+# Sat May 14 02:49:58 UTC 2016
pkgbase = cocos2d-x-src
pkgdesc = Cocos2D-X is a game engine that supports multiple platforms such as iOS, Android, WinXP/7/8, WP8, BlackBerry, MeeGo, Marmelade, WebOS, Mac OS X
pkgver = 3.11
- pkgrel = 1
+ pkgrel = 2
url = http://cdn.cocos2d-x.org/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 6bd25937db74..f65e5e18ef71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Mantainer: Wilson E. Alvarez <wilson.e.alvarez1@gmail.com>
+# Contributor: DasFranck
_appname=cocos2d-x
pkgname=cocos2d-x-src
pkgver=3.11
-pkgrel=1
+pkgrel=2
pkgdesc="Cocos2D-X is a game engine that supports multiple platforms such as iOS, Android, WinXP/7/8, WP8, BlackBerry, MeeGo, Marmelade, WebOS, Mac OS X"
arch=('i686' 'x86_64')
url="http://cdn.cocos2d-x.org/"
@@ -52,6 +53,10 @@ package() {
sed -i 's/js_tests/js-tests/g' "$srcdir/$_appname-$pkgver/tests/js-tests/project/CMakeLists.txt"
sed -i 's/lua_tests/lua-tests/g' "$srcdir/$_appname-$pkgver/tests/lua-tests/project/CMakeLists.txt"
+ # Replace hardcoded python paths to python2
+ find "$srcdir"/$_appname-$pkgver/ -type f -exec sed -i "s|/usr/bin/python$|/usr/bin/python2|g" {} \;
+ sed -e 's/python/python2/g' -i "$srcdir"/$_appname-$pkgver/tools/cocos2d-console/plugins/plugin_package/sdkbox "$srcdir"/$_appname-$pkgver/tools/cocos2d-console/bin/cocos
+
# Packaging source
mv "$srcdir"/$_appname-$pkgver/* "$pkgdir/opt/$_appname"
}
diff --git a/README b/README
index 762a2cc6a83b..1af775b5380d 100644
--- a/README
+++ b/README
@@ -1,17 +1,3 @@
-Very important point to have a full functionnal cocos2d-x install:
-
-*******************
-** WARNING **
-*******************
- * All cocos2d scripts use python2. Calling "python2 script" is not enough
- as other submodule will be called with "env python" (which could point to python3).
- cocos2d scripts will failed if called with python3.
-
- In order to use cocos2d wrapper correctly without forcing symlink python to be python2,
- you can use this : https://wiki.archlinux.org/index.php/python#Dealing_with_version_problem_in_build_scripts
- A first pattern I suggest is "/opt/cocos2d-x/*"
-
-
************************
** CONFIGURATION **
************************