summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2020-02-07 08:45:49 -0700
committeryochananmarqos2020-02-07 08:45:49 -0700
commit2e21de176c0398a0fa8a66a8894dbce127401c57 (patch)
tree460ab02c23b37627968cf6044617bfec66616edf
downloadaur-2e21de176c0398a0fa8a66a8894dbce127401c57.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..787cb24f7acb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = cod
+ pkgdesc = A completion daemon for bash/zsh
+ pkgver = 0.0.0
+ pkgrel = 1
+ url = https://github.com/dim-an/cod
+ arch = any
+ license = Apache-2.0
+ makedepends = go-pie
+ optdepends = bash-completion
+ optdepends = zsh
+ source = cod-0.0.0.tar.gz::https://github.com/dim-an/cod/archive/v0.0.0.tar.gz
+ sha256sums = 6f773358f363141dcd1bbdffaaa5dea0a40ae7a84d5fc55fd453302de8493c20
+
+pkgname = cod
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b8d8f9f6ba5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=cod
+pkgver=0.0.0
+pkgrel=1
+pkgdesc="A completion daemon for bash/zsh"
+arch=('any')
+url="https://github.com/dim-an/cod"
+license=('Apache-2.0')
+makedepends=('go-pie')
+optdepends=('bash-completion' 'zsh')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/dim-an/cod/archive/v$pkgver.tar.gz")
+sha256sums=('6f773358f363141dcd1bbdffaaa5dea0a40ae7a84d5fc55fd453302de8493c20')
+
+build() {
+ cd "$pkgname-$pkgver"
+ go build \
+ -trimpath \
+ -ldflags "-extldflags $LDFLAGS" \
+ -o $pkgname .
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+}