summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-08-16 14:17:55 -0600
committerMark Wagie2021-08-16 14:17:55 -0600
commit61b71deda8df1858e6b413da0612e632b35bf6ef (patch)
tree759be5bed0221632c31ced8dbc7def82d98dc2b0
parent55debd9e3f51c4931df1a975edd698cc28076359 (diff)
downloadaur-61b71deda8df1858e6b413da0612e632b35bf6ef.tar.gz
don't install common license
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD39
2 files changed, 21 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f767edc1e27b..efefd75dc2fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = cod
pkgdesc = A completion daemon for bash/zsh
pkgver = 0.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/dim-an/cod
arch = any
- license = Apache-2.0
+ license = Apache
makedepends = go
optdepends = bash-completion
source = cod-0.1.0.tar.gz::https://github.com/dim-an/cod/archive/v0.1.0.tar.gz
sha256sums = 3d8ed6f284afcf4c86a2164e234ab7ff40c50aa6ab0bd892e59f8dc8aef02541
pkgname = cod
-
diff --git a/PKGBUILD b/PKGBUILD
index 3ead05206599..e10bf4b60a75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,39 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=cod
pkgver=0.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="A completion daemon for bash/zsh"
arch=('any')
url="https://github.com/dim-an/cod"
-license=('Apache-2.0')
+license=('Apache')
makedepends=('go')
optdepends=('bash-completion')
source=("$pkgname-$pkgver.tar.gz::https://github.com/dim-an/cod/archive/v$pkgver.tar.gz")
sha256sums=('3d8ed6f284afcf4c86a2164e234ab7ff40c50aa6ab0bd892e59f8dc8aef02541')
prepare() {
- # Prevent creation of a `go` directory in one's home.
- # Sometimes this directory cannot be removed with even `rm -rf` unless
- # one becomes root or changes the write permissions.
- export GOPATH="$srcdir/gopath"
- go clean -modcache
+ # Prevent creation of a `go` directory in one's home.
+ # Sometimes this directory cannot be removed with even `rm -rf` unless
+ # one becomes root or changes the write permissions.
+ export GOPATH="$srcdir/gopath"
+ go clean -modcache
}
build() {
- cd "$pkgname-$pkgver"
- export GOPATH="$srcdir/gopath"
- export CGO_CPPFLAGS="${CPPFLAGS}"
- export CGO_CFLAGS="${CFLAGS}"
- export CGO_CXXFLAGS="${CXXFLAGS}"
- export CGO_LDFLAGS="${LDFLAGS}"
- export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- go build -v -o "${pkgname%-git}" .
+ cd "$pkgname-$pkgver"
+ export GOPATH="$srcdir/gopath"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -v -o "${pkgname%-git}" .
- # Clean now to ensure makepkg --clean works
- go clean -modcache
+ # Clean now to ensure makepkg --clean works
+ go clean -modcache
}
package() {
- cd "$pkgname-$pkgver"
- install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
- install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+ cd "$pkgname-$pkgver"
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
}