summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-03-18 09:06:17 -0600
committerMark Wagie2022-03-18 09:06:17 -0600
commita7bb3bb38964dd091e8402cd3f28fceead3f0af8 (patch)
treee319e9acf0413249771cfcc1eb9931d80a668953
parent2ad2f29497a2e345eae8169341693de92850f0d9 (diff)
downloadaur-a7bb3bb38964dd091e8402cd3f28fceead3f0af8.tar.gz
clean module cache for makepkg -C
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f42ab9593eb..8b8313116e60 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cod
pkgdesc = A completion daemon for bash/zsh
pkgver = 0.1.0
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/dim-an/cod
arch = any
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index e1d4176daff2..d6e3ca7134c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=cod
pkgver=0.1.0
-pkgrel=4
+pkgrel=5
pkgdesc="A completion daemon for bash/zsh"
arch=('any')
url="https://github.com/dim-an/cod"
@@ -14,11 +14,11 @@ prepare() {
cd "$pkgname-$pkgver"
export GOPATH="$srcdir/gopath"
+ # download dependencies
+ go mod download -x
+
# create directory for build output
mkdir -p build
-
- # download dependencies
- go mod download -x
}
build() {
@@ -30,6 +30,9 @@ build() {
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
go build -v -buildvcs=false -o build .
+
+ # Clean module cache for makepkg -C
+ go clean -modcache
}
package() {