summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2021-07-11 01:39:05 -0600
committerBrian Bidulock2021-07-11 01:39:05 -0600
commitd9c35ad726d8543a8feaa23ca26068d47ae35b96 (patch)
treeea67b8622ecc4e5a7e648edbc5dbf1efe7f09a12
parentf226a002309ed87cce25f5a3db349b2bf9693d35 (diff)
downloadaur-d9c35ad726d8543a8feaa23ca26068d47ae35b96.tar.gz
uppkg
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1122ad343747..a4d3d410f83e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = coda
pkgdesc = A distributed file system with disconnected operation.
- pkgver = 7.1.1
+ pkgver = 8.1.3
pkgrel = 1
url = http://coda.cs.cmu.edu/
arch = i686
@@ -9,8 +9,10 @@ pkgbase = coda
license = GPL
depends = bash
depends = perl
- source = http://coda.cs.cmu.edu/coda/source/coda-7.1.1.tar.xz
- sha512sums = ad7ae62f586b4a459c185b1def8b7ba6300a9b3e110c28879815fb4d6168b30823b808efa2c559e78790063d0580ca7e9ddeb72c83a3467e1397755dc57ed156
+ depends = python
+ depends = python-attrs
+ depends = python-setuptools
+ source = http://coda.cs.cmu.edu/coda/source/coda-8.1.3.tar.xz
+ sha512sums = 04bae335d4a85e0b0ba5a5577a4c4b424e7ceb0b5f1a7d9346bbae6876b12ebdb53408eeee43d520051df74bc6187c91f1906d569172e60a6e83b6ae16eefde2
pkgname = coda
-
diff --git a/PKGBUILD b/PKGBUILD
index b3ad3ebe429f..2ab94b8feddb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,19 @@
# Maintainer Brian Bidulock <bidulock@openss7.org>
pkgname=coda
-pkgver=7.1.1
+pkgver=8.1.3
pkgrel=1
pkgdesc="A distributed file system with disconnected operation."
-depends=('bash' 'perl')
+depends=('bash' 'perl' 'python' 'python-attrs' 'python-setuptools')
arch=(i686 x86_64 armv7h)
url="http://coda.cs.cmu.edu/"
source=("http://coda.cs.cmu.edu/coda/source/$pkgname-$pkgver.tar.xz")
-sha512sums=('ad7ae62f586b4a459c185b1def8b7ba6300a9b3e110c28879815fb4d6168b30823b808efa2c559e78790063d0580ca7e9ddeb72c83a3467e1397755dc57ed156')
+sha512sums=('04bae335d4a85e0b0ba5a5577a4c4b424e7ceb0b5f1a7d9346bbae6876b12ebdb53408eeee43d520051df74bc6187c91f1906d569172e60a6e83b6ae16eefde2')
license=("GPL")
prepare() {
cd $pkgname-$pkgver
- for f in al/pdbtool.c al/pdbtool.8 al/pdb.h al/Makefile.am auth2/passwd.coda.5 scripts/vice-setup-user.in ; do
- sed -i -e 's,pdbtool,cpdbtool,g' coda-src/$f
- sed -i -e 's,PDBTOOL,CPDBTOOL,g' coda-src/$f
- done
- mv coda-src/al/pdbtool.c coda-src/al/cpdbtool.c
- mv coda-src/al/pdbtool.8 coda-src/al/cpdbtool.8
+ sed -i -e 's,^LDFLAGS=,,' lib-src/rpc2/rp2gen/Makefile.am
./bootstrap.sh
}
@@ -33,7 +28,7 @@ build() {
--includedir=/usr/include \
--enable-client \
--enable-server
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed,-pie\0/g' libtool
+ sed -i -e 's/ -shared / -Wl,-O1,--sort-common,--as-needed,-pie,-z,relro,-z,now \0/g' libtool
make V=1
}