summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortinywrkb2019-09-02 16:26:47 +0300
committertinywrkb2019-09-02 16:26:47 +0300
commitba977ca5a9b434529813888f509f28ecf4acc13b (patch)
treecf1d2cdab3cf504c7e9aed72dfc68314a9d2ece7
downloadaur-ba977ca5a9b434529813888f509f28ecf4acc13b.tar.gz
initial import
-rw-r--r--.SRCINFO17
-rw-r--r--000-packaging.patch33
-rw-r--r--PKGBUILD40
3 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4ad0e291101
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = coda-bits-git
+ pkgdesc = Bits & pieces of information about CODA VPUs
+ pkgver = r6.5840a95
+ pkgrel = 1
+ url = https://github.com/pH5/coda-bits
+ arch = x86_64
+ license = ISC
+ makedepends = git
+ makedepends = meson
+ depends = glibc
+ source = coda-bits::git+https://github.com/pH5/coda-bits.git
+ source = 000-packaging.patch
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = coda-bits-git
+
diff --git a/000-packaging.patch b/000-packaging.patch
new file mode 100644
index 000000000000..bdb3611a451c
--- /dev/null
+++ b/000-packaging.patch
@@ -0,0 +1,33 @@
+diff --git a/meson.build b/meson.build
+index 4eb5213..692058c 100644
+--- a/meson.build
++++ b/meson.build
+@@ -11,18 +11,25 @@ bitdis_sources = [
+ 'src/reorder.c',
+ 'src/reorder.h'
+ ]
+-executable('bitdis', bitdis_sources)
++executable('bitdis', bitdis_sources, install : true)
+
+ bitspl_sources = [
+ 'src/bitspl.c',
+ 'src/reorder.c',
+ 'src/reorder.h'
+ ]
+-executable('bitspl', bitspl_sources)
++executable('bitspl', bitspl_sources, install : true)
+
+ coda_fwinfo_sources = [
+ 'src/coda-fwinfo.c',
+ 'src/reorder.c',
+ 'src/reorder.h'
+ ]
+-executable('coda-fwinfo', coda_fwinfo_sources)
++executable('coda-fwinfo', coda_fwinfo_sources, install : true)
++
++codabits_docs = [
++ 'README.rst',
++ 'doc/bit-isa.rst',
++ 'doc/bit.rst'
++]
++install_data(codabits_docs, install_dir: 'share/doc/coda-bits')
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32797670d794
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: tinywrkb <tinywrkb@gmail.com>
+
+_pkgname=coda-bits
+pkgname=${_pkgname}-git
+pkgver=r6.5840a95
+pkgrel=1
+pkgdesc="Bits & pieces of information about CODA VPUs"
+arch=(x86_64)
+url="https://github.com/pH5/${_pkgname}"
+license=(ISC)
+depends=(glibc)
+makedepends=(git meson)
+source=("${_pkgname}::git+${url}.git"
+ 000-packaging.patch)
+sha256sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd ${_pkgname}
+ set -o pipefail
+ git describe --long 2> /dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ${_pkgname}
+ patch -Np1 -i "${srcdir}"/000-packaging.patch
+}
+
+build() {
+ cd ${_pkgname}
+ meson --prefix=/usr build
+ ninja -C build
+}
+
+package() {
+ cd ${_pkgname}
+ DESTDIR="$pkgdir" meson install -C build
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}