summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortinywrkb2019-09-20 01:17:50 +0300
committertinywrkb2019-09-20 01:17:50 +0300
commite599e95a3673d7448a7b6042bfab935a07d0047e (patch)
treef5c3fa1d3a5e3c6f8d395f56b0c9faeeb76db218
parentba977ca5a9b434529813888f509f28ecf4acc13b (diff)
downloadaur-e599e95a3673d7448a7b6042bfab935a07d0047e.tar.gz
upgpkg: r11.61c8cc4
-rw-r--r--.SRCINFO4
-rw-r--r--000-packaging.patch33
-rw-r--r--PKGBUILD15
3 files changed, 5 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4ad0e291101..b19075f140cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = coda-bits-git
pkgdesc = Bits & pieces of information about CODA VPUs
- pkgver = r6.5840a95
+ pkgver = r11.61c8cc4
pkgrel = 1
url = https://github.com/pH5/coda-bits
arch = x86_64
@@ -9,8 +9,6 @@ pkgbase = coda-bits-git
makedepends = meson
depends = glibc
source = coda-bits::git+https://github.com/pH5/coda-bits.git
- source = 000-packaging.patch
- sha256sums = SKIP
sha256sums = SKIP
pkgname = coda-bits-git
diff --git a/000-packaging.patch b/000-packaging.patch
deleted file mode 100644
index bdb3611a451c..000000000000
--- a/000-packaging.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff --git a/meson.build b/meson.build
-index 4eb5213..692058c 100644
---- a/meson.build
-+++ b/meson.build
-@@ -11,18 +11,25 @@ bitdis_sources = [
- 'src/reorder.c',
- 'src/reorder.h'
- ]
--executable('bitdis', bitdis_sources)
-+executable('bitdis', bitdis_sources, install : true)
-
- bitspl_sources = [
- 'src/bitspl.c',
- 'src/reorder.c',
- 'src/reorder.h'
- ]
--executable('bitspl', bitspl_sources)
-+executable('bitspl', bitspl_sources, install : true)
-
- coda_fwinfo_sources = [
- 'src/coda-fwinfo.c',
- 'src/reorder.c',
- 'src/reorder.h'
- ]
--executable('coda-fwinfo', coda_fwinfo_sources)
-+executable('coda-fwinfo', coda_fwinfo_sources, install : true)
-+
-+codabits_docs = [
-+ 'README.rst',
-+ 'doc/bit-isa.rst',
-+ 'doc/bit.rst'
-+]
-+install_data(codabits_docs, install_dir: 'share/doc/coda-bits')
diff --git a/PKGBUILD b/PKGBUILD
index 32797670d794..14e0bc5e83be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=coda-bits
pkgname=${_pkgname}-git
-pkgver=r6.5840a95
+pkgver=r11.61c8cc4
pkgrel=1
pkgdesc="Bits & pieces of information about CODA VPUs"
arch=(x86_64)
@@ -10,10 +10,8 @@ url="https://github.com/pH5/${_pkgname}"
license=(ISC)
depends=(glibc)
makedepends=(git meson)
-source=("${_pkgname}::git+${url}.git"
- 000-packaging.patch)
-sha256sums=('SKIP'
- 'SKIP')
+source=("${_pkgname}::git+${url}.git")
+sha256sums=('SKIP')
pkgver() {
cd ${_pkgname}
@@ -22,14 +20,9 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd ${_pkgname}
- patch -Np1 -i "${srcdir}"/000-packaging.patch
-}
-
build() {
cd ${_pkgname}
- meson --prefix=/usr build
+ meson --prefix=/usr build -D docs=true
ninja -C build
}