summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Hansen2016-05-04 16:29:06 -0700
committerMichael Hansen2016-05-04 16:29:06 -0700
commit709fd45c0c349589bb17ef09c6ed8677e1bb397e (patch)
treec6b6e307d8d193877cb6a60db4ba00d3f677f256
parent1bbddbe05944cb0a2fbbe36bf58cdf5daef71456 (diff)
downloadaur-709fd45c0c349589bb17ef09c6ed8677e1bb397e.tar.gz
Bump minimum memory for gulp process to 2GiB
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5af12551dc83..7276404b34ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Apr 15 16:08:48 UTC 2016
+# Wed May 4 23:28:43 UTC 2016
pkgbase = visual-studio-code-oss
pkgdesc = Visual Studio Code for Linux, Open Source version
pkgver = 1.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://code.visualstudio.com/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index c65e05644890..50970ae09733 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=visual-studio-code-oss
pkgdesc='Visual Studio Code for Linux, Open Source version'
pkgver=1.0.0
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
url='https://code.visualstudio.com/'
license=('MIT')
@@ -42,7 +42,10 @@ build() {
cd "${srcdir}/vscode-${pkgver}"
./scripts/npm.sh install
- gulp vscode-linux-${_vscode_arch}
+
+ # The default memory limit is too low on some systems (i686?). This will
+ # set it to 2GB -- change it if this number doesn't work for your system
+ node --max_old_space_size=2048 /usr/bin/gulp vscode-linux-${_vscode_arch}
}
package() {