summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Hansen2016-02-17 17:03:30 -0800
committerMichael Hansen2016-02-17 17:03:30 -0800
commit9e010b0e27823190142ab3315f3c100744a9176f (patch)
tree0cf1c33824903168f5c11ecd798232ff93e9483e
parent7783efe8976d948c15da154b782bf16d56900a21 (diff)
downloadaur-9e010b0e27823190142ab3315f3c100744a9176f.tar.gz
Update to v0.10.8, and fix a couple of issues with the OSS build
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
-rw-r--r--fix_omnisharp_ext.patch12
-rw-r--r--product_json.patch19
-rw-r--r--visual-studio-code-oss.desktop4
5 files changed, 58 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40ecfbfb0db0..6ef8377764b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Dec 24 18:32:20 UTC 2015
+# Thu Feb 18 01:02:59 UTC 2016
pkgbase = visual-studio-code-oss
pkgdesc = Visual Studio Code for Linux, Open Source version
- pkgver = 0.10.6
+ pkgver = 0.10.8
pkgrel = 1
url = https://code.visualstudio.com/
arch = i686
@@ -15,10 +15,14 @@ pkgbase = visual-studio-code-oss
depends = gconf
provides = vscode-oss
conflicts = vscode-oss
- source = https://github.com/Microsoft/vscode/archive/0.10.6.tar.gz
+ source = https://github.com/Microsoft/vscode/archive/0.10.8.tar.gz
source = visual-studio-code-oss.desktop
- sha1sums = 4b979c5da74a450972cbefb31a0a166891d6d4d7
- sha1sums = 9ba4659068dc5a71b2bb30eb106872e525660e3f
+ source = fix_omnisharp_ext.patch
+ source = product_json.patch
+ sha1sums = fd74fcc6a16b19c11dc80620fdf2ea2eca7b3118
+ sha1sums = fba307396d3550beff64760bd7a6dec7e90ce0b9
+ sha1sums = 59dbb5cd20fe1c63bd63a019bfac6d2f6ca9e7ee
+ sha1sums = 4a7f41876a016ef8d969fb81c7b1b4bc7b1e026b
pkgname = visual-studio-code-oss
diff --git a/PKGBUILD b/PKGBUILD
index 74ec25dd22c3..93c87466fafc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=visual-studio-code-oss
pkgdesc='Visual Studio Code for Linux, Open Source version'
-pkgver=0.10.6
+pkgver=0.10.8
pkgrel=1
arch=('i686' 'x86_64')
url='https://code.visualstudio.com/'
@@ -13,9 +13,13 @@ conflicts=('vscode-oss')
provides=('vscode-oss')
source=("https://github.com/Microsoft/vscode/archive/${pkgver}.tar.gz"
- "${pkgname}.desktop")
-sha1sums=('4b979c5da74a450972cbefb31a0a166891d6d4d7'
- '9ba4659068dc5a71b2bb30eb106872e525660e3f')
+ "${pkgname}.desktop"
+ 'fix_omnisharp_ext.patch'
+ 'product_json.patch')
+sha1sums=('fd74fcc6a16b19c11dc80620fdf2ea2eca7b3118'
+ 'fba307396d3550beff64760bd7a6dec7e90ce0b9'
+ '59dbb5cd20fe1c63bd63a019bfac6d2f6ca9e7ee'
+ '4a7f41876a016ef8d969fb81c7b1b4bc7b1e026b')
case "$CARCH" in
i686)
@@ -30,6 +34,13 @@ case "$CARCH" in
;;
esac
+prepare() {
+ cd "${srcdir}/vscode-${pkgver}"
+
+ patch -p1 -i "${srcdir}/fix_omnisharp_ext.patch"
+ patch -p1 -i "${srcdir}/product_json.patch"
+}
+
build() {
cd "${srcdir}/vscode-${pkgver}"
@@ -43,7 +54,7 @@ package() {
# Include symlink in system bin directory
install -m 0755 -d "${pkgdir}/usr/bin"
- ln -s '/opt/VSCode-OSS/Code [OSS Build]' "${pkgdir}/usr/bin/${pkgname}"
+ ln -s '/opt/VSCode-OSS/Code - OSS' "${pkgdir}/usr/bin/${pkgname}"
# Add .desktop file
install -D -m644 "${srcdir}/${pkgname}.desktop" \
diff --git a/fix_omnisharp_ext.patch b/fix_omnisharp_ext.patch
new file mode 100644
index 000000000000..3efee9cecdb0
--- /dev/null
+++ b/fix_omnisharp_ext.patch
@@ -0,0 +1,12 @@
+diff -rupN a/build/gulpfile.vscode.js b/build/gulpfile.vscode.js
+--- a/build/gulpfile.vscode.js 2016-02-17 16:20:46.522632538 -0800
++++ b/build/gulpfile.vscode.js 2016-02-17 16:21:54.609301270 -0800
+@@ -39,7 +39,7 @@ var baseModules = [
+ // Build
+
+ var builtInExtensions = {
+- 'jrieken.vscode-omnisharp': '0.3.2',
++ 'ms-vscode.omnisharp': '0.3.2',
+ };
+
+ var vscodeEntryPoints = _.flatten([
diff --git a/product_json.patch b/product_json.patch
new file mode 100644
index 000000000000..3fb6da80e948
--- /dev/null
+++ b/product_json.patch
@@ -0,0 +1,19 @@
+diff -rupN a/product.json b/product.json
+--- a/product.json 2016-02-17 16:46:45.526013096 -0800
++++ b/product.json 2016-02-17 16:49:24.172684567 -0800
+@@ -6,5 +6,12 @@
+ "win32ShortcutName": "code-oss",
+ "licenseUrl": "https://github.com/Microsoft/vscode/blob/master/LICENSE.txt",
+ "darwinBundleIdentifier": "com.visualstudio.code.oss",
+- "welcomePage": "http://go.microsoft.com/fwlink/?LinkId=723048"
+-}
+\ No newline at end of file
++ "welcomePage": "http://go.microsoft.com/fwlink/?LinkId=723048",
++ "quality": "stable",
++ "extensionsGallery": {
++ "serviceUrl": "https://marketplace.visualstudio.com/_apis/public/gallery",
++ "itemUrl": "https://marketplace.visualstudio.com/items"
++ },
++ "documentationUrl": "http://go.microsoft.com/fwlink/?LinkID=533484#vscode",
++ "releaseNotesUrl": "http://go.microsoft.com/fwlink/?LinkID=533483#vscode"
++}
diff --git a/visual-studio-code-oss.desktop b/visual-studio-code-oss.desktop
index affbec0d06a2..bd1ab8fd1be5 100644
--- a/visual-studio-code-oss.desktop
+++ b/visual-studio-code-oss.desktop
@@ -1,8 +1,8 @@
[Desktop Entry]
Encoding=UTF-8
Name=Visual Studio Code (Open Source)
-Version=0.10.6
-Exec="/opt/VSCode-OSS/Code [OSS Build]" %F
+Version=0.10.8
+Exec="/opt/VSCode-OSS/Code - OSS" %F
Icon=/opt/VSCode-OSS/resources/app/resources/linux/code.png
Type=Application
Categories=Development;