summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Hansen2016-11-23 09:04:38 -0800
committerMichael Hansen2016-11-23 09:04:38 -0800
commitf3c4734613d9af35df5739eb0df4be3d0335c3ae (patch)
treed65b15ba63f84510827336d07cf3c308976a8a1a
parentaf4651a6b534169f451d68ed05676f38fd2aa8c7 (diff)
downloadaur-f3c4734613d9af35df5739eb0df4be3d0335c3ae.tar.gz
Update to 1.7.2 and incorporate chicomag's contributions
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
-rw-r--r--visual-studio-code-oss.desktop1
3 files changed, 25 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd2c38e8608c..522e550ee006 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
# Generated by mksrcinfo v8
-# Wed Nov 9 16:56:57 UTC 2016
+# Wed Nov 23 17:03:25 UTC 2016
pkgbase = visual-studio-code-oss
pkgdesc = Visual Studio Code for Linux, Open Source version
- pkgver = 1.7.1
- pkgrel = 2
+ pkgver = 1.7.2
+ pkgrel = 1
url = https://code.visualstudio.com/
install = visual-studio-code-oss.nonfree.install
arch = i686
arch = x86_64
+ arch = armv7h
license = MIT
license = proprietary
makedepends = npm
@@ -24,11 +25,11 @@ pkgbase = visual-studio-code-oss
depends = alsa-lib
provides = vscode-oss
conflicts = vscode-oss
- source = 1.7.1-2.tar.gz::https://github.com/Microsoft/vscode/archive/02611b40b24c9df2726ad8b33f5ef5f67ac30b44.tar.gz
+ source = 1.7.2-1.tar.gz::https://github.com/Microsoft/vscode/archive/7ba55c5860b152d999dda59393ca3ebeb1b5c85f.tar.gz
source = visual-studio-code-oss.desktop
source = product_json.patch
- sha1sums = 27868bbab5ecb5313daf419b4fcba81c1d4ad1dc
- sha1sums = 1f08aa48cfa0ec57114ad906db48a35e59e077be
+ sha1sums = 7be23cfef9dced748e0c3a105b69c7e5b9e48d29
+ sha1sums = 3603936424a566452537d6931e9b3d56d04ad7ef
sha1sums = ba8febe936932080610d899fdb57294fc2f9f614
pkgname = visual-studio-code-oss
diff --git a/PKGBUILD b/PKGBUILD
index 6079053f6f9b..bd0be81fa765 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: Michael Hansen <zrax0111 gmail com>
+# Contributor: Francisco Magalhães <franmagneto gmail com>
# Set this to 0 if you want to include only the open-source Visual Studio Code
# components. This will cause the extension manager to work in a local-only
@@ -7,10 +8,10 @@
pkgname=visual-studio-code-oss
pkgdesc='Visual Studio Code for Linux, Open Source version'
-pkgver=1.7.1
-pkgrel=2
-_commit=02611b40b24c9df2726ad8b33f5ef5f67ac30b44
-arch=('i686' 'x86_64')
+pkgver=1.7.2
+pkgrel=1
+_commit=7ba55c5860b152d999dda59393ca3ebeb1b5c85f
+arch=('i686' 'x86_64' 'armv7h')
url='https://code.visualstudio.com/'
license=('MIT')
makedepends=('npm' 'nodejs>=6.8.0' 'gulp' 'python2' 'git')
@@ -20,13 +21,13 @@ provides=('vscode-oss')
source=("${pkgver}-${pkgrel}.tar.gz::https://github.com/Microsoft/vscode/archive/${_commit}.tar.gz"
"${pkgname}.desktop")
-sha1sums=('27868bbab5ecb5313daf419b4fcba81c1d4ad1dc'
- '1f08aa48cfa0ec57114ad906db48a35e59e077be')
+sha1sums=('7be23cfef9dced748e0c3a105b69c7e5b9e48d29'
+ '3603936424a566452537d6931e9b3d56d04ad7ef')
if (( VSCODE_NONFREE )); then
source+=('product_json.patch')
sha1sums+=('ba8febe936932080610d899fdb57294fc2f9f614')
- install='visual-studio-code-oss.nonfree.install'
+ install="${pkgname}.nonfree.install"
license+=('proprietary')
fi
@@ -37,6 +38,9 @@ case "$CARCH" in
x86_64)
_vscode_arch=x64
;;
+ armv7h)
+ _vscode_arch=arm
+ ;;
*)
# Needed for mksrcinfo
_vscode_arch=DUMMY
@@ -49,7 +53,7 @@ prepare() {
if (( VSCODE_NONFREE )); then
patch -p1 -i "${srcdir}/product_json.patch"
_datestamp=$(date -u -Is | sed 's/\+00:00/Z/')
- sed -e "s/@COMMIT@/$_commit/" -e "s/@DATE@/$_datestamp/" \
+ sed -e "s/@COMMIT@/${_commit}/" -e "s/@DATE@/${_datestamp}/" \
-i product.json
fi
}
@@ -59,10 +63,11 @@ build() {
./scripts/npm.sh install --arch=${_vscode_arch}
- # The default memory limit is too low for current versions of node to
- # successfully build vscode. This will set it to 2GB -- change it if
- # this number still doesn't work for your system.
- node --max_old_space_size=2048 /usr/bin/gulp vscode-linux-${_vscode_arch}
+ # The default memory limit may be too low for current versions of node
+ # to successfully build vscode. Uncomment this to set it to 2GB, or
+ # change it if this number still doesn't work for your system.
+ #mem_limit="--max_ols_space_size=2048"
+ node $mem_limit /usr/bin/gulp vscode-linux-${_vscode_arch}
}
package() {
diff --git a/visual-studio-code-oss.desktop b/visual-studio-code-oss.desktop
index 17d52ec5fad2..df090409ea06 100644
--- a/visual-studio-code-oss.desktop
+++ b/visual-studio-code-oss.desktop
@@ -1,6 +1,7 @@
[Desktop Entry]
Encoding=UTF-8
Name=Visual Studio Code (Open Source)
+Comment=Source code editor and debugger for modern web and cloud applications
Version=1.0
Exec="/opt/VSCode-OSS/bin/code-oss" %F
Icon=/opt/VSCode-OSS/resources/app/resources/linux/code.png