summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhe Park2022-04-01 12:07:46 +0800
committerSainnhe Park2022-04-01 12:07:46 +0800
commit13e955cda29bff77a7f849278c27e788581e6e36 (patch)
tree2562a78699684c0f75bab7d2927ed938f92c0afb
parent3cab758f797e99d440953e144149595b5f13c9e4 (diff)
downloadaur-13e955cda29bff77a7f849278c27e788581e6e36.tar.gz
Don't handle `linkProtectionTrustedDomains`
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rwxr-xr-xpatch.sh6
3 files changed, 6 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d418b6343842..9697f75c63dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = code-features
pkgdesc = Unblock some features in Code OSS
pkgver = 1.66.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/microsoft/vscode
install = code-features.install
arch = any
@@ -14,6 +14,6 @@ pkgbase = code-features
source = code-features.hook
source = patch.sh
md5sums = 5d5bd889095a60ffbf1918d5a2a08bdb
- md5sums = df24ddf83b21d0a96d515311a8021d49
+ md5sums = 3d94d3e6e2a49e790bcab78b65d949a4
pkgname = code-features
diff --git a/PKGBUILD b/PKGBUILD
index 02689d330bd9..15eecf2429e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Sainnhe Park <sainnhe@gmail.com>
pkgname=code-features
pkgver=1.66.0
-pkgrel=1
+pkgrel=2
pkgdesc='Unblock some features in Code OSS'
arch=('any')
url='https://github.com/microsoft/vscode'
@@ -14,7 +14,7 @@ install="${pkgname}.install"
source=("${pkgname}.hook"
'patch.sh')
md5sums=('5d5bd889095a60ffbf1918d5a2a08bdb'
- 'df24ddf83b21d0a96d515311a8021d49')
+ '3d94d3e6e2a49e790bcab78b65d949a4')
package() {
install -Dm 644 "${srcdir}/${pkgname}.hook" "${pkgdir}/usr/share/libalpm/hooks/${pkgname}.hook"
diff --git a/patch.sh b/patch.sh
index d04af1bd3003..d5ed46878496 100755
--- a/patch.sh
+++ b/patch.sh
@@ -3,7 +3,6 @@
if [ "${1}" = "-R" ]; then
sed -i -e 's/^[[:blank:]]*"nameLong":.*/\t"nameLong": "Code - OSS",/' \
-e '/^[[:blank:]]*"extensionEnabledApiProposals"/d' \
- -e '/^[[:blank:]]*"documentationUrl"/i\\t"linkProtectionTrustedDomains": ["https:\/\/open-vsx.org"],' \
-e '/^[[:blank:]]*"extensionSyncedKeys/d' \
/usr/lib/code/product.json
else
@@ -11,12 +10,11 @@ else
# Use vim to visual select "extensionEnabledApiProposals"
# Then press :join<CR>
# To patch sync server:
- # Use vim to visual select "extensionSyncedKeys" "linkProtectionTrustedDomains" "auth" "configurationSync.store"
+ # Use vim to visual select "extensionSyncedKeys" "auth" "configurationSync.store"
# Then press :join<CR>
# Select joined line and execute :'<,'>s/\//\\\//g
sed -i -e 's/^[[:blank:]]*"nameLong":.*/\t"nameLong": "Visual Studio Code",/' \
-e '/^[[:blank:]]*"extensionsGallery"/i\\t"extensionEnabledApiProposals": { "ms-vscode.vscode-selfhost-test-provider": ["testObserver"], "VisualStudioExptTeam.vscodeintellicode-completions": ["inlineCompletions"], "ms-vsliveshare.vsliveshare": ["contribMenuBarHome", "diffCommand", "documentFiltersExclusive", "fileSearchProvider", "findTextInFiles", "notebookCellExecutionState", "notebookContentProvider", "notebookDocumentEvents", "notebookEditor", "notebookEditorEdit", "notebookLiveShare", "terminalDimensions", "terminalDataWriteEvent", "textDocumentNotebook", "textSearchProvider"], "ms-vscode.js-debug": ["portsAttributes", "findTextInFiles", "workspaceTrust", "resolvers"], "ms-toolsai.vscode-ai-remote": ["resolvers", "notebookEditor"], "ms-python.python": ["quickPickSortByLabel", "testObserver", "notebookEditor"], "ms-dotnettools.dotnet-interactive-vscode": ["notebookConcatTextDocument", "notebookContentProvider", "notebookCellExecutionState", "notebookControllerKind", "notebookDebugOptions", "notebookDeprecated", "notebookEditor", "notebookEditorDecorationType", "notebookEditorEdit", "notebookLiveShare", "notebookMessaging", "notebookMime", "textDocumentNotebook"], "GitHub.codespaces": ["contribMenuBarHome", "contribRemoteHelp", "contribViewsRemote", "notebookEditor", "resolvers", "terminalDataWriteEvent", "treeViewReveal"], "ms-vscode.azure-repos": ["extensionRuntime", "fileSearchProvider", "resolvers", "textSearchProvider"], "ms-vscode.remote-repositories": ["contribRemoteHelp", "contribMenuBarHome", "contribViewsRemote", "contribViewsWelcome", "documentFiltersExclusive", "extensionRuntime", "fileSearchProvider", "quickPickSortByLabel", "workspaceTrust", "scmSelectedProvider", "scmValidation", "textSearchProvider", "timeline", "notebookEditor"], "ms-vscode.vscode-github-issue-notebooks": ["notebookEditor"], "tanhakabir.rest-book": ["notebookEditor"], "ms-vscode-remote.remote-wsl": ["resolvers", "contribViewsRemote", "telemetry"], "ms-vscode-remote.remote-ssh": ["resolvers", "terminalDataWriteEvent", "contribViewsRemote", "telemetry"], "ms-vscode-remote.remote-containers": ["resolvers", "workspaceTrust", "terminalDimensions", "contribViewsRemote"], "ms-vscode.js-debug-nightly": ["portsAttributes", "findTextInFiles", "workspaceTrust", "resolvers"], "ms-vscode.lsif-browser": ["documentFiltersExclusive"], "GitHub.vscode-pull-request-github": ["tokenInformation"], "GitHub.copilot": ["inlineCompletions", "textDocumentNotebook"], "GitHub.copilot-nightly": ["inlineCompletions", "textDocumentNotebook"], "GitHub.remotehub": ["contribRemoteHelp", "contribMenuBarHome", "contribViewsRemote", "contribViewsWelcome", "documentFiltersExclusive", "extensionRuntime", "fileSearchProvider", "quickPickSortByLabel", "workspaceTrust", "resolvers", "scmSelectedProvider", "scmValidation", "textSearchProvider", "timeline", "notebookEditor"], "GitHub.remotehub-insiders": ["contribRemoteHelp", "contribMenuBarHome", "contribViewsRemote", "contribViewsWelcome", "documentFiltersExclusive", "extensionRuntime", "fileSearchProvider", "quickPickSortByLabel", "workspaceTrust", "resolvers", "scmSelectedProvider", "scmValidation", "textSearchProvider", "timeline", "notebookEditor"], "ms-python.gather": ["notebookEditor", "notebookCellExecutionState"], "ms-python.vscode-pylance": ["notebookDocumentEvents", "notebookEditor", "notebookCellExecutionState"], "ms-toolsai.jupyter": ["notebookConcatTextDocument", "notebookControllerKind", "notebookDebugOptions", "notebookDeprecated", "notebookEditor", "notebookDocumentEvents", "notebookEditorDecorationType", "notebookEditorEdit", "notebookMessaging", "notebookMime", "notebookCellExecutionState", "portsAttributes", "textDocumentNotebook", "quickPickSortByLabel"], "dbaeumer.vscode-eslint": ["tabs", "notebookDocumentEvents", "notebookEditor", "notebookCellExecutionState"], "ms-vscode.azure-sphere-tools-ui": ["resolvers"], "ms-azuretools.vscode-azureappservice": ["terminalDataWriteEvent"] },' \
- -e '/^[[:blank:]]*"linkProtectionTrustedDomains/d' \
- -e '/^[[:blank:]]*"extensionsGallery/i\\t"extensionSyncedKeys": { "ritwickdey.liveserver": ["liveServer.setup.version"] }, "linkProtectionTrustedDomains": ["https:\/\/*.visualstudio.com", "https:\/\/*.microsoft.com", "https:\/\/aka.ms", "https:\/\/vscode-auth.github.com", "https:\/\/client-auth-staging-14a768b.herokuapp.com", "https:\/\/*.gallerycdn.vsassets.io", "https:\/\/github.com\/microsoft\/", "https:\/\/github.com\/MicrosoftDocs\/", "https:\/\/login.microsoftonline.com"], "auth": { "loginUrl": "https:\/\/login.microsoftonline.com\/common\/oauth2\/authorize", "tokenUrl": "https:\/\/login.microsoftonline.com\/common\/oauth2\/token", "redirectUrl": "https:\/\/vscode-redirect.azurewebsites.net\/", "clientId": "aebc6443-996d-45c2-90f0-388ff96faa56" }, "configurationSync.store": { "url": "https:\/\/vscode-sync.trafficmanager.net\/", "stableUrl": "https:\/\/vscode-sync.trafficmanager.net\/", "insidersUrl": "https:\/\/vscode-sync-insiders.trafficmanager.net\/", "canSwitch": false, "authenticationProviders": { "microsoft": { "scopes": ["openid", "profile", "email", "offline_access"] }, "github": { "scopes": ["user:email"] } } },' \
+ -e '/^[[:blank:]]*"extensionsGallery/i\\t"extensionSyncedKeys": { "ritwickdey.liveserver": ["liveServer.setup.version"] }, "auth": { "loginUrl": "https:\/\/login.microsoftonline.com\/common\/oauth2\/authorize", "tokenUrl": "https:\/\/login.microsoftonline.com\/common\/oauth2\/token", "redirectUrl": "https:\/\/vscode-redirect.azurewebsites.net\/", "clientId": "aebc6443-996d-45c2-90f0-388ff96faa56" }, "configurationSync.store": { "url": "https:\/\/vscode-sync.trafficmanager.net\/", "stableUrl": "https:\/\/vscode-sync.trafficmanager.net\/", "insidersUrl": "https:\/\/vscode-sync-insiders.trafficmanager.net\/", "canSwitch": false, "authenticationProviders": { "microsoft": { "scopes": ["openid", "profile", "email", "offline_access"] }, "github": { "scopes": ["user:email"] } } },' \
/usr/lib/code/product.json
fi