summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhe Park2024-04-10 19:28:09 +0800
committerSainnhe Park2024-04-10 19:28:09 +0800
commit2eeb30177263ac35d408b615d6faac900591eade (patch)
tree7d17ed39a4b529b4152d74a77c2928c397ba3b33
parent104b7b34c905561e9ae17a95a72557f26e6d7a85 (diff)
downloadaur-2eeb30177263ac35d408b615d6faac900591eade.tar.gz
Update to 1.88.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--patch.json34
-rwxr-xr-xupdate.py2
4 files changed, 26 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3bfc9e31c72a..dce567529127 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = code-features
pkgdesc = Unblock some features in Code OSS
- pkgver = 1.87.0
- pkgrel = 2
+ pkgver = 1.88.0
+ pkgrel = 1
url = https://github.com/microsoft/vscode
install = code-features.install
arch = any
@@ -17,6 +17,6 @@ pkgbase = code-features
source = patch.json
md5sums = 1d4002cba0560dd6da192ddd756f52e5
md5sums = 9ed6f3972479ab6d3d053e7c47ead55a
- md5sums = 1d9f06e2ed16e3100f41eb6c69a81638
+ md5sums = 3825c66c686454d02425c8b265f0d499
pkgname = code-features
diff --git a/PKGBUILD b/PKGBUILD
index 66bd501ef9e7..42a36b644509 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Sainnhe Park <sainnhe@gmail.com>
pkgname=code-features
-pkgver=1.87.0
-pkgrel=2
+pkgver=1.88.0
+pkgrel=1
pkgdesc='Unblock some features in Code OSS'
arch=('any')
url='https://github.com/microsoft/vscode'
@@ -16,7 +16,7 @@ source=("${pkgname}.hook"
'patch.json')
md5sums=('1d4002cba0560dd6da192ddd756f52e5'
'9ed6f3972479ab6d3d053e7c47ead55a'
- '1d9f06e2ed16e3100f41eb6c69a81638')
+ '3825c66c686454d02425c8b265f0d499')
package() {
install -Dm 644 "${srcdir}/${pkgname}.hook" "${pkgdir}/usr/share/libalpm/hooks/${pkgname}.hook"
diff --git a/patch.json b/patch.json
index e8357122e2a5..2e33be43fca8 100644
--- a/patch.json
+++ b/patch.json
@@ -292,15 +292,14 @@
"settingsSearchUrl": "https://bingsettingssearch.trafficmanager.net/api/Search",
"extensionEnabledApiProposals": {
"ms-vscode.vscode-selfhost-test-provider": [
- "testObserver",
- "testCoverage"
- ],
- "ms-vscode.extension-test-runner": [
- "testCoverage"
+ "testObserver"
],
"VisualStudioExptTeam.vscodeintellicode-completions": [
"inlineCompletionsAdditions"
],
+ "ms-toolsai.datawrangler": [
+ "debugFocus"
+ ],
"ms-vsliveshare.vsliveshare": [
"contribMenuBarHome",
"contribShareMenu",
@@ -321,9 +320,6 @@
"workspaceTrust",
"tunnels"
],
- "vscjava.vscode-java-test": [
- "testCoverage"
- ],
"ms-toolsai.vscode-ai-remote": [
"resolvers"
],
@@ -335,7 +331,8 @@
"testObserver",
"quickPickItemTooltip",
"terminalDataWriteEvent",
- "terminalExecuteCommandEvent"
+ "terminalExecuteCommandEvent",
+ "contribIssueReporter"
],
"ms-dotnettools.dotnet-interactive-vscode": [
"notebookMessaging"
@@ -425,7 +422,10 @@
],
"GitHub.vscode-pull-request-github": [
"activeComment",
+ "commentingRangeHint",
+ "commentThreadApplicability",
"contribCommentThreadAdditionalMenu",
+ "contribCommentsViewThreadMenus",
"tokenInformation",
"codeActionRanges",
"commentReactor",
@@ -465,7 +465,10 @@
"textSearchProvider",
"contribSourceControlInputBoxMenu",
"newSymbolNamesProvider",
- "findFiles2"
+ "findFiles2",
+ "extensionsAny",
+ "authLearnMore",
+ "testObserver"
],
"GitHub.remotehub": [
"contribRemoteHelp",
@@ -489,7 +492,8 @@
"notebookCellExecutionState"
],
"ms-python.debugpy": [
- "portsAttributes"
+ "portsAttributes",
+ "contribIssueReporter"
],
"ms-toolsai.jupyter-renderers": [
"contribNotebookStaticPreloads"
@@ -507,6 +511,7 @@
"contribNotebookStaticPreloads",
"quickPickItemTooltip",
"notebookExecution",
+ "notebookCellExecution",
"notebookVariableProvider"
],
"dbaeumer.vscode-eslint": [
@@ -734,7 +739,6 @@
},
"trustedExtensionAuthAccess": {
"github": [
- "vscode.git",
"vscode.github",
"github.remotehub",
"ms-vscode.remote-server",
@@ -745,7 +749,6 @@
"ms-vsliveshare.vsliveshare"
],
"github-enterprise": [
- "vscode.git",
"vscode.github",
"github.remotehub",
"ms-vscode.remote-server",
@@ -756,7 +759,6 @@
"ms-vsliveshare.vsliveshare"
],
"microsoft": [
- "vscode.git",
"ms-vscode.azure-repos",
"ms-vscode.remote-server",
"ms-vsliveshare.vsliveshare",
@@ -764,7 +766,6 @@
"ms-edu.vscode-learning"
],
"microsoft-sovereign-cloud": [
- "vscode.git",
"ms-vscode.azure-repos",
"ms-vscode.remote-server",
"ms-vsliveshare.vsliveshare",
@@ -839,5 +840,6 @@
]
}
}
- }
+ },
+ "enableTelemetry": false
} \ No newline at end of file
diff --git a/update.py b/update.py
index ff54586d9a35..3db26ed6bb33 100755
--- a/update.py
+++ b/update.py
@@ -48,5 +48,7 @@ patch_data = {}
for key in key_list:
patch_data[key] = product_data[key]
+patch_data["enableTelemetry"] = False
+
with open(patch_path, "w") as patch_file:
json.dump(patch_data, patch_file, indent='\t')