summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhe Park2021-04-06 15:47:27 +0800
committerSainnhe Park2021-04-06 15:47:27 +0800
commit4fa65f69476bc2469ac0d57b57f1f1f87a806366 (patch)
treecceb4039018bc3bbbed7933a5658caab8dbbf98b
parentd35bd6be1223aa8fe2bf00f82446012bb7d2accc (diff)
downloadaur-4fa65f69476bc2469ac0d57b57f1f1f87a806366.tar.gz
support settings sync
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rwxr-xr-xpatch.sh3
3 files changed, 15 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 41a4341c78d2..64703348f031 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,21 @@
pkgbase = code-features
pkgdesc = Unblock some features in Code OSS
pkgver = 1.54.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/microsoft/vscode
install = code-features.install
arch = any
license = unknown
depends = code
depends = sed
+ optdepends = org.freedesktop.secrets: for settings sync feature
+ optdepends = libsecret: for settings sync feature
+ provides = code-features
+ conflicts = code-features
source = code-features.hook
source = patch.sh
md5sums = 5d5bd889095a60ffbf1918d5a2a08bdb
- md5sums = ce2b2c47777f18bb8842b7ff5dd530a2
+ md5sums = 5af300de3e3efbfd071425b832c83313
pkgname = code-features
diff --git a/PKGBUILD b/PKGBUILD
index 72722325c3ec..a5144190d422 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,21 @@
# Maintainer: Sainnhe Park <sainnhe@gmail.com>
pkgname=code-features
pkgver=1.54.3
-pkgrel=1
+pkgrel=2
pkgdesc='Unblock some features in Code OSS'
arch=('any')
url='https://github.com/microsoft/vscode'
license=('unknown')
depends=('code' 'sed')
+optdepends=('org.freedesktop.secrets: for settings sync feature'
+ 'libsecret: for settings sync feature')
+provides=('code-features')
+conflicts=('code-features')
install="${pkgname}.install"
source=("${pkgname}.hook"
'patch.sh')
md5sums=('5d5bd889095a60ffbf1918d5a2a08bdb'
- 'ce2b2c47777f18bb8842b7ff5dd530a2')
+ '5af300de3e3efbfd071425b832c83313')
package() {
install -Dm 644 "${srcdir}/${pkgname}.hook" "${pkgdir}/usr/share/libalpm/hooks/${pkgname}.hook"
diff --git a/patch.sh b/patch.sh
index 07effc093b46..3adeea24b933 100755
--- a/patch.sh
+++ b/patch.sh
@@ -3,9 +3,12 @@
if [ "${1}" = "-R" ]; then
sed -i -e 's/^[[:blank:]]*"nameLong":.*/\t"nameLong": "Code - OSS",/' \
-e 's/^[[:blank:]]*"extensionAllowedProposedApi":.*/\t"extensionAllowedProposedApi": ["ms-vscode.vscode-js-profile-flame", "ms-vscode.vscode-js-profile-table", "ms-vscode.github-browser", "ms-vscode.github-richnav"],/' \
+ -e '/^[[:blank:]]*"extensionSyncedKeys/d' \
/usr/lib/code/product.json
else
sed -i -e 's/^[[:blank:]]*"nameLong":.*/\t"nameLong": "Visual Studio Code",/' \
-e 's/^[[:blank:]]*"extensionAllowedProposedApi":.*/\t"extensionAllowedProposedApi": ["GitHub.codespaces", "GitHub.vscode-pull-request-github-insiders", "GitHub.vscode-pull-request-github", "Microsoft.vscode-nmake-tools", "ms-ai-tools.notebook-renderers", "ms-dotnettools.dotnet-interactive-vscode", "ms-python.gather", "ms-python.python", "ms-toolsai.jupyter", "ms-toolsai.vscode-ai", "ms-toolsai.vscode-ai-remote", "ms-vscode-remote.remote-containers-nightly", "ms-vscode-remote.remote-containers", "ms-vscode-remote.remote-ssh-edit-nightly", "ms-vscode-remote.remote-ssh-edit", "ms-vscode-remote.remote-ssh-nightly", "ms-vscode-remote.remote-ssh", "ms-vscode-remote.remote-wsl-nightly", "ms-vscode-remote.remote-wsl", "ms-vscode-remote.remote-wsl-recommender", "ms-vscode-remote.vscode-remote-extensionpack-nightly", "ms-vscode-remote.vscode-remote-extensionpack", "ms-vscode.azure-account", "ms-vscode.azure-sphere-tools-ui", "ms-vscode.azure-sphere-tools", "ms-vscode.github-browser", "ms-vscode.github-richnav", "ms-vscode.js-debug-nightly", "ms-vscode.js-debug", "ms-vscode.lsif-browser", "ms-vscode.vscode-js-profile-flame", "ms-vscode.vscode-js-profile-table", "ms-vscode.vscode-selfhost-test-provider", "ms-vsliveshare.cloudenv-explorer", "ms-vsliveshare.cloudenv", "ms-vsliveshare.vsliveshare", "ms-vsonline.vsonline", "dbaeumer.vscode-eslint"],/' \
+ -e '/^[[:blank:]]*"extensionSyncedKeys/d' \
+ -e '/^[[:blank:]]*"extensionAllowedProposedApi/a\\t"extensionSyncedKeys": { "ritwickdey.liveserver": ["liveServer.setup.version"] }, "linkProtectionTrustedDomains": ["https:\/\/*.visualstudio.com", "https:\/\/*.microsoft.com", "https:\/\/aka.ms", "https:\/\/vscode-auth.github.com", "https:\/\/*.gallerycdn.vsassets.io", "https:\/\/github.com\/microsoft\/", "https:\/\/github.com\/MicrosoftDocs\/", "https:\/\/login.microsoftonline.com"], "auth": { "loginUrl": "https:\/\/login.microsoftonline.com\/common\/oauth2\/authorize", "tokenUrl": "https:\/\/login.microsoftonline.com\/common\/oauth2\/token", "redirectUrl": "https:\/\/vscode-redirect.azurewebsites.net\/", "clientId": "aebc6443-996d-45c2-90f0-388ff96faa56" }, "configurationSync.store": { "url": "https:\/\/vscode-sync.trafficmanager.net\/", "stableUrl": "https:\/\/vscode-sync.trafficmanager.net\/", "insidersUrl": "https:\/\/vscode-sync-insiders.trafficmanager.net\/", "canSwitch": false, "authenticationProviders": { "microsoft": { "scopes": ["https:\/\/management.core.windows.net\/.default", "offline_access"] }, "github": { "scopes": ["user:email"] } } },' \
/usr/lib/code/product.json
fi