summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhe Park2022-08-06 10:35:42 +0800
committerSainnhe Park2022-08-06 10:35:42 +0800
commitbdcf431ee8837b97bb9e0059645dae386a2f118c (patch)
tree9f6c01168fc3d5e7ecfaf828e923547f6768537e
parent5580b513693a5b9a45ddcc10708ac89730d6bc9f (diff)
downloadaur-bdcf431ee8837b97bb9e0059645dae386a2f118c.tar.gz
Update to 1.70.0
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rwxr-xr-xpatch.sh6
3 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a92850b1f80..dca0c843be7f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = code-features
pkgdesc = Unblock some features in Code OSS
- pkgver = 1.69.0
+ pkgver = 1.70.0
pkgrel = 1
url = https://github.com/microsoft/vscode
install = code-features.install
@@ -14,6 +14,6 @@ pkgbase = code-features
source = code-features.hook
source = patch.sh
md5sums = 5d5bd889095a60ffbf1918d5a2a08bdb
- md5sums = e69b0dffde4fef8b7056e36b83446cee
+ md5sums = bd0f2f3cac790e132ca90fe0f1cd78e1
pkgname = code-features
diff --git a/PKGBUILD b/PKGBUILD
index d5d43cb6eb64..b505b0268d60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Sainnhe Park <sainnhe@gmail.com>
pkgname=code-features
-pkgver=1.69.0
+pkgver=1.70.0
pkgrel=1
pkgdesc='Unblock some features in Code OSS'
arch=('any')
@@ -13,7 +13,7 @@ install="${pkgname}.install"
source=("${pkgname}.hook"
'patch.sh')
md5sums=('5d5bd889095a60ffbf1918d5a2a08bdb'
- 'e69b0dffde4fef8b7056e36b83446cee')
+ 'bd0f2f3cac790e132ca90fe0f1cd78e1')
package() {
install -Dm 644 "${srcdir}/${pkgname}.hook" "${pkgdir}/usr/share/libalpm/hooks/${pkgname}.hook"
diff --git a/patch.sh b/patch.sh
index 6bd3f8b5041f..c9c7bd295515 100755
--- a/patch.sh
+++ b/patch.sh
@@ -10,11 +10,11 @@ else
# Use vim to visual select "extensionEnabledApiProposals"
# Then press :join<CR>
# To patch sync server:
- # Use vim to visual select "extensionSyncedKeys" "auth" "configurationSync.store"
+ # Use vim to visual select "extensionSyncedKeys" "auth" "configurationSync.store" "editSessions.store"
# Then press :join<CR>
# Select joined line and execute :'<,'>s/\//\\\//g
sed -i -e 's/^[[:blank:]]*"nameLong":.*/\t"nameLong": "Visual Studio Code",/' \
- -e '/^[[:blank:]]*"extensionsGallery"/i\\t"extensionEnabledApiProposals": { "ms-vscode.vscode-selfhost-test-provider": ["testObserver"], "VisualStudioExptTeam.vscodeintellicode-completions": ["inlineCompletionsNew", "inlineCompletionsAdditions"], "ms-vsliveshare.vsliveshare": ["contribMenuBarHome", "diffCommand", "documentFiltersExclusive", "fileSearchProvider", "findTextInFiles", "notebookCellExecutionState", "notebookContentProvider", "notebookEditor", "notebookEditorEdit", "notebookLiveShare", "notebookWorkspaceEdit", "terminalDimensions", "terminalDataWriteEvent", "textSearchProvider"], "ms-vscode.js-debug": ["portsAttributes", "findTextInFiles", "workspaceTrust", "resolvers"], "ms-toolsai.vscode-ai-remote": ["resolvers", "notebookEditor"], "ms-python.python": ["quickPickSortByLabel", "testObserver", "notebookEditor"], "ms-dotnettools.dotnet-interactive-vscode": ["notebookCellExecutionState", "notebookControllerKind", "notebookDebugOptions", "notebookEditor", "notebookLiveShare", "notebookMessaging", "notebookMime", "notebookWorkspaceEdit"], "GitHub.codespaces": ["contribMenuBarHome", "contribRemoteHelp", "contribViewsRemote", "notebookEditor", "resolvers", "terminalDataWriteEvent", "treeViewReveal"], "ms-vscode.azure-repos": ["extensionRuntime", "fileSearchProvider", "textSearchProvider"], "ms-vscode.remote-repositories": ["contribEditSessions", "contribRemoteHelp", "contribMenuBarHome", "contribViewsRemote", "contribViewsWelcome", "documentFiltersExclusive", "extensionRuntime", "fileSearchProvider", "quickPickSortByLabel", "workspaceTrust", "scmSelectedProvider", "scmValidation", "textSearchProvider", "timeline", "notebookEditor"], "ms-vscode.remote-server": ["resolvers"], "ms-vscode-remote.remote-wsl": ["resolvers", "contribViewsRemote", "telemetry"], "ms-vscode-remote.remote-ssh": ["resolvers", "terminalDataWriteEvent", "contribViewsRemote", "telemetry"], "ms-vscode-remote.remote-containers": ["resolvers", "workspaceTrust", "terminalDimensions", "contribViewsRemote"], "ms-vscode.js-debug-nightly": ["portsAttributes", "findTextInFiles", "workspaceTrust", "resolvers"], "ms-vscode.lsif-browser": ["documentFiltersExclusive"], "GitHub.vscode-pull-request-github": ["tokenInformation", "commentsResolvedState"], "GitHub.copilot": ["inlineCompletionsNew", "inlineCompletionsAdditions"], "GitHub.copilot-nightly": ["inlineCompletionsNew", "inlineCompletionsAdditions"], "GitHub.remotehub": ["contribRemoteHelp", "contribMenuBarHome", "contribViewsRemote", "contribViewsWelcome", "documentFiltersExclusive", "extensionRuntime", "fileSearchProvider", "quickPickSortByLabel", "workspaceTrust", "scmSelectedProvider", "scmValidation", "textSearchProvider", "timeline", "notebookEditor"], "GitHub.remotehub-insiders": ["contribRemoteHelp", "contribMenuBarHome", "contribViewsRemote", "contribViewsWelcome", "documentFiltersExclusive", "extensionRuntime", "fileSearchProvider", "quickPickSortByLabel", "workspaceTrust", "scmSelectedProvider", "scmValidation", "textSearchProvider", "timeline", "notebookEditor"], "ms-python.gather": ["notebookEditor", "notebookCellExecutionState"], "ms-python.vscode-pylance": ["notebookEditor", "notebookCellExecutionState"], "ms-toolsai.jupyter": ["notebookControllerKind", "notebookDebugOptions", "notebookDeprecated", "notebookEditor", "notebookWorkspaceEdit", "notebookMessaging", "notebookMime", "notebookCellExecutionState", "portsAttributes", "quickPickSortByLabel", "notebookKernelSource"], "ms-toolsai.vscode-jupyter-powertoys": ["notebookEditor", "notebookEditorEdit", "notebookWorkspaceEdit"], "dbaeumer.vscode-eslint": ["notebookEditor", "notebookCellExecutionState"], "ms-vscode.azure-sphere-tools-ui": ["resolvers"], "ms-azuretools.vscode-azureappservice": ["terminalDataWriteEvent"], "ms-vscode.anycode": ["extensionsAny"], "ms-vscode.cpptools": ["terminalDataWriteEvent"] },' \
- -e '/^[[:blank:]]*"extensionsGallery/i\\t"extensionSyncedKeys": { "ritwickdey.liveserver": ["liveServer.setup.version"] }, "auth": { "loginUrl": "https:\/\/login.microsoftonline.com\/common\/oauth2\/authorize", "tokenUrl": "https:\/\/login.microsoftonline.com\/common\/oauth2\/token", "redirectUrl": "https:\/\/vscode-redirect.azurewebsites.net\/", "clientId": "aebc6443-996d-45c2-90f0-388ff96faa56" }, "configurationSync.store": { "url": "https:\/\/vscode-sync.trafficmanager.net\/", "stableUrl": "https:\/\/vscode-sync.trafficmanager.net\/", "insidersUrl": "https:\/\/vscode-sync-insiders.trafficmanager.net\/", "canSwitch": false, "authenticationProviders": { "microsoft": { "scopes": ["openid", "profile", "email", "offline_access"] }, "github": { "scopes": ["user:email"] } } },' \
+ -e '/^[[:blank:]]*"extensionsGallery"/i\\t"extensionEnabledApiProposals": { "ms-vscode.vscode-selfhost-test-provider": ["testObserver"], "VisualStudioExptTeam.vscodeintellicode-completions": ["inlineCompletionsNew", "inlineCompletionsAdditions"], "ms-vsliveshare.vsliveshare": ["contribMenuBarHome", "diffCommand", "documentFiltersExclusive", "fileSearchProvider", "findTextInFiles", "notebookCellExecutionState", "notebookContentProvider", "notebookEditor", "notebookEditorEdit", "notebookLiveShare", "notebookWorkspaceEdit", "terminalDimensions", "terminalDataWriteEvent", "textSearchProvider"], "ms-vscode.js-debug": ["portsAttributes", "findTextInFiles", "workspaceTrust", "resolvers"], "ms-toolsai.vscode-ai-remote": ["resolvers", "notebookEditor"], "ms-python.python": ["quickPickSortByLabel", "testObserver"], "ms-dotnettools.dotnet-interactive-vscode": ["notebookCellExecutionState", "notebookControllerKind", "notebookDebugOptions", "notebookEditor", "notebookLiveShare", "notebookMessaging", "notebookMime", "notebookWorkspaceEdit"], "GitHub.codespaces": ["contribEditSessions", "contribMenuBarHome", "contribRemoteHelp", "contribViewsRemote", "notebookEditor", "resolvers", "terminalDataWriteEvent", "treeViewReveal"], "ms-vscode.azure-repos": ["extensionRuntime", "fileSearchProvider", "textSearchProvider"], "ms-vscode.remote-repositories": ["contribEditSessions", "contribRemoteHelp", "contribMenuBarHome", "contribViewsRemote", "contribViewsWelcome", "documentFiltersExclusive", "extensionRuntime", "fileSearchProvider", "quickPickSortByLabel", "workspaceTrust", "scmSelectedProvider", "scmValidation", "textSearchProvider", "timeline"], "ms-vscode-remote.remote-wsl": ["resolvers", "contribViewsRemote", "telemetry"], "ms-vscode-remote.remote-ssh": ["resolvers", "terminalDataWriteEvent", "contribViewsRemote", "telemetry"], "ms-vscode.remote-server": ["resolvers", "contribViewsRemote"], "ms-vscode-remote.remote-containers": ["resolvers", "workspaceTrust", "terminalDimensions", "contribViewsRemote"], "ms-vscode.js-debug-nightly": ["portsAttributes", "findTextInFiles", "workspaceTrust", "resolvers"], "ms-vscode.lsif-browser": ["documentFiltersExclusive"], "GitHub.vscode-pull-request-github": ["tokenInformation", "commentsResolvedState", "badges", "contribViewSize"], "GitHub.copilot": ["inlineCompletionsNew", "inlineCompletionsAdditions"], "GitHub.copilot-nightly": ["inlineCompletionsNew", "inlineCompletionsAdditions"], "GitHub.remotehub": ["contribRemoteHelp", "contribMenuBarHome", "contribViewsRemote", "contribViewsWelcome", "documentFiltersExclusive", "extensionRuntime", "fileSearchProvider", "quickPickSortByLabel", "workspaceTrust", "scmSelectedProvider", "scmValidation", "textSearchProvider", "timeline"], "GitHub.remotehub-insiders": ["contribRemoteHelp", "contribMenuBarHome", "contribViewsRemote", "contribViewsWelcome", "documentFiltersExclusive", "extensionRuntime", "fileSearchProvider", "quickPickSortByLabel", "workspaceTrust", "scmSelectedProvider", "scmValidation", "textSearchProvider", "timeline"], "ms-python.gather": ["notebookCellExecutionState"], "ms-python.vscode-pylance": ["notebookEditor", "notebookCellExecutionState"], "ms-toolsai.jupyter": ["notebookControllerKind", "notebookDebugOptions", "notebookDeprecated", "notebookWorkspaceEdit", "notebookMessaging", "notebookMime", "notebookCellExecutionState", "portsAttributes", "quickPickSortByLabel", "notebookKernelSource", "interactiveWindow"], "ms-toolsai.vscode-jupyter-powertoys": ["notebookWorkspaceEdit"], "dbaeumer.vscode-eslint": ["notebookCellExecutionState"], "ms-vscode.azure-sphere-tools-ui": ["resolvers"], "ms-azuretools.vscode-azureappservice": ["terminalDataWriteEvent"], "ms-vscode.anycode": ["extensionsAny"], "ms-vscode.cpptools": ["terminalDataWriteEvent"] },' \
+ -e '/^[[:blank:]]*"extensionsGallery/i\\t"extensionSyncedKeys": { "ritwickdey.liveserver": ["liveServer.setup.version"] }, "auth": { "loginUrl": "https:\/\/login.microsoftonline.com\/common\/oauth2\/authorize", "tokenUrl": "https:\/\/login.microsoftonline.com\/common\/oauth2\/token", "redirectUrl": "https:\/\/vscode-redirect.azurewebsites.net\/", "clientId": "aebc6443-996d-45c2-90f0-388ff96faa56" }, "configurationSync.store": { "url": "https:\/\/vscode-sync.trafficmanager.net\/", "stableUrl": "https:\/\/vscode-sync.trafficmanager.net\/", "insidersUrl": "https:\/\/vscode-sync-insiders.trafficmanager.net\/", "canSwitch": false, "authenticationProviders": { "microsoft": { "scopes": ["openid", "profile", "email", "offline_access"] }, "github": { "scopes": ["user:email"] } } }, "editSessions.store": { "url": "https:\/\/vscode-sync.trafficmanager.net\/", "authenticationProviders": { "microsoft": { "scopes": ["openid", "profile", "email", "offline_access"] }, "github": { "scopes": ["user:email"] } } },' \
/usr/lib/code/product.json
fi