summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhe Park2022-02-04 21:17:46 +0800
committerSainnhe Park2022-02-04 21:17:46 +0800
commit5869512bf196a37173a33dcb89c4ebf87964d1f5 (patch)
tree993e6dd0ac5f2b9430d8775a11dca59bf90b8a1d
parent7674488ff25c080dada7d3bde61b1281b6aa0754 (diff)
downloadaur-5869512bf196a37173a33dcb89c4ebf87964d1f5.tar.gz
Update to 1.64.0
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rwxr-xr-xpatch.sh9
3 files changed, 12 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 21875c49aa7e..87ad624c9e41 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = code-features-insiders
pkgdesc = Unblock some features in Code OSS, including features in VSCode Insiders
- pkgver = 1.63.2
+ pkgver = 1.64.0
pkgrel = 1
url = https://github.com/microsoft/vscode
install = code-features-insiders.install
@@ -14,6 +14,6 @@ pkgbase = code-features-insiders
source = code-features-insiders.hook
source = patch.sh
md5sums = 6ff3e599956e45e9d1a78ac3c88c0454
- md5sums = 5d1923cac94f0a4253c0155fc5bd9cb7
+ md5sums = 68c84f2b9cc5f52a565cba655a7eb58a
pkgname = code-features-insiders
diff --git a/PKGBUILD b/PKGBUILD
index 8bec6182d518..98e29c77cf29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Sainnhe Park <sainnhe@gmail.com>
pkgname=code-features-insiders
-pkgver=1.63.2
+pkgver=1.64.0
pkgrel=1
pkgdesc='Unblock some features in Code OSS, including features in VSCode Insiders'
arch=('any')
@@ -14,7 +14,7 @@ install="${pkgname}.install"
source=("${pkgname}.hook"
'patch.sh')
md5sums=('6ff3e599956e45e9d1a78ac3c88c0454'
- '5d1923cac94f0a4253c0155fc5bd9cb7')
+ '68c84f2b9cc5f52a565cba655a7eb58a')
package() {
install -Dm 644 "${srcdir}/${pkgname}.hook" "${pkgdir}/usr/share/libalpm/hooks/${pkgname}.hook"
diff --git a/patch.sh b/patch.sh
index d1239fdf1bf0..8aff480a7994 100755
--- a/patch.sh
+++ b/patch.sh
@@ -6,8 +6,15 @@ if [ "${1}" = "-R" ]; then
-e '/^[[:blank:]]*"extensionSyncedKeys/d' \
/usr/lib/code/product.json
else
+ # To patch proposed api:
+ # Use vim to visual select "extensionAllowedProposedApi" and "extensionEnabledApiProposals"
+ # Then press :join<CR>
+ # To patch sync server:
+ # Use vim to visual select "extensionSyncedKeys" "linkProtectionTrustedDomains" "auth" "configurationSync.store"
+ # Then press :join<CR>
+ # Select joined line and execute :'<,'>s/\//\\\//g
sed -i -e 's/^[[:blank:]]*"nameLong":.*/\t"nameLong": "Visual Studio Code - Insiders",/' \
- -e 's/^[[:blank:]]*"extensionAllowedProposedApi":.*/\t"extensionAllowedProposedApi": ["GitHub.codespaces", "GitHub.vscode-pull-request-github-insiders", "ms-dotnettools.dotnet-interactive-vscode", "ms-python.gather", "ms-python.python", "ms-toolsai.vscode-ai", "ms-toolsai.vscode-ai-remote", "ms-vscode-remote.remote-ssh-nightly", "ms-vscode.azure-account", "ms-vscode.azure-sphere-tools", "ms-vscode.js-debug", "ms-vscode.vscode-selfhost-test-provider", "ms-vsliveshare.vsliveshare", "ms-vsonline.vsonline", "VisualStudioExptTeam.vscodeintellicode", "VisualStudioExptTeam.vscodeintellicode-insiders", "VisualStudioExptTeam.vscodeintellicode-completions", "ms-azuretools.vscode-azureappservice"],/' \
+ -e 's/^[[:blank:]]*"extensionAllowedProposedApi":.*/\t"extensionAllowedProposedApi": ["GitHub.codespaces", "GitHub.vscode-pull-request-github-insiders", "ms-dotnettools.dotnet-interactive-vscode", "ms-python.gather", "ms-python.python", "ms-toolsai.vscode-ai", "ms-toolsai.vscode-ai-remote", "ms-vscode-remote.remote-ssh-nightly", "ms-vscode.azure-account", "ms-vscode.azure-sphere-tools", "ms-vscode.js-debug", "ms-vscode.vscode-selfhost-test-provider", "ms-vsliveshare.vsliveshare", "ms-vsonline.vsonline", "VisualStudioExptTeam.vscodeintellicode", "VisualStudioExptTeam.vscodeintellicode-insiders", "VisualStudioExptTeam.vscodeintellicode-completions", "ms-azuretools.vscode-azureappservice"], "extensionEnabledApiProposals": { "ms-vscode.anycode": ["languageStatus"], "ms-vscode.azure-repos": ["fileSearchProvider", "textSearchProvider"], "ms-vscode.vscode-github-issue-notebooks": ["notebookEditor"], "tanhakabir.rest-book": ["notebookEditor"], "ms-vscode-remote.remote-wsl": ["resolvers", "contribViewsRemote"], "ms-vscode-remote.remote-ssh": ["resolvers", "terminalDataWriteEvent", "contribViewsRemote"], "ms-vscode-remote.remote-containers": ["resolvers", "workspaceTrust", "terminalDimensions", "contribViewsRemote"], "ms-vscode.js-debug-nightly": ["portsAttributes", "findTextInFiles", "workspaceTrust", "resolvers"], "ms-vscode.lsif-browser": ["documentFiltersExclusive"], "GitHub.vscode-pull-request-github": ["tokenInformation", "commentTimestamp"], "GitHub.copilot": ["inlineCompletions", "textDocumentNotebook", "contribIcons", "contribIconFonts"], "GitHub.copilot-nightly": ["inlineCompletions", "textDocumentNotebook", "contribIcons", "contribIconFonts"], "GitHub.remotehub": ["contribRemoteHelp", "contribMenuBarHome", "contribViewsRemote", "contribViewsWelcome", "documentFiltersExclusive", "extensionRuntime", "fileSearchProvider", "quickPickSortByLabel", "workspaceTrust", "resolvers", "scmSelectedProvider", "scmValidation", "textSearchProvider", "timeline", "notebookEditor"], "GitHub.remotehub-insiders": ["contribRemoteHelp", "contribMenuBarHome", "contribViewsRemote", "contribViewsWelcome", "documentFiltersExclusive", "extensionRuntime", "fileSearchProvider", "quickPickSortByLabel", "workspaceTrust", "resolvers", "scmSelectedProvider", "scmValidation", "textSearchProvider", "timeline", "notebookEditor"], "ms-toolsai.jupyter": ["notebookConcatTextDocument", "notebookControllerKind", "notebookDebugOptions", "notebookDeprecated", "notebookEditor", "notebookEditorDecorationType", "notebookEditorEdit", "notebookMessaging", "notebookMime", "notebookCellExecutionState", "portsAttributes", "textDocumentNotebook", "quickPickSortByLabel"] },/' \
-e '/^[[:blank:]]*"extensionSyncedKeys/d' \
-e '/^[[:blank:]]*"extensionAllowedProposedApi/a\\t"extensionSyncedKeys": { "ritwickdey.liveserver": ["liveServer.setup.version"] }, "linkProtectionTrustedDomains": ["https:\/\/*.visualstudio.com", "https:\/\/*.microsoft.com", "https:\/\/aka.ms", "https:\/\/vscode-auth.github.com", "https:\/\/client-auth-staging-14a768b.herokuapp.com", "https:\/\/*.gallerycdn.vsassets.io", "https:\/\/github.com\/microsoft\/", "https:\/\/github.com\/MicrosoftDocs\/", "https:\/\/login.microsoftonline.com"], "auth": { "loginUrl": "https:\/\/login.microsoftonline.com\/common\/oauth2\/authorize", "tokenUrl": "https:\/\/login.microsoftonline.com\/common\/oauth2\/token", "redirectUrl": "https:\/\/vscode-redirect.azurewebsites.net\/", "clientId": "aebc6443-996d-45c2-90f0-388ff96faa56" }, "configurationSync.store": { "url": "https:\/\/vscode-sync-insiders.trafficmanager.net\/", "stableUrl": "https:\/\/vscode-sync.trafficmanager.net\/", "insidersUrl": "https:\/\/vscode-sync-insiders.trafficmanager.net\/", "canSwitch": true, "authenticationProviders": { "microsoft": { "scopes": ["openid", "profile", "email", "offline_access"] }, "github": { "scopes": ["user:email"] } } },' \
/usr/lib/code/product.json