summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhe Park2022-08-06 10:41:10 +0800
committerSainnhe Park2022-08-06 10:41:10 +0800
commite2c9f12841794f02b0c7668a1c7a696d5c2c30df (patch)
treea52ed6a4f3ce6bed3b2bd9361aec0d0f25720bc1
parent7c93b2b76627e019fc6d794d3a90dabd8d9be1d1 (diff)
downloadaur-e2c9f12841794f02b0c7668a1c7a696d5c2c30df.tar.gz
Update to 1.70.0
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rwxr-xr-xpatch.sh6
3 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aeb05d3fe121..05b2052ab8d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = code-features-insiders
pkgdesc = Unblock some features in Code OSS, including features in VSCode Insiders
- pkgver = 1.69.0
+ pkgver = 1.70.0
pkgrel = 1
url = https://github.com/microsoft/vscode
install = code-features-insiders.install
@@ -14,6 +14,6 @@ pkgbase = code-features-insiders
source = code-features-insiders.hook
source = patch.sh
md5sums = 6ff3e599956e45e9d1a78ac3c88c0454
- md5sums = a4149e42e63507268033a013bf816af5
+ md5sums = aa94e56cf041781ed7a7a4a4623e9edf
pkgname = code-features-insiders
diff --git a/PKGBUILD b/PKGBUILD
index a3d2ea9b461e..a9d1096c8c35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Sainnhe Park <sainnhe@gmail.com>
pkgname=code-features-insiders
-pkgver=1.69.0
+pkgver=1.70.0
pkgrel=1
pkgdesc='Unblock some features in Code OSS, including features in VSCode Insiders'
arch=('any')
@@ -14,7 +14,7 @@ install="${pkgname}.install"
source=("${pkgname}.hook"
'patch.sh')
md5sums=('6ff3e599956e45e9d1a78ac3c88c0454'
- 'a4149e42e63507268033a013bf816af5')
+ 'aa94e56cf041781ed7a7a4a4623e9edf')
package() {
install -Dm 644 "${srcdir}/${pkgname}.hook" "${pkgdir}/usr/share/libalpm/hooks/${pkgname}.hook"
diff --git a/patch.sh b/patch.sh
index 907db76ddd87..9347abdee412 100755
--- a/patch.sh
+++ b/patch.sh
@@ -10,11 +10,11 @@ else
# Use vim to visual select "extensionEnabledApiProposals"
# Then press :join<CR>
# To patch sync server:
- # Use vim to visual select "extensionSyncedKeys" "auth" "configurationSync.store"
+ # Use vim to visual select "extensionSyncedKeys" "auth" "configurationSync.store" "editSessions.store"
# Then press :join<CR>
# Select joined line and execute :'<,'>s/\//\\\//g
sed -i -e 's/^[[:blank:]]*"nameLong":.*/\t"nameLong": "Visual Studio Code - Insiders",/' \
- -e '/^[[:blank:]]*"extensionsGallery"/i\\t"extensionEnabledApiProposals": { "ms-vscode.vscode-selfhost-test-provider": ["testObserver"], "VisualStudioExptTeam.vscodeintellicode-completions": ["inlineCompletionsNew", "inlineCompletionsAdditions"], "ms-vsliveshare.vsliveshare": ["contribMenuBarHome", "diffCommand", "documentFiltersExclusive", "fileSearchProvider", "findTextInFiles", "notebookCellExecutionState", "notebookContentProvider", "notebookEditor", "notebookEditorEdit", "notebookLiveShare", "notebookWorkspaceEdit", "terminalDimensions", "terminalDataWriteEvent", "textSearchProvider"], "ms-vscode.js-debug": ["portsAttributes", "findTextInFiles", "workspaceTrust", "resolvers"], "ms-toolsai.vscode-ai-remote": ["resolvers", "notebookEditor"], "ms-python.python": ["quickPickSortByLabel", "testObserver", "notebookEditor"], "ms-dotnettools.dotnet-interactive-vscode": ["notebookCellExecutionState", "notebookControllerKind", "notebookDebugOptions", "notebookEditor", "notebookLiveShare", "notebookMessaging", "notebookMime", "notebookWorkspaceEdit"], "GitHub.codespaces": ["contribMenuBarHome", "contribRemoteHelp", "contribViewsRemote", "notebookEditor", "resolvers", "terminalDataWriteEvent", "treeViewReveal"], "ms-vscode.azure-repos": ["extensionRuntime", "fileSearchProvider", "textSearchProvider"], "ms-vscode.remote-repositories": ["contribEditSessions", "contribRemoteHelp", "contribMenuBarHome", "contribViewsRemote", "contribViewsWelcome", "documentFiltersExclusive", "extensionRuntime", "fileSearchProvider", "quickPickSortByLabel", "workspaceTrust", "scmSelectedProvider", "scmValidation", "textSearchProvider", "timeline", "notebookEditor"], "ms-vscode-remote.remote-wsl": ["resolvers", "contribViewsRemote", "telemetry"], "ms-vscode.remote-server": ["resolvers", "contribViewsRemote"], "ms-vscode-remote.remote-ssh": ["resolvers", "terminalDataWriteEvent", "contribViewsRemote", "telemetry"], "ms-vscode-remote.remote-containers": ["resolvers", "workspaceTrust", "terminalDimensions", "contribViewsRemote"], "ms-vscode.js-debug-nightly": ["portsAttributes", "findTextInFiles", "workspaceTrust", "resolvers"], "ms-vscode.lsif-browser": ["documentFiltersExclusive"], "GitHub.vscode-pull-request-github": ["tokenInformation", "commentsResolvedState"], "GitHub.copilot": ["inlineCompletionsNew", "inlineCompletionsAdditions"], "GitHub.copilot-nightly": ["inlineCompletionsNew", "inlineCompletionsAdditions"], "GitHub.remotehub": ["contribRemoteHelp", "contribMenuBarHome", "contribViewsRemote", "contribViewsWelcome", "documentFiltersExclusive", "extensionRuntime", "fileSearchProvider", "quickPickSortByLabel", "workspaceTrust", "scmSelectedProvider", "scmValidation", "textSearchProvider", "timeline", "notebookEditor"], "GitHub.remotehub-insiders": ["contribRemoteHelp", "contribMenuBarHome", "contribViewsRemote", "contribViewsWelcome", "documentFiltersExclusive", "extensionRuntime", "fileSearchProvider", "quickPickSortByLabel", "workspaceTrust", "scmSelectedProvider", "scmValidation", "textSearchProvider", "timeline", "notebookEditor"], "ms-python.gather": ["notebookEditor", "notebookCellExecutionState"], "ms-python.vscode-pylance": ["notebookEditor", "notebookCellExecutionState"], "ms-toolsai.jupyter": ["notebookControllerKind", "notebookDebugOptions", "notebookDeprecated", "notebookEditor", "notebookWorkspaceEdit", "notebookMessaging", "notebookMime", "notebookCellExecutionState", "portsAttributes", "quickPickSortByLabel", "notebookKernelSource"], "ms-toolsai.vscode-jupyter-powertoys": ["notebookEditor", "notebookEditorEdit", "notebookWorkspaceEdit"], "dbaeumer.vscode-eslint": ["notebookEditor", "notebookCellExecutionState"], "ms-vscode.azure-sphere-tools-ui": ["resolvers"], "ms-azuretools.vscode-azureappservice": ["terminalDataWriteEvent"], "ms-vscode.anycode": ["extensionsAny"], "ms-vscode.cpptools": ["terminalDataWriteEvent"] },' \
- -e '/^[[:blank:]]*"extensionsGallery/i\\t"extensionSyncedKeys": { "ritwickdey.liveserver": ["liveServer.setup.version"] }, "auth": { "loginUrl": "https:\/\/login.microsoftonline.com\/common\/oauth2\/authorize", "tokenUrl": "https:\/\/login.microsoftonline.com\/common\/oauth2\/token", "redirectUrl": "https:\/\/vscode-redirect.azurewebsites.net\/", "clientId": "aebc6443-996d-45c2-90f0-388ff96faa56" }, "configurationSync.store": { "url": "https:\/\/vscode-sync-insiders.trafficmanager.net\/", "stableUrl": "https:\/\/vscode-sync.trafficmanager.net\/", "insidersUrl": "https:\/\/vscode-sync-insiders.trafficmanager.net\/", "canSwitch": true, "authenticationProviders": { "microsoft": { "scopes": ["openid", "profile", "email", "offline_access"] }, "github": { "scopes": ["user:email"] } } },' \
+ -e '/^[[:blank:]]*"extensionsGallery"/i\\t"extensionEnabledApiProposals": { "ms-vscode.vscode-selfhost-test-provider": ["testObserver"], "VisualStudioExptTeam.vscodeintellicode-completions": ["inlineCompletionsNew", "inlineCompletionsAdditions"], "ms-vsliveshare.vsliveshare": ["contribMenuBarHome", "diffCommand", "documentFiltersExclusive", "fileSearchProvider", "findTextInFiles", "notebookCellExecutionState", "notebookContentProvider", "notebookEditor", "notebookEditorEdit", "notebookLiveShare", "notebookWorkspaceEdit", "terminalDimensions", "terminalDataWriteEvent", "textSearchProvider"], "ms-vscode.js-debug": ["portsAttributes", "findTextInFiles", "workspaceTrust", "resolvers"], "ms-toolsai.vscode-ai-remote": ["resolvers", "notebookEditor"], "ms-python.python": ["quickPickSortByLabel", "testObserver"], "ms-dotnettools.dotnet-interactive-vscode": ["notebookMessaging", "notebookWorkspaceEdit"], "GitHub.codespaces": ["contribEditSessions", "contribMenuBarHome", "contribRemoteHelp", "contribViewsRemote", "resolvers", "terminalDataWriteEvent", "treeViewReveal"], "ms-vscode.azure-repos": ["extensionRuntime", "fileSearchProvider", "textSearchProvider"], "ms-vscode.remote-repositories": ["contribEditSessions", "contribRemoteHelp", "contribMenuBarHome", "contribViewsRemote", "contribViewsWelcome", "documentFiltersExclusive", "extensionRuntime", "fileSearchProvider", "quickPickSortByLabel", "workspaceTrust", "scmSelectedProvider", "scmValidation", "textSearchProvider", "timeline"], "ms-vscode-remote.remote-wsl": ["resolvers", "contribViewsRemote", "telemetry"], "ms-vscode-remote.remote-ssh": ["resolvers", "terminalDataWriteEvent", "contribViewsRemote", "telemetry"], "ms-vscode.remote-server": ["resolvers", "contribViewsRemote"], "ms-vscode-remote.remote-containers": ["resolvers", "workspaceTrust", "terminalDimensions", "contribViewsRemote"], "ms-vscode.js-debug-nightly": ["portsAttributes", "findTextInFiles", "workspaceTrust", "resolvers"], "ms-vscode.lsif-browser": ["documentFiltersExclusive"], "GitHub.vscode-pull-request-github": ["tokenInformation", "commentsResolvedState", "badges", "contribViewSize"], "GitHub.copilot": ["inlineCompletionsNew", "inlineCompletionsAdditions"], "GitHub.copilot-nightly": ["inlineCompletionsNew", "inlineCompletionsAdditions"], "GitHub.remotehub": ["contribRemoteHelp", "contribMenuBarHome", "contribViewsRemote", "contribViewsWelcome", "documentFiltersExclusive", "extensionRuntime", "fileSearchProvider", "quickPickSortByLabel", "workspaceTrust", "scmSelectedProvider", "scmValidation", "textSearchProvider", "timeline"], "ms-python.gather": ["notebookCellExecutionState"], "ms-python.vscode-pylance": ["notebookCellExecutionState"], "ms-toolsai.jupyter": ["notebookControllerKind", "notebookDebugOptions", "notebookDeprecated", "notebookWorkspaceEdit", "notebookMessaging", "notebookMime", "notebookCellExecutionState", "portsAttributes", "quickPickSortByLabel", "notebookKernelSource", "interactiveWindow"], "ms-toolsai.vscode-jupyter-powertoys": ["notebookWorkspaceEdit"], "dbaeumer.vscode-eslint": ["notebookCellExecutionState"], "ms-vscode.azure-sphere-tools-ui": ["resolvers"], "ms-azuretools.vscode-azureappservice": ["terminalDataWriteEvent"], "ms-vscode.anycode": ["extensionsAny"], "ms-vscode.cpptools": ["terminalDataWriteEvent"] },' \
+ -e '/^[[:blank:]]*"extensionsGallery/i\\t"extensionSyncedKeys": { "ritwickdey.liveserver": ["liveServer.setup.version"] }, "auth": { "loginUrl": "https:\/\/login.microsoftonline.com\/common\/oauth2\/authorize", "tokenUrl": "https:\/\/login.microsoftonline.com\/common\/oauth2\/token", "redirectUrl": "https:\/\/vscode-redirect.azurewebsites.net\/", "clientId": "aebc6443-996d-45c2-90f0-388ff96faa56" }, "configurationSync.store": { "url": "https:\/\/vscode-sync-insiders.trafficmanager.net\/", "stableUrl": "https:\/\/vscode-sync.trafficmanager.net\/", "insidersUrl": "https:\/\/vscode-sync-insiders.trafficmanager.net\/", "canSwitch": true, "authenticationProviders": { "microsoft": { "scopes": ["openid", "profile", "email", "offline_access"] }, "github": { "scopes": ["user:email"] } } }, "editSessions.store": { "url": "https:\/\/vscode-sync.trafficmanager.net\/", "authenticationProviders": { "microsoft": { "scopes": ["openid", "profile", "email", "offline_access"] }, "github": { "scopes": ["user:email"] } } },' \
/usr/lib/code/product.json
fi