summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Hansen2017-12-10 10:50:31 -0800
committerMichael Hansen2017-12-10 10:50:48 -0800
commit820a8c0fba577893ddad0678429784b6b14d17d9 (patch)
tree3fed6f39f1006d99e4b59c0c08eff6b9bc598416
parent9e15c8fc1d6e7e93d4431890d5f70ba6e7eca08e (diff)
downloadaur-820a8c0fba577893ddad0678429784b6b14d17d9.tar.gz
Update PKGBUILD for yarn-based build (note: npm is still needed by yarn)
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD35
2 files changed, 7 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3a7d80db75b..21ba434b46d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Jul 24 17:55:19 UTC 2017
+# Sun Dec 10 18:50:38 UTC 2017
pkgbase = visual-studio-code-git
pkgdesc = Visual Studio Code for Linux, Open Source version from git
- pkgver = 1.1.0.insider.r10766.gd41c48d46
+ pkgver = 1.16.0.r4189.g6e71921951
pkgrel = 1
url = https://code.visualstudio.com/
arch = i686
@@ -14,6 +14,7 @@ pkgbase = visual-studio-code-git
makedepends = gulp
makedepends = python2
makedepends = git
+ makedepends = yarn
depends = gtk2
depends = gconf
depends = libnotify
diff --git a/PKGBUILD b/PKGBUILD
index 310acd0741d9..f63e7e102add 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,12 +8,12 @@
pkgname=visual-studio-code-git
pkgdesc='Visual Studio Code for Linux, Open Source version from git'
-pkgver=1.1.0.insider.r16716.g37c73f0c71
+pkgver=1.16.0.r4189.g6e71921951
pkgrel=1
arch=('i686' 'x86_64' 'armv7h')
url='https://code.visualstudio.com/'
license=('MIT')
-makedepends=('npm' 'nodejs>=6.8.0' 'gulp' 'python2' 'git')
+makedepends=('npm' 'nodejs>=6.8.0' 'gulp' 'python2' 'git' 'yarn')
depends=('gtk2' 'gconf' 'libnotify' 'libxss' 'libxtst' 'libxkbfile' 'nss'
'alsa-lib')
conflicts=('vscode-oss' 'visual-studio-code-oss')
@@ -66,42 +66,15 @@ prepare() {
fi
}
-# npm.sh wrapper puts things in the user's home directory...
-# To avoid that, we perform its environment setup manually instead
-npm_wrap() {
- (
- ROOT="${srcdir}/vscode"
- ELECTRON_VERSION=$(
- cat "$ROOT"/package.json |
- grep electronVersion |
- sed -e 's/[[:space:]]*"electronVersion":[[:space:]]*"\([0-9.]*\)"\(,\)*/\1/'
- )
-
- ELECTRON_GYP_HOME="${srcdir}/electron-gyp"
- mkdir -p $ELECTRON_GYP_HOME
-
- npm_config_disturl=https://atom.io/download/electron \
- npm_config_target=$ELECTRON_VERSION \
- npm_config_runtime=electron \
- HOME=$ELECTRON_GYP_HOME \
- npm $*
- )
-}
-
build() {
cd "${srcdir}/vscode"
- # The provided shrinkwrap file doesn't work correctly with npm 5.x
- # Therefore, we install an older version and use that for the build
- ( cd "${srcdir}" && /usr/bin/npm install 'npm@4.6.1' )
- PATH="${srcdir}/node_modules/.bin":$PATH
-
- npm_wrap install --arch=${_vscode_arch}
+ yarn install --arch=${_vscode_arch}
# The default memory limit may be too low for current versions of node
# to successfully build vscode. Uncomment this to set it to 2GB, or
# change it if this number still doesn't work for your system.
- #mem_limit="--max_old_space_size=2048"
+ mem_limit="--max_old_space_size=2048"
/usr/bin/node $mem_limit /usr/bin/gulp vscode-linux-${_vscode_arch}
# Patch the startup script to know where the app is installed, rather