summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Dewar2020-03-30 16:55:53 +0100
committerAlex Dewar2020-03-30 16:55:53 +0100
commite2c0d3867f7f850edcef36ba9f9c0896c18ba576 (patch)
tree1922c7ebdb5d5241571f4e2bf464f5e937309029
parente7240850b34a01f71066fe8e66933c1c3d39671b (diff)
downloadaur-e2c0d3867f7f850edcef36ba9f9c0896c18ba576.tar.gz
v1.44.0_20200330
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f5cf119fa45..3df15acf8f1c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = code-headmelted-bin
pkgdesc = Community builds of Visual Studio Code, including for ARM devices
- pkgver = 1.43.0_2020_02_17
+ pkgver = 1.44.0_20200330
pkgrel = 1
url = https://code.headmelted.com
arch = armv7h
@@ -19,10 +19,10 @@ pkgbase = code-headmelted-bin
conflicts = code
conflicts = vscode-headmelted-bin
replaces = vscode-headmelted-bin
- source_armv7h = https://github.com/headmelted/codebuilds/releases/download/17-Feb-20/code-oss_1.43.0-1581902153_armhf.deb
- md5sums_armv7h = 0ec2caf17318c9a89f2c58ce20707e4a
- source_aarch64 = https://github.com/headmelted/codebuilds/releases/download/17-Feb-20/code-oss_1.43.0-1581902160_arm64.deb
- md5sums_aarch64 = b4d37bd2a4651fdd8d65e6f1f7bb3836
+ source_armv7h = https://github.com/headmelted/codebuilds/releases/download/30-Mar-20/code-oss_1.44.0-1585531024_armhf.deb
+ md5sums_armv7h = 8f62b15408974d0c78b7e35b087a4bec
+ source_aarch64 = https://github.com/headmelted/codebuilds/releases/download/30-Mar-20/code-oss_1.44.0-1585531075_arm64.deb
+ md5sums_aarch64 = c346e8a9f870138bcb3e0a82ec13f0ce
pkgname = code-headmelted-bin
diff --git a/PKGBUILD b/PKGBUILD
index bd2f4dfe906f..d69b6755857c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
# Maintainer: Alex Dewar <a.dewar@sussex.ac.uk>
pkgname=code-headmelted-bin
-_pkgver=1.43.0
-_date=2020_02_17
-_url=https://github.com/headmelted/codebuilds/releases/download/17-Feb-20
-_armhf_build=1581902153
-_arm64_build=1581902160
-pkgver="${_pkgver}_${_date}"
+_pkgver=1.44.0
+_date=2020-03-30
+_fdate=`date --date=$_date '+%d-%b-%y'`
+_url=https://github.com/headmelted/codebuilds/releases/download/$_fdate
+_armhf_build=1585531024
+_arm64_build=1585531075
+pkgver="${_pkgver}_${_date//-/}"
pkgrel=1
pkgdesc="Community builds of Visual Studio Code, including for ARM devices"
arch=(armv7h aarch64)
@@ -18,8 +19,8 @@ replaces=(vscode-headmelted-bin)
conflicts=(code vscode-headmelted-bin)
source_armv7h=("$_url/code-oss_$_pkgver-${_armhf_build}_armhf.deb")
source_aarch64=("$_url/code-oss_$_pkgver-${_arm64_build}_arm64.deb")
-md5sums_armv7h=('0ec2caf17318c9a89f2c58ce20707e4a')
-md5sums_aarch64=('b4d37bd2a4651fdd8d65e6f1f7bb3836')
+md5sums_armv7h=('8f62b15408974d0c78b7e35b087a4bec')
+md5sums_aarch64=('c346e8a9f870138bcb3e0a82ec13f0ce')
package() {
msg2 "Extracting the data.tar.xz..."