summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-10-29 10:52:19 +0800
committerSainnhepark2020-10-29 10:52:19 +0800
commitb44ee5632b06f736bf605fd94b35ccf9f80fd27b (patch)
tree206acf591c97660664583bacd70780ef0d686435
parentf8cd96cfb05b48ce0bdd0d8dc3a66c7086f3038f (diff)
downloadaur-b44ee5632b06f736bf605fd94b35ccf9f80fd27b.tar.gz
update url and depends
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--code-marketplace.hook2
3 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca206263d8dd..713ca9907c0d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,14 +2,14 @@ pkgbase = code-marketplace
pkgdesc = Enable vscode marketplace in Code OSS
pkgver = 1.50.1
pkgrel = 1
- url = https://github.com/microsoft/vscode
+ url = https://marketplace.visualstudio.com/vscode
install = code-marketplace.install
arch = any
license = unknown
- depends = code
+ depends = code>=1.50.1
source = code-marketplace.hook
source = product_json.patch
- md5sums = a55c25aba17a6bf3f6e1327c853e8b35
+ md5sums = 8a5cbd751ee2762d40f1e43e9e6e69e0
md5sums = 9e476c8aae4243010d6a1c18e56ac402
pkgname = code-marketplace
diff --git a/PKGBUILD b/PKGBUILD
index fad605c5bf2c..6eb722b5737f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@ pkgver=1.50.1
pkgrel=1
pkgdesc='Enable vscode marketplace in Code OSS'
arch=('any')
-url='https://github.com/microsoft/vscode'
+url='https://marketplace.visualstudio.com/vscode'
license=('unknown')
-depends=('code')
+depends=('code>=1.50.1')
install="${pkgname}.install"
source=('code-marketplace.hook'
'product_json.patch')
-md5sums=('a55c25aba17a6bf3f6e1327c853e8b35'
+md5sums=('8a5cbd751ee2762d40f1e43e9e6e69e0'
'9e476c8aae4243010d6a1c18e56ac402')
package() {
diff --git a/code-marketplace.hook b/code-marketplace.hook
index ca596c200585..5e685e15dd88 100644
--- a/code-marketplace.hook
+++ b/code-marketplace.hook
@@ -5,6 +5,6 @@ Type = Path
Target = usr/lib/code/product.json
[Action]
-Description = Modifying product.json...
+Description = Patching product.json...
Exec = /usr/bin/bash -c "/usr/bin/patch /usr/lib/code/product.json < /usr/lib/code/product_json.patch"
When = PostTransaction