summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWenxuan Zhang2020-10-23 17:17:07 +0800
committerWenxuan Zhang2020-10-23 17:17:07 +0800
commit231cbc95cfc780f61803fe756d25756dfbdfc9e7 (patch)
tree0d9b3c5ede60b2d584319f189293e92f67ed127a
parentb31fdb53b02c7fc49d71b2963407e2c6ff84aed0 (diff)
downloadaur-231cbc95cfc780f61803fe756d25756dfbdfc9e7.tar.gz
add conflicts
-rw-r--r--.SRCINFO2
-rw-r--r--.pre-commit-config.yaml1
-rw-r--r--PKGBUILD7
-rw-r--r--PKGBUILD.tmpl7
4 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 373c52bc10cc..9344a9de24bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,6 +9,8 @@ pkgbase = code-minimap
license = APACHE
makedepends = rust
makedepends = cargo
+ conflicts = code-minimap-git
+ conflicts = code-minimap-bin
source = https://github.com/wfxr/code-minimap/archive/v0.4.2.tar.gz
md5sums = 3fece54f3539602477321493f6736a7d
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index 4fc8fc89b900..ac6362d4711a 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -5,7 +5,6 @@ repos:
rev: v3.1.0
hooks:
- id: trailing-whitespace
- - id: end-of-file-fixer
- id: check-added-large-files
- id: mixed-line-ending
- repo: local
diff --git a/PKGBUILD b/PKGBUILD
index 6f98c12dc584..233e0b694cab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,13 @@
pkgname=code-minimap
pkgver=0.4.2
pkgrel=1
-pkgdesc="A high performance code minimap render"
+pkgdesc='A high performance code minimap render'
arch=(i686 x86_64)
url="https://github.com/wfxr/code-minimap"
-license=("MIT" "APACHE")
+license=('MIT' 'APACHE')
depends=()
-makedepends=("rust" "cargo")
+makedepends=('rust' 'cargo')
+conflicts=("${pkgname}-git" "${pkgname}-bin")
source=("https://github.com/wfxr/${pkgname}/archive/v${pkgver}.tar.gz")
md5sums=('3fece54f3539602477321493f6736a7d')
diff --git a/PKGBUILD.tmpl b/PKGBUILD.tmpl
index 2cd8a4f2b3f5..3779011903d6 100644
--- a/PKGBUILD.tmpl
+++ b/PKGBUILD.tmpl
@@ -2,12 +2,13 @@
pkgname=code-minimap
pkgver={{PKGVER}}
pkgrel={{PKGREL}}
-pkgdesc="A high performance code minimap render"
+pkgdesc='A high performance code minimap render'
arch=(i686 x86_64)
url="https://github.com/wfxr/code-minimap"
-license=("MIT" "APACHE")
+license=('MIT' 'APACHE')
depends=()
-makedepends=("rust" "cargo")
+makedepends=('rust' 'cargo')
+conflicts=("${pkgname}-git" "${pkgname}-bin")
source=("https://github.com/wfxr/${pkgname}/archive/v${pkgver}.tar.gz")
md5sums=('{{MD5SUM}}')