summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWenxuan Zhang2020-09-26 12:57:40 +0800
committerWenxuan Zhang2020-09-26 12:57:40 +0800
commit93abb66a9819368518574f72e6b88d633f9e08d2 (patch)
tree60f265b7f6a9c36500612479109e525db0cbfa05
downloadaur-93abb66a9819368518574f72e6b88d633f9e08d2.tar.gz
init commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore2
-rw-r--r--.pre-commit-config.yaml19
-rw-r--r--PKGBUILD30
4 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a821d224cd7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = code-minimap
+ pkgdesc = A high performance code minimap render
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/wfxr/code-minimap
+ arch = i686
+ arch = x86_64
+ license = MIT
+ license = APACHE
+ makedepends = rust
+ makedepends = cargo
+ source = https://github.com/wfxr/code-minimap/archive/v0.3.0.tar.gz
+ md5sums = 031231c71e6648e07de1a3872c4aaed1
+
+pkgname = code-minimap
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ee591e8bed32
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+/src
+*.gz
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
new file mode 100644
index 000000000000..4fc8fc89b900
--- /dev/null
+++ b/.pre-commit-config.yaml
@@ -0,0 +1,19 @@
+# See https://pre-commit.com for more information
+# See https://pre-commit.com/hooks.html for more hooks
+repos:
+- repo: https://github.com/pre-commit/pre-commit-hooks
+ rev: v3.1.0
+ hooks:
+ - id: trailing-whitespace
+ - id: end-of-file-fixer
+ - id: check-added-large-files
+ - id: mixed-line-ending
+- repo: local
+ hooks:
+ - id: makepkg
+ name: makepkg
+ pass_filenames: false
+ always_run: true
+ language: system
+ entry: >
+ sh -c 'make codegen && git add PKGBUILD .SRCINFO'
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0aad21677c85
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Wenxuan <wenxuangm@gmail.com>
+pkgname=code-minimap
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="A high performance code minimap render"
+arch=(i686 x86_64)
+url="https://github.com/wfxr/code-minimap"
+license=("MIT" "APACHE")
+depends=()
+makedepends=("rust" "cargo")
+
+source=("https://github.com/wfxr/${pkgname}/archive/v${pkgver}.tar.gz")
+md5sums=('031231c71e6648e07de1a3872c4aaed1')
+
+build() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ cargo build --release
+}
+
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ install -Dm755 "target/release/${pkgname}" "$pkgdir/usr/bin/${pkgname}"
+ install -Dm644 "completions/fish/${pkgname}.fish" "$pkgdir/usr/share/fish/vendor_completions.d/${pkgname}.fish"
+ install -Dm644 "completions/zsh/_${pkgname}" "$pkgdir/usr/share/zsh/site-functions/_${pkgname}"
+ install -Dm644 "README.md" "$pkgdir/usr/share/doc/${pkgname}/README.md"
+ install -Dm644 "LICENSE-MIT" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE-MIT"
+ install -Dm644 "LICENSE-APACHE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE-APACHE"
+}
+
+# vim:set noet sts=0 sw=4 ts=4 ft=PKGBUILD: