summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrantic10482022-06-12 21:55:24 +0800
committerfrantic10482022-06-12 21:55:24 +0800
commit527aad56af9ff27991e195898a76a82b649483d0 (patch)
tree757de170780d508e9f0f2703f2239c6e56b3a6c2
parentbd568bcdaa26104dd1557682ed39a18642de223b (diff)
downloadaur-527aad56af9ff27991e195898a76a82b649483d0.tar.gz
upgpkg: code-transparent 1.67.2-2
add patch to make terminal transparent via: https://aur.archlinux.org/packages/code-transparent#comment-867126
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--fix-terminal-not-transparent.diff12
3 files changed, 25 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54e8f8a8ee26..34d9443536bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = code-transparent
pkgdesc = The Open Source build of Visual Studio Code (vscode) editor - with transparency enabled.
pkgver = 1.67.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/microsoft/vscode
install = code-transparent.install
arch = x86_64
@@ -29,11 +29,13 @@ pkgbase = code-transparent
source = product_json.diff
source = transparent.diff
source = fix-first-window-not-transparent.diff
+ source = fix-terminal-not-transparent.diff
sha512sums = SKIP
sha512sums = 6e8ee1df4dd982434a8295ca99e786a536457c86c34212546e548b115081798c5492a79f99cd5a3f1fa30fb71d29983aaabc2c79f4895d4a709d8354e9e2eade
sha512sums = b8bdb0e53cf8748140ed444c9b02cb6a57a7e1e120d96861d4cc9f79744a987f0253c052a238c78aa2c3f86459c4afb6f3b687435f0588d8f640822a9908b257
sha512sums = b1aa0d7c5b3e3e8ba1172822d75ea38e90efc431b270e0b4ca9e45bf9c0be0f60922c8618969ef071b5b6dbd9ac9f030294f1bf49bcc28c187b46d113dca63a7
- sha512sums = SKIP
+ sha512sums = 83a66451909a1829982b8c412447bf1cd1e2bdf7eea9fe8dcbb5facff0bf4a0d36a57d6e88af58ad8c22e005be0201567469e0704cc5420b2d1b94e255fb4b28
sha512sums = e662f0bf3f55a82ce9bce98f22c6be80ee83c1e2241d2eca596326478887ec6b73c7d0041903e17f35a424578ccc22674354931166dc7c7d7e76bb97135e009e
+ sha512sums = 2c047e9c10f9ae14c10ddfb36a1da6d8814a02213d35c9c5cd47a98da8b348797c32e8bc2ce8519485f45666501aded238074656af15efc67ad6140b3ff83942
pkgname = code-transparent
diff --git a/PKGBUILD b/PKGBUILD
index 52de8793c361..c6424b4bf2f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ pkgdesc='The Open Source build of Visual Studio Code (vscode) editor - with tran
# Important: Remember to check https://github.com/microsoft/vscode/blob/master/.yarnrc (choose correct tag) for target electron version
_electron=electron17
pkgver=1.67.2
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url='https://github.com/microsoft/vscode'
license=('MIT')
@@ -32,13 +32,15 @@ source=("$_pkgname::git+$url.git#tag=$pkgver"
'code.sh'
'product_json.diff'
'transparent.diff'
- 'fix-first-window-not-transparent.diff')
+ 'fix-first-window-not-transparent.diff'
+ 'fix-terminal-not-transparent.diff')
sha512sums=('SKIP'
'6e8ee1df4dd982434a8295ca99e786a536457c86c34212546e548b115081798c5492a79f99cd5a3f1fa30fb71d29983aaabc2c79f4895d4a709d8354e9e2eade'
'b8bdb0e53cf8748140ed444c9b02cb6a57a7e1e120d96861d4cc9f79744a987f0253c052a238c78aa2c3f86459c4afb6f3b687435f0588d8f640822a9908b257'
'b1aa0d7c5b3e3e8ba1172822d75ea38e90efc431b270e0b4ca9e45bf9c0be0f60922c8618969ef071b5b6dbd9ac9f030294f1bf49bcc28c187b46d113dca63a7'
- 'SKIP'
- 'e662f0bf3f55a82ce9bce98f22c6be80ee83c1e2241d2eca596326478887ec6b73c7d0041903e17f35a424578ccc22674354931166dc7c7d7e76bb97135e009e')
+ '83a66451909a1829982b8c412447bf1cd1e2bdf7eea9fe8dcbb5facff0bf4a0d36a57d6e88af58ad8c22e005be0201567469e0704cc5420b2d1b94e255fb4b28'
+ 'e662f0bf3f55a82ce9bce98f22c6be80ee83c1e2241d2eca596326478887ec6b73c7d0041903e17f35a424578ccc22674354931166dc7c7d7e76bb97135e009e'
+ '2c047e9c10f9ae14c10ddfb36a1da6d8814a02213d35c9c5cd47a98da8b348797c32e8bc2ce8519485f45666501aded238074656af15efc67ad6140b3ff83942')
# Even though we don't officially support other archs, let's
# allow the user to use this PKGBUILD to compile the package
@@ -78,6 +80,9 @@ prepare() {
# https://github.com/electron/electron/issues/16809
patch -p1 <../fix-first-window-not-transparent.diff
+ # https://aur.archlinux.org/packages/code-transparent#comment-867126
+ patch -p1 <../fix-terminal-not-transparent.diff
+
# Set the commit and build date
local _commit=$(git rev-parse HEAD)
local _datestamp=$(date -u -Is | sed 's/\+00:00/Z/')
diff --git a/fix-terminal-not-transparent.diff b/fix-terminal-not-transparent.diff
new file mode 100644
index 000000000000..295f3129bfee
--- /dev/null
+++ b/fix-terminal-not-transparent.diff
@@ -0,0 +1,12 @@
+diff --git a/src/vs/workbench/contrib/terminal/browser/xterm/xtermTerminal.ts b/src/vs/workbench/contrib/terminal/browser/xterm/xtermTerminal.ts
+index 30b72f90a8e..21855f79a52 100644
+--- a/src/vs/workbench/contrib/terminal/browser/xterm/xtermTerminal.ts
++++ b/src/vs/workbench/contrib/terminal/browser/xterm/xtermTerminal.ts
+@@ -125,6 +125,7 @@ export class XtermTerminal extends DisposableStore implements IXtermTerminal {
+ letterSpacing: font.letterSpacing,
+ lineHeight: font.lineHeight,
+ minimumContrastRatio: config.minimumContrastRatio,
++ allowTransparency: true,
+ cursorBlink: config.cursorBlinking,
+ cursorStyle: config.cursorStyle === 'line' ? 'bar' : config.cursorStyle,
+ cursorWidth: config.cursorWidth,