summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrantic10482020-11-26 16:46:15 +0800
committerfrantic10482020-11-26 16:46:15 +0800
commitc5860490b3f436e97f0d30ae6b4e65083af3d179 (patch)
treed19f41b2ec1c638a02145bf4650b58b1bbaa4b58
parente49fac23a599f6f0a5a50ebb2b2d413822807091 (diff)
downloadaur-c5860490b3f436e97f0d30ae6b4e65083af3d179.tar.gz
upgpkg: code-transparent 1.51.1-1
upstream release - add fix first window not transparent workaround patch.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--fix-first-window-not-transparent.diff10
3 files changed, 24 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 203c063a682f..2e0c5af6b31b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = code-transparent
pkgdesc = The Open Source build of Visual Studio Code (vscode) editor - with transparency enabled.
- pkgver = 1.50.1
+ pkgver = 1.51.1
pkgrel = 1
url = https://github.com/microsoft/vscode
install = code-transparent.install
@@ -22,16 +22,18 @@ pkgbase = code-transparent
optdepends = x11-ssh-askpass: SSH authentication
provides = code
conflicts = code
- source = code::git+https://github.com/microsoft/vscode.git#tag=1.50.1
+ source = code::git+https://github.com/microsoft/vscode.git#tag=1.51.1
source = code.js
source = code.sh
source = product_json.diff
source = transparent.diff
+ source = fix-first-window-not-transparent.diff
sha512sums = SKIP
sha512sums = 814c9554427183cd893a33cd2cbe91f6e0ea71921ef0717c86217b1d3058d265f9ff7a9ace3e7b76f122e60b7686475cf4d999e581a1845face3033afb9f745f
sha512sums = 0e75ee88274cbaf48c59ef6f363f6b8ac2ea83f8b17a61155008db773b709a1f0233754fa63a136ec0417313ba90a7eb17db000ec22a38ca8840d8ba6c47cab1
sha512sums = b1aa0d7c5b3e3e8ba1172822d75ea38e90efc431b270e0b4ca9e45bf9c0be0f60922c8618969ef071b5b6dbd9ac9f030294f1bf49bcc28c187b46d113dca63a7
sha512sums = ae7fc5d2d1851bf9353c3f531a4de05cc5b41496468e908776b7a17cf85e889c601b94499bd6165efb902578af1ebf37443a03881f98d8c6120cb4f8667d8fe7
+ sha512sums = e662f0bf3f55a82ce9bce98f22c6be80ee83c1e2241d2eca596326478887ec6b73c7d0041903e17f35a424578ccc22674354931166dc7c7d7e76bb97135e009e
pkgname = code-transparent
diff --git a/PKGBUILD b/PKGBUILD
index a187c45590d6..5c192fa34ddd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ pkgdesc='The Open Source build of Visual Studio Code (vscode) editor - with tran
# - erbium: 12
# Important: Remember to check https://github.com/microsoft/vscode/blob/master/.yarnrc (choose correct tag) for target electron version
_electron=electron9
-pkgver=1.50.1
+pkgver=1.51.1
pkgrel=1
arch=('x86_64')
url='https://github.com/microsoft/vscode'
@@ -31,12 +31,14 @@ source=("$_pkgname::git+$url.git#tag=$pkgver"
'code.js'
'code.sh'
'product_json.diff'
- 'transparent.diff')
+ 'transparent.diff'
+ 'fix-first-window-not-transparent.diff')
sha512sums=('SKIP'
'814c9554427183cd893a33cd2cbe91f6e0ea71921ef0717c86217b1d3058d265f9ff7a9ace3e7b76f122e60b7686475cf4d999e581a1845face3033afb9f745f'
'0e75ee88274cbaf48c59ef6f363f6b8ac2ea83f8b17a61155008db773b709a1f0233754fa63a136ec0417313ba90a7eb17db000ec22a38ca8840d8ba6c47cab1'
'b1aa0d7c5b3e3e8ba1172822d75ea38e90efc431b270e0b4ca9e45bf9c0be0f60922c8618969ef071b5b6dbd9ac9f030294f1bf49bcc28c187b46d113dca63a7'
- 'ae7fc5d2d1851bf9353c3f531a4de05cc5b41496468e908776b7a17cf85e889c601b94499bd6165efb902578af1ebf37443a03881f98d8c6120cb4f8667d8fe7')
+ 'ae7fc5d2d1851bf9353c3f531a4de05cc5b41496468e908776b7a17cf85e889c601b94499bd6165efb902578af1ebf37443a03881f98d8c6120cb4f8667d8fe7'
+ 'e662f0bf3f55a82ce9bce98f22c6be80ee83c1e2241d2eca596326478887ec6b73c7d0041903e17f35a424578ccc22674354931166dc7c7d7e76bb97135e009e')
# Even though we don't officially support other archs, let's
# allow the user to use this PKGBUILD to compile the package
@@ -70,6 +72,11 @@ prepare() {
# enable window transparency
patch -p1 <../transparent.diff
+ # fixes sometimes the first code window is not transparent
+ # https://aur.archlinux.org/packages/code-transparent/#comment-775691
+ # https://github.com/electron/electron/issues/16809
+ patch -p1 <../fix-first-window-not-transparent.diff
+
# Set the commit and build date
local _commit=$(git rev-parse HEAD)
local _datestamp=$(date -u -Is | sed 's/\+00:00/Z/')
diff --git a/fix-first-window-not-transparent.diff b/fix-first-window-not-transparent.diff
new file mode 100644
index 000000000000..4272ba08234d
--- /dev/null
+++ b/fix-first-window-not-transparent.diff
@@ -0,0 +1,10 @@
+--- a/src/vs/code/electron-main/app.ts 2020-10-29 17:51:27.330706163 +0800
++++ b/src/vs/code/electron-main/app.ts 2020-11-24 14:11:33.058005352 +0800
+@@ -322,6 +322,7 @@
+ }
+
+ async startup(): Promise<void> {
++ await new Promise((resolve) => setTimeout(resolve, 400));
+ this.logService.debug('Starting VS Code');
+ this.logService.debug(`from: ${this.environmentService.appRoot}`);
+ this.logService.debug('args:', this.environmentService.args);