summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-07-25 15:10:29 +0300
committerDimitris Kiziridis2020-07-25 15:10:29 +0300
commit02a01951e5bc668873c7d9660b63bf929d7eb27f (patch)
treee304f0f0d6b1b5f1ee95e8d82b915762a44a5635
downloadaur-02a01951e5bc668873c7d9660b63bf929d7eb27f.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1afb9e97181e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = code2pdf-git
+ pkgdesc = Convert various source codes into pdf file with custom features
+ pkgver = r67.e753616
+ pkgrel = 1
+ url = https://github.com/tushar-rishav/code2pdf
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = git
+ depends = python-pyqt5
+ depends = python-pygments
+ provides = code2pdf
+ conflicts = code2pdf
+ source = code2pdf::git+https://github.com/tushar-rishav/code2pdf
+ sha256sums = SKIP
+
+pkgname = code2pdf-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9dc7fbd3816
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=code2pdf-git
+pkgver=r67.e753616
+pkgrel=1
+pkgdesc="Convert various source codes into pdf file with custom features"
+arch=('any')
+url='https://github.com/tushar-rishav/code2pdf'
+license=('MIT')
+provides=('code2pdf')
+conflicts=('code2pdf')
+depends=('python-pyqt5'
+ 'python-pygments')
+makedepends=('python-setuptools' 'git')
+source=("code2pdf::git+${url}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd code2pdf
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd code2pdf
+ sed -i "s|unittest2||" requirements.txt
+}
+
+build() {
+ cd code2pdf
+ python setup.py build
+}
+
+package() {
+ cd code2pdf
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+} \ No newline at end of file