summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarius Lindvall2019-11-03 17:53:42 +0100
committerMarius Lindvall2019-11-03 17:53:42 +0100
commit64f1f4ac57b52f9263044386ba8614047a1dc6d8 (patch)
tree67bc668a41083911b50798a6713249f90b7e9c3e
downloadaur-64f1f4ac57b52f9263044386ba8614047a1dc6d8.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26efba7f62d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = codecept-bin
+ pkgdesc = The Codeception PHP testing framework (PHP 7 Phar version)
+ pkgver = 3.1.2
+ pkgrel = 1
+ url = https://codeception.com/
+ arch = any
+ license = MIT
+ depends = php>=7
+ source = https://codeception.com/releases/3.1.2/codecept.phar
+ source = https://raw.githubusercontent.com/Codeception/Codeception/3.1/LICENSE
+ sha256sums = 8ebed51fea351193b9f7e0b738695be8dd4d5b1dd076731ea5d274eec73087bd
+ sha256sums = a170b2c91593ab8e55624afcd6b392d8df3e9e914105b1f1e9ea8b8b73aee16f
+
+pkgname = codecept-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d34a4b0b6c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Marius Lindvall <(firstname) {cat} varden {dog} info>
+
+_version='3.1.2'
+_sha256='8ebed51fea351193b9f7e0b738695be8dd4d5b1dd076731ea5d274eec73087bd'
+
+pkgname=codecept-bin
+pkgver=${_version}
+pkgrel=1
+pkgdesc='The Codeception PHP testing framework (PHP 7 Phar version)'
+
+url='https://codeception.com/'
+arch=('any')
+license=('MIT')
+
+depends=('php>=7')
+optdepends=()
+conflicts=()
+source=("https://codeception.com/releases/${_version}/codecept.phar"
+ "https://raw.githubusercontent.com/Codeception/Codeception/3.1/LICENSE")
+sha256sums=("${_sha256}"
+ "a170b2c91593ab8e55624afcd6b392d8df3e9e914105b1f1e9ea8b8b73aee16f")
+
+pkgver() {
+ echo ${_version}
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm 755 "codecept.phar" "$pkgdir/usr/bin/codecept"
+ install -Dm 644 "LICENSE" "$pkgdir/usr/share/licenses/codecept-bin/LICENSE"
+}