summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordrzee2021-06-30 09:15:18 +0000
committerdrzee2021-06-30 09:15:18 +0000
commita616b31e820b681f637dce8792967472e9f5f7d2 (patch)
tree057826f02bebf0ff5194aece0471409b1adb427b
parentfd7df2499292ce1b08c11601554e7aeb28ce7be1 (diff)
downloadaur-a616b31e820b681f637dce8792967472e9f5f7d2.tar.gz
PKGBUILD to install version 1.3.2_1902 of AWS Codedeploy Agent
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0bde3e8e532a..f0e3dd0f74cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = codedeploy-agent
pkgdesc = AWS CodeDeploy is a deployment service that enables developers to automate the deployment of applications to instances and to update the applications as required.
- pkgver = 1.0_1.1458
+ pkgver = 1.3.2_1902
pkgrel = 1
url = https://aws.amazon.com/documentation/codedeploy/
- arch = i686
arch = x86_64
license = APACHE
- depends = ruby
- source = https://aws-codedeploy-eu-west-1.s3-eu-west-1.amazonaws.com/releases/codedeploy-agent_1.0-1.1458_all.deb
- md5sums = 78540a9e2fa0f79820a3b2b7ca998e45
+ depends = ruby2.7
+ depends = systemd
+ source = https://aws-codedeploy-eu-west-1.s3-eu-west-1.amazonaws.com/releases/codedeploy-agent_1.3.2-1902_all.deb
+ md5sums = 4a2697e9e3c022313705497caa197327
pkgname = codedeploy-agent
-
diff --git a/PKGBUILD b/PKGBUILD
index 8dd2ca4133b8..eab70d57cfb9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,25 @@
-# Maintainer: JUXT <info@juxt.pro>
+# Maintainer: drzee <info@drzee.net>
+# Contributor: JUXT <info@juxt.pro>
# Contributor: James Conroy-Finn <james@invetica.co.uk>
pkgname=codedeploy-agent
-pkgver=1.0_1.1458
+pkgver=1.3.2_1902
pkgrel=1
pkgdesc="AWS CodeDeploy is a deployment service that enables developers to automate the deployment of applications to instances and to update the applications as required."
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://aws.amazon.com/documentation/codedeploy/"
license=('APACHE')
groups=()
-depends=('ruby')
+depends=('ruby2.7' 'systemd')
source=(https://aws-codedeploy-eu-west-1.s3-eu-west-1.amazonaws.com/releases/${pkgname}_${pkgver//_/-}_all.deb)
-md5sums=('78540a9e2fa0f79820a3b2b7ca998e45')
+md5sums=('4a2697e9e3c022313705497caa197327')
noextract=()
prepare() {
cd "$srcdir"
tar -xf data.tar.gz
+
+ sed -i 's/\/opt\/codedeploy-agent\/bin\/codedeploy-agent/\/usr\/bin\/ruby*2.7 \/opt\/codedeploy-agent\/lib\/codedeploy-agent.rb/' etc/init.d/codedeploy-agent.service
+ sed -i '/^#!\/usr\/bin\/env ruby/a STDERR.puts \"Please use the systemctl utility to start,stop,restart or status the codedeploy-agent service. This script should not be used.\"\nexit(1)' opt/codedeploy-agent/bin/codedeploy-agent
}
package() {
@@ -31,6 +35,6 @@ package() {
install -Dm744 \
"$srcdir"/etc/init.d/codedeploy-agent.service \
"$pkgdir"/usr/lib/systemd/system/codedeploy-agent.service
+
}
-# vim:set ts=2 sw=2 et: