summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordrzee2021-08-02 14:52:51 +0000
committerdrzee2021-08-02 14:52:51 +0000
commit1ddb103b34fb29c3c36bfba8bd97ad36a5ae0382 (patch)
treeb4aa10f91e1213c661d8ec197042a6127d5ded6a
downloadaur-1ddb103b34fb29c3c36bfba8bd97ad36a5ae0382.tar.gz
PKGBUILD to install version 1.3.2_1902 of AWS Codedeploy Agent
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD38
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ff0d0e09f68
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = codedeploy-agent-bin
+ pkgdesc = AWS CodeDeploy is a deployment service that enables developers to automate the deployment of applications to instances and to update the applications as required.
+ pkgver = 1.3.2_1902
+ pkgrel = 1
+ url = https://aws.amazon.com/documentation/codedeploy/
+ arch = x86_64
+ license = APACHE
+ depends = ruby2.7
+ depends = systemd
+ source = https://aws-codedeploy-eu-west-1.s3-eu-west-1.amazonaws.com/releases/codedeploy-agent_1.3.2-1902_all.deb
+ md5sums = 4a2697e9e3c022313705497caa197327
+
+pkgname = codedeploy-agent-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5ef20b9e20e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: drzee <info@drzee.net>
+pkgname=codedeploy-agent-bin
+pkgver=1.3.2_1902
+pkgrel=1
+pkgdesc="AWS CodeDeploy is a deployment service that enables developers to automate the deployment of applications to instances and to update the applications as required."
+arch=('x86_64')
+url="https://aws.amazon.com/documentation/codedeploy/"
+license=('APACHE')
+groups=()
+depends=('ruby2.7' 'systemd')
+source=(https://aws-codedeploy-eu-west-1.s3-eu-west-1.amazonaws.com/releases/codedeploy-agent_${pkgver//_/-}_all.deb)
+md5sums=('4a2697e9e3c022313705497caa197327')
+noextract=()
+
+prepare() {
+ cd "$srcdir"
+ tar -xf data.tar.gz
+
+ sed -i 's/\/opt\/codedeploy-agent\/bin\/codedeploy-agent/\/usr\/bin\/ruby*2.7 \/opt\/codedeploy-agent\/lib\/codedeploy-agent.rb/' etc/init.d/codedeploy-agent.service
+ sed -i '/^#!\/usr\/bin\/env ruby/a STDERR.puts \"Please use the systemctl utility to start,stop,restart or status the codedeploy-agent service. This script should not be used.\"\nexit(1)' opt/codedeploy-agent/bin/codedeploy-agent
+}
+
+package() {
+ cd "$srcdir"
+
+ install -dm755 "$pkgdir"/opt/
+ cp -R "${srcdir}"/opt/codedeploy-agent "${pkgdir}/opt/"
+
+ install -Dm744 \
+ "$srcdir"/etc/codedeploy-agent/conf/codedeployagent.yml \
+ "$pkgdir"/etc/codedeploy-agent/conf/codedeployagent.yml
+
+ install -Dm644 \
+ "$srcdir"/etc/init.d/codedeploy-agent.service \
+ "$pkgdir"/usr/lib/systemd/system/codedeploy-agent.service
+
+}
+