summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordrzee2023-03-12 09:36:28 +0000
committerdrzee2023-03-12 09:36:28 +0000
commita9f5a093bf560b2c1a7cfdeff746281417f1b66b (patch)
tree1a47401ca253678177cde367c339f573e2514523
parent0848e07985468063b136578b3f63dc7f99e0bb25 (diff)
downloadaur-a9f5a093bf560b2c1a7cfdeff746281417f1b66b.tar.gz
PKGBUILD to install version 1.5.0_57 of AWS Codedeploy Agent
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b30a12dd1930..e826f0b4b69b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = codedeploy-agent-bin
pkgdesc = AWS CodeDeploy is a deployment service that enables developers to automate the deployment of applications to instances and to update the applications as required.
- pkgver = 1.4.1_2244
+ pkgver = 1.5.0_57
pkgrel = 1
url = https://aws.amazon.com/documentation/codedeploy/
arch = x86_64
license = APACHE
- depends = ruby2.7
+ depends = ruby
depends = systemd
provides = codedeploy-agent
conflicts = codedeploy-agent
- source = https://aws-codedeploy-eu-west-1.s3-eu-west-1.amazonaws.com/releases/codedeploy-agent_1.4.1-2244_all.deb
- md5sums = 4b5da7df2ed057fe1a9b1b72c216e8e2
+ source = https://aws-codedeploy-eu-west-1.s3-eu-west-1.amazonaws.com/releases/codedeploy-agent_1.5.0-57_all.deb
+ md5sums = a5a0a7a6568b357fdad1f2806ba12308
pkgname = codedeploy-agent-bin
diff --git a/PKGBUILD b/PKGBUILD
index c67fc904f725..47eed61d57c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,23 @@
# Maintainer: drzee <info@drzee.net>
pkgname=codedeploy-agent-bin
-pkgver=1.4.1_2244
+pkgver=1.5.0_57
pkgrel=1
pkgdesc="AWS CodeDeploy is a deployment service that enables developers to automate the deployment of applications to instances and to update the applications as required."
arch=('x86_64')
url="https://aws.amazon.com/documentation/codedeploy/"
license=('APACHE')
groups=()
-depends=('ruby2.7' 'systemd')
+depends=('ruby' 'systemd')
provides=("${pkgname%-bin}")
conflicts=("${pkgname%-bin}")
source=(https://aws-codedeploy-eu-west-1.s3-eu-west-1.amazonaws.com/releases/${pkgname%-bin}_${pkgver//_/-}_all.deb)
-md5sums=('4b5da7df2ed057fe1a9b1b72c216e8e2')
+md5sums=('a5a0a7a6568b357fdad1f2806ba12308')
noextract=()
prepare() {
cd "$srcdir"
tar -xf data.tar.gz
- sed -i 's/\/opt\/codedeploy-agent\/bin\/codedeploy-agent/\/usr\/bin\/ruby*2.7 \/opt\/codedeploy-agent\/lib\/codedeploy-agent.rb/' etc/init.d/codedeploy-agent.service
- sed -i '/^#!\/usr\/bin\/env ruby/a STDERR.puts \"Please use the systemctl utility to start,stop,restart or status the codedeploy-agent service. This script should not be used.\"\nexit(1)' opt/codedeploy-agent/bin/codedeploy-agent
}
package() {