summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorirmluity2023-12-13 02:59:42 +0800
committerirmluity2023-12-13 02:59:42 +0800
commit11966a54f66aadab1b4341e0ccf54654a1d54abe (patch)
treeef10e70decfa8390529aca7edc30b66f73df7772
downloadaur-11966a54f66aadab1b4341e0ccf54654a1d54abe.tar.gz
create package
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD27
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b062c477ecc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = codegpt-bin
+ pkgdesc = A CLI written in Go language that writes git commit messages or do a code review brief for you using ChatGPT AI (gpt-4, gpt-3.5-turbo model) and automatically installs a git prepare-commit-msg hook
+ pkgver = 0.7.0
+ pkgrel = 1
+ url = https://github.com/appleboy/CodeGPT
+ arch = x86_64
+ arch = aarch64
+ license = MIT
+ provides = codegpt
+ conflicts = codegpt-git
+ conflicts = codegpt
+ source = https://raw.githubusercontent.com/appleboy/CodeGPT/main/LICENSE
+ sha256sums = SKIP
+ source_x86_64 = codegpt-x86_64-0.7.0::https://github.com/appleboy/CodeGPT/releases/download/v0.7.0/CodeGPT-0.7.0-linux-amd64
+ sha256sums_x86_64 = d8200d8d4170fa76aedd9157b052852f082e622d33fa79dbdc387c85d23e8028
+ source_aarch64 = codegpt-x86_64-0.7.0::https://github.com/appleboy/CodeGPT/releases/download/v0.7.0/CodeGPT-0.7.0-linux-arm64
+ sha256sums_aarch64 = SKIP
+
+pkgname = codegpt-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3014070bbe79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: irmluity <45vw4yz8g@mozmail.com>
+
+_pkgname=codegpt
+pkgname=${_pkgname}-bin
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="A CLI written in Go language that writes git commit messages or do a code review brief for you using ChatGPT AI (gpt-4, gpt-3.5-turbo model) and automatically installs a git prepare-commit-msg hook"
+arch=('x86_64' 'aarch64')
+url='https://github.com/appleboy/CodeGPT'
+license=('MIT')
+provides=(${_pkgname})
+conflicts=(${_pkgname}-git ${_pkgname})
+source=(
+ "https://raw.githubusercontent.com/appleboy/CodeGPT/main/LICENSE"
+)
+source_x86_64=("${_pkgname}-$CARCH-${pkgver}::${url}/releases/download/v${pkgver}/CodeGPT-${pkgver}-linux-amd64")
+source_aarch64=("${_pkgname}-$CARCH-${pkgver}::${url}/releases/download/v${pkgver}/CodeGPT-${pkgver}-linux-arm64")
+sha256sums=(
+ "SKIP"
+)
+sha256sums_x86_64=('d8200d8d4170fa76aedd9157b052852f082e622d33fa79dbdc387c85d23e8028')
+sha256sums_aarch64=('SKIP')
+
+package() {
+ install -Dm755 "$srcdir/${_pkgname}-$CARCH-${pkgver}" "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}