summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUffe Jakobsen2021-02-08 13:27:19 +0100
committerUffe Jakobsen2021-02-08 18:31:31 +0100
commit14a773d9d6ed1d21b9fc67db14e74596b85a61ce (patch)
treec2613d63b44d3aefab845a9912c8c7ec3a5984f5
parent3fd1679d4ce8c49d2f15d4bdf5b925b80e48aa65 (diff)
downloadaur-14a773d9d6ed1d21b9fc67db14e74596b85a61ce.tar.gz
Use wxGTK3
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD23
2 files changed, 23 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index febcd50afaec..b6f7f06b8b61 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = codelite
pkgdesc = Cross platform C/C++/PHP and Node.js IDE written in C++
pkgver = 15.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.codelite.org/
arch = i686
arch = x86_64
@@ -9,25 +9,27 @@ pkgbase = codelite
makedepends = pkgconfig
makedepends = cmake
makedepends = clang
- depends = wxgtk2
+ depends = wxgtk3
depends = clang
depends = lldb
depends = libedit
depends = libssh
depends = mariadb-libs
depends = ncurses
- depends = xterm
depends = wget
depends = curl
+ depends = xterm
depends = python2
+ depends = python
optdepends = graphviz: callgraph visualization
optdepends = clang: compiler
optdepends = gcc: compiler
optdepends = gdb: debugger
optdepends = valgrind: debugger
+ noextract = wxgui.zip
source = codelite-15.0.tar.gz::https://github.com/eranif/codelite/archive/15.0.tar.gz
source = http://repos.codelite.org/wxCrafterLibs/wxgui.zip
- md5sums = e9d2519fa8077ca9f86b6b8fa9adf332
+ md5sums = 1c54744ab0c9b5732087687ab17ab49d
md5sums = 20f3428eb831c3ff2539a7228afaa3b4
pkgname = codelite
diff --git a/PKGBUILD b/PKGBUILD
index bcab9947fb22..509698144644 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,23 +21,34 @@
_pkgname=codelite
_pkgver=15.0
+#_commit=d19d21e702fa0de1c6649c8a63096f30ee90cf9d
+
+pkg_ident="${pkgver//_/-}"
+pkg_name_ver="${_pkgname}-${_pkgver//_/-}"
+
+#pkg_ident="${_commit}"
+#pkg_name_ver="${_pkgname}-${_commit}"
pkgname=${_pkgname}
pkgver=${_pkgver}
-pkgrel=1
+pkgrel=2
pkgdesc="Cross platform C/C++/PHP and Node.js IDE written in C++"
arch=('i686' 'x86_64')
url="http://www.codelite.org/"
license=('GPL')
makedepends=('pkgconfig' 'cmake' 'clang')
-depends=('wxgtk2'
+depends=(
+ 'wxgtk3'
+ #'wxgtk2' 'webkit2gtk'
'clang' 'lldb'
'libedit'
'libssh'
'mariadb-libs'
'ncurses'
- 'xterm' 'wget' 'curl'
+ 'wget' 'curl'
+ 'xterm'
'python2'
+ 'python'
)
optdepends=('graphviz: callgraph visualization'
'clang: compiler'
@@ -59,6 +70,7 @@ source=(
md5sums=('1c54744ab0c9b5732087687ab17ab49d'
'20f3428eb831c3ff2539a7228afaa3b4'
)
+noextract=('wxgui.zip')
#
#
@@ -74,8 +86,6 @@ md5sums=('1c54744ab0c9b5732087687ab17ab49d'
BUILD_DIR="_build"
-pkg_name_ver="${_pkgname}-${pkgver//_/-}"
-
#
#
@@ -98,8 +108,9 @@ CXXFLAGS="${CXXFLAGS} -fno-devirtualize"
export CXXFLAGS
# cmake find_package() will try env var WX_CONFIG as wx-config tool path before checking its builtin hardcoded naming conbinations for wx-config tool
+#WX_CONFIG="wx-config"
#WX_CONFIG="wx-config-gtk2"
-WX_CONFIG="wx-config"
+WX_CONFIG="wx-config-gtk3"
export WX_CONFIG
mkdir -p "${BUILD_DIR}"