summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUffe Jakobsen2015-06-22 23:54:58 +0200
committerUffe Jakobsen2015-06-22 23:54:58 +0200
commit1fb6d00b3b413786166464b084396ec4a4886e44 (patch)
treed2fbf0c6be2a768e1ad4065f3d64df879d6022a1
downloadaur-1fb6d00b3b413786166464b084396ec4a4886e44.tar.gz
Initial import
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD59
2 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..64adeeead2ce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = codelite
+ pkgdesc = Open-source, cross platform IDE for the C/C++ programming languages
+ pkgver = 8.0_1
+ pkgrel = 1
+ url = http://www.codelite.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = pkgconfig
+ makedepends = cmake
+ depends = wxgtk
+ depends = curl
+ depends = webkitgtk2
+ depends = libssh
+ depends = xterm
+ depends = python2
+ depends = libedit
+ depends = ncurses
+ depends = valgrind
+ depends = libmariadbclient
+ depends = lldb
+ optdepends = graphviz: callgraph visualization
+ noextract = wxgui.zip
+ source = https://github.com/eranif/codelite/archive/8.0-1.tar.gz
+ source = http://repos.codelite.org/wxCrafterLibs/wxgui.zip
+ md5sums = 1be80bf75f45243eebfd5d5c11f2d192
+ md5sums = 093485fcae62073ca8d0ba6ff3a5cb69
+
+pkgname = codelite
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6b85026574c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+#
+# codelite PKGBUILD
+#
+# Maintainer: Uffe Jakobsen <uffe@uffe.org>
+#
+# Contributor: Miguel Revilla <yo@miguelrevilla.com>
+# Contributor: nem <nem@ikitten.co.uk>
+# Contributor: agvares <agvares13@gmail.com>
+# Contributor: p2k <Patrick.Schneider@uni-ulm.de>
+# Contributor: Uffe Jakobsen <uffe@uffe.org>
+#
+
+pkgname=codelite
+pkgver=8.0_1
+pkgrel=1
+pkgdesc="Open-source, cross platform IDE for the C/C++ programming languages"
+arch=('i686' 'x86_64')
+url="http://www.codelite.org/"
+license=('GPL')
+depends=('wxgtk' 'curl' 'webkitgtk2' 'libssh' 'xterm' 'python2' 'libedit' 'ncurses' 'valgrind' 'libmariadbclient' 'lldb')
+makedepends=('pkgconfig' 'cmake')
+optdepends=('graphviz: callgraph visualization')
+
+source=(https://github.com/eranif/${pkgname}/archive/${pkgver//_/-}.tar.gz
+ http://repos.codelite.org/wxCrafterLibs/wxgui.zip)
+
+md5sums=('1be80bf75f45243eebfd5d5c11f2d192'
+ '093485fcae62073ca8d0ba6ff3a5cb69')
+
+#if [[ "$CARCH" == 'i686' ]]; then
+# source+=(http://repos.codelite.org/wxCrafterLibs/ArchLinux/32/wxCrafter.so)
+# md5sums+=('cd3e71e8187ce586031df070caed6c85')
+#elif [[ "$CARCH" == 'x86_64' ]]; then
+# source+=(http://repos.codelite.org/wxCrafterLibs/ArchLinux/64/wxCrafter.so)
+# md5sums+=('6fcd2f0fada5fc401d0bcd62cd5452bb')
+#fi
+
+noextract=('wxgui.zip')
+
+pkg_name_ver="${pkgname}-${pkgver//_/-}"
+
+build() {
+ cd "${srcdir}/${pkg_name_ver}"
+
+ CXXFLAGS="${CXXFLAGS} -fno-devirtualize"
+
+ mkdir -p build
+ cd build
+ cmake -G "Unix Makefiles" -DCMAKE_BUILD_TYPE=Release -DENABLE_CLANG=1 -DENABLE_LLDB=1 -DWITH_MYSQL=1 -DCMAKE_INSTALL_LIBDIR=lib ..
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkg_name_ver}/build"
+ make -j1 DESTDIR="${pkgdir}" install
+# install -m 755 -D "${srcdir}/wxCrafter.so" "${pkgdir}/usr/lib/codelite/wxCrafter.so"
+ install -m 644 -D "${srcdir}/wxgui.zip" "${pkgdir}/usr/share/codelite/wxgui.zip"
+ install -m 644 -D "${srcdir}/${pkg_name_ver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}